P. 1
Panduan-Access-2007

Panduan-Access-2007

|Views: 108|Likes:
Panduan Access 2007 untuk Pembelajaran
Panduan Access 2007 untuk Pembelajaran

More info:

Published by: Tri Kurnialis Tak Bersenjata on Feb 16, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

03/26/2013

pdf

text

original

Singkat-Padat-Jelas

Diktat

Disusun oleh:

Pengantar
Salam pendidikan.... Puji syukur ke hadirat Tuhan Yang Maha Esa, karena Dia senantiasa memberikan nikmatNya, sehingga penyusunan diktat Microsoft Access 2007 untuk mata pelajaran KKPI SMK kelas XI semua jurusan ini telah selesai. Diktat ini disusun guna memberikan bahan acuan pendamping belajar dan praktikum Ketrampilan Komputer dan Pengelolaan Informasi di Laboratorium Komputer SMK Yos Sudarso Kawunganten. Dalam hal ini diktat ini disusun berdasarkan kurikulum SMK khususnya pada mata pelajaran KKPI. Adapun perinciannya sebagai berikut : Standar Kompetensi : Mengoperasikan Sistem Operasi Software. Kompetensi Dasar : 1. Mengoperasikan Software Aplikasi Basis Data. 2. Melakukan Entry Data Aplikasi dengan Keyboard. 3. Melakukan Update dan Delete Data dengan Utilitas Aplikasi. Akhirnya kami mengucapkan terima kasih kepada semua pembaca yang telah meluangkan waktu membaca diktat ini. Semoga bermanfaat. Cilacap, Februari 2011 Penulis

KD-1
A.

: MENGOPERASIKAN SOFTWARE APLIKSI BASIS DATA
PENGENALAN SOFTWARE BASIS DATA (DATABASE) 1. Pengertian Database Dalam kehidupan sehari-hari, kita tidak akan bisa lepas dari data. Misalnya data tentang peserta didik, nilai, harga, makanan, dan lain-lain. Agar data menjadi suatu informasi yang bermanfaat bagi orang yang membacanya, maka data harus diorganisasikan dan diolah dalam suatu file database. Untuk pengorganisasian dan pengolahan data dengan komputer dibutuhkan suatu sistem manajemen database (DBMS). Dengan DBMS, kita dapat menambah, mengubah, menghapus, dan mengurutkan data sesuai dengan urutan yang sesuai dengan yang diinginkan serta membuat laporan bagi data tersebut. Database atau biasa dikenal dengan basis data adalah kumpulan data yang terhubung dengan suatu objek, topik, atau tujuan khusus tertentu. Contoh database antara lain : buku telepon, buku kamus, katalog buku diperpustakaaan, dan lain-lain. 2. Mengenal Microsoft Access 2007 Microsoft Access 2007 atau lebih dikenal dengan sebutan Access 2007 merupakan salah satu perangkat lunak yang diperuntukkan untuk mengolah database di bawah system Windows. Dengan menggunakan Microsoft Acces 2007 Anda dapat merancang, membuat, dan mengolah database dengan mudah dan cepat. Banyak kemudahan yang akan diperoleh jika bekerja dengan microsoft Access 2007 diantaranya dapat melakukan proses penyortiran pengaturan data, pembuatan label data serta laporan pembuatan data kegiatan sehari-hari misalnya untuk menampung daftar pelanggan, pendataan data karyawan, dan lain sebagainya. 3. Database Dalam Access 2007 Di dalam mengolah database, Access 2007 memiliki sarana atau objek yang dapat mempermudah dalam membangun sebuah database. Adapun objekobjek tersebut antara lain :
Tabel 1.1 Objek dalam Access 2007

Objek Table Query Form

Report

Kegunaan Merupakan tempat atau sarana untuk penyimpanan data Digunakan untuk menyaring data dengan berbagai kriteria dan urutan yang diinginkan Digunakan untuk memasukkan dan mengubah data atau informasi yang ada didalam suatu database dengan menggunakan tampilan formulir Digunakan untuk menampilkan atau mencetak data atau informasi dalam bentuk laporan

Ada beberapa istilah yang harus diketahui pada saat bekerja dalam lingkungan Access 2007 yaitu : Diktat Microsoft Access 2007 | 1

a. Table adalah sekumpulan data yang memiliki topik tertentu. Tabel mengatur data di dalamnya dalam bentuk kolom (field) dan baris (record). b. Field adalah tempat atau dimana data atau informasi dalam kelompok yang sama atau sejenis dimasukkan. Field umumnya tersimpan dalam bentuk kolom secara vertikal pada tabel. c. Record merupakan data lengkap dalam jumlah tunggal yang biasanya tersimpan dalam bentuk baris secara horizontal pada tabel.

Record

Field

Gambar 1.3 Contoh tampilah field dan record

4. Memulai Microsoft Access 2007 Untuk menjalankan Microsoft Access 2007, ikuti langkah sebagai berikut : klik Start pilih All Programs  pilih Microsoft Office  pilih dan klik Microsoft Office Access 2007.

Gambar 1.1 Memulai Microsoft Access 2007

Sehingga dilayar tampak kotak dialog Microsoft Access seperti berikut :

Gambar 1.2 Tampilan awal Access 2007

Diktat Microsoft Access 2007 | 2

Pada tampilan awal tersebut, klik salah satu pilihan berikut : 1) Blank Database  jika ingin membuat sebuah database baru yang masih kosong. Ketik nama filenya pada kotak dialog yang muncul disebelah kanan Access 2007. 2) Feature Online Template  jika ingin membuat sebuah database dengan menggunakan template yang disediakan oleh Windows Sharepoints Service Site. Klik Create untuk pilihan Blank Database atau klik Download untuk pilihan yang ada di Feature Online Templates. 5. Membuat Database Baru Untuk membuat sebuah database baru, langkah-langkahnya sebagai berikut : a. Pada tampilan awal pilih Blank Database atau bisa juga memilih New  Blank database pada bagian Microsoft Office Button. b. Setelah muncul dialog untuk memasukkan nama file database, isikan alamat beserta nama file database secara manual atau bisa mengklik tombol folder untuk menyimpan secara otomatis. c. Klik tombol Create untuk membuat sebuah database atau tombol Cancel untuk membatalkan proses pembuatan file database.
Gambar 1.4 Tampilan dialog blank database

6. Membuka File Database Untuk membuka file database dapat dilakukan dengan cara : a. Klik Office Button lalu klik Open. b. Di dalam daftar folder, cari folder atau alamat tempat tersimpannya file database. c. Bila sudah menemukan file database yang diinginkan, pilih salah satu langkah berikut : 1. Double klik file database untuk membukanya. 2. Pilih file database yang diinginkan lalu klik tombol Open untuk membukanya. 7. Menutup File Database yang Aktif Untuk menutup database yang sedang aktif, langkah-langkahnya sebagai berikut : a. Klik Office Button . b. Klik tombol Close Database (Ctrl+W). Diktat Microsoft Access 2007 | 3

8. Mengakhiri Access 2007 Untuk mengakhiri atau menutup Access 2007, Anda tinggal mengklik tombol Close (X) dari jendela Access yang sedang aktif atau tekan secara bersamaan tombol Alt dan F4 pada keyboard. B. BEKERJA DENGAN APLIKASI MICROSOFT ACCESS 2007 Membuat dan Memodifikasi Tabel pada Access 2007 1. Pengertian Tabel Selain objek utama sebuah database, sebuah tabel bisa dipandang sebagai kumpulan data tentang topik yang khusus, seperti data peserta didik, data guru, dan lain sebagainya. Dengan menggunakan tabel terpisah masing-masing topik berarti kita sudah melakukan suatu tindakan yang amat berguna bagi database. Sebab dengan demikian akan mengurangi kesalahan terutama di dalam memasukkan data. Tabel terdiri dari dua bagian utama yaitu kolom (field) dan baris (record). Struktur tabel pada Access 2007 yang terdiri dari field-field yang mengelompokkan data ke dalam kelompok-kelompok yang berjenis sama. Di dalam tabel perlu menentukan jenis dan ukuran yang dibutuhkan sesuai dengan besarnya data yang akan dimasukkan. Berikut ini adalah jenis data yang disediakan oleh Access 2007 dan sering digunakan untuk membentuk sebuah tabel :
Tabel 2.1 Jenis data pada Access 2007

Jenis Data Text Memo

Number Date/Time Currency AutoNumber Yes/No Ole Object

Hyperlink

Lookup Wizard

Keterangan Untuk pemasukan huruf, angka, simbol, dan spasi. Jumlah karakter maksimum 255 karakter. Untuk pemasukan teks panjang dan berguna untuk memberikan keterangan dan lain-lain. Jumlah karakter maksimum 64.000 karakter. Untuk pemasukan data yang berjenis numerik maupun angka biasa. Bisa menampung hingga 255 karakter. Untuk menampung data waktu yaitu hari, tanggal, jam, menit. Untuk menampung data yang berjenis angka dengan format mata uang. Untuk mengisi field dengan nomor urut otomatis untuk masing-masing record dan nilainya tidak dapat diubah. Untuk menampung dua macam keadaan, Yes (ya) atau No (tidak) Untuk menampung objek yang berasal dari aplikasi lain dari proses OLE (Object Linking dan Embeddeing). Ukuran yang disediakan bisa mencapai satu GB. Merupakan kombinasi teks dan angka. Dapat diisi dengan alamat hyperlink agar bisa terkait dengan data yang tersimpan di lokasi tertentu. Memungkinkan Anda untuk membuat sebuah daftar pilihan yang berguna untuk pemilihan nilai dari tabel atau daftar. Diktat Microsoft Access 2007 | 4

2. Merancang Tabel Untuk membuat sebuah tabel baru, Anda dapat merancang dan membuat dengan langkah-langkah berikut ini :  Buka file database yang Anda inginkan atau buat sebuah database baru.  Ketika pertama kali database dibuat atau dimunculkan, maka secara otomatis akan muncul tampilan table1 dalam format Datasheet View. Walaupun begitu tidak disarankan merancang tabel dalam format datasheet view karena struktur dan jenis data tabel tidak terlalu terlihat. Oleh karena itu, pilih tab Datasheet  klik View  pilih Design View. Gambar 2.1  Maka secara otomatis Anda akan diminta memasukkan nama Ribbon view tabel. Ketikkan nama Peserta Didik. Lalu tekan OK.

Gambar 2.2 Tampilan simpan tabel

 Setelah itu akan muncul tampilan Design View dengan nama field yang secara otomatis terisi dengan ID. Hapus nama field tersebut.

Gambar 2.3 Tampilan awal design view

 Pada jendela design view isikan struktur tabel seperti di gambar berikut ini :

Gambar 2.4 Struktur tabel peserta didik

Diktat Microsoft Access 2007 | 5

 Pada Field Name, ketikkan nama field sesuai dengan struktur tabel di atas. Maksimum nama field 64 karakter dan tidak boleh mengandung titik (.).  Pada Data Type pilih jenis data sesuai struktur di atas.  Pada Description isikan keterangan dari nama field beserta properties yang diubah (sebagai contoh field size dari nama field yang ada). Isikan sesuai dengan perubahan yang Anda buat pada field di sebelahnya.  Pada saat mengisi nama field, Anda perlu menentukan nama field mana yang akan dijadikan Primary Key. Misalnya nama field NIS (posisikan kursor dalam keadaan aktif di field name NIS) dijadikan sebagai primary key (biasanya field yang dijadikan primary key harus mengandung nilai yang UNIQUE dan bisa dijadikan acuan untuk nilai yang lain), maka langkahnya sebagai berikut : 1. Pilih field yang akan dijadikan primary key contoh : NIS. 2. Pilih tab Design  klik Primary Key.

Gambar 2.5 Ribbon primary key

 Pada kotak Field Properties, terdapat beberapa pilihan yaitu :
Tabel 2.2 Pilihan field properties

Perintah Field Size Format Input Mask Decimal Place Caption Default Value

Validation Rule Validation Text

Required Allow Zero Length Indexed

Kegunaan Untuk menentukan jumlah maksimum karakter yang diisikan pada field tersebut Untuk menentukan format tampilan data Untuk menentukan standarisasi tampilan pada saat memasukkan data di layar Untuk menentukan jumlah angka desimal yang diinginkan Untuk menempatkan keterangan sebagai judul kolom, form, atau laporan Untuk menempatkan data yang sering digunakan atau data yang sama pada field tertentu agar selalu ditampilkan kembali Untuk mengontrol atau membatasi sampai sejauh mana data yang Anda masukkan dalam sebuah database Untuk menampilkan keterangan atau pesan apabila data yang dimasukkan tidak sesuai dengan batasan yang ada di validation rule Untuk mengatur apakah field ini boleh dikosongkan atau tidak pada saat pengisian record Untuk mendefinisikan nilai blank (““) yang membedakan dengan nilai null Untuk membuat index pada field yang disorot

 Setelah selesai membuat struktur tabel di atas, simpan struktur tabel tersebut. Diktat Microsoft Access 2007 | 6

3. Merancang Tabel dengan Entering Data Untuk membuat sebuah tabel baru, pengguna juga bisa menggunakan fasilitas Entering Data dengan langkah-langkah berikut ini :  Buka file database yang diinginkan, kemudian pada tab Create kilk Table.

Gambar 2.6 Tampilan tab create

 Secara otomatis akan timbul tampilan seperti berikut :

Gambar 2.7 Tampilan jendela kerja tabel kosong

 Untuk menggantikan nama field tersebut di atas, klik kanan kolom yang akan diganti. Kemudian pilih Rename Column. Untuk selanjutnya lakukan untuk menambah kolom dengan cara menekan tombol tab sehingga tampilannya seperti berikut :

Gambar 2.8 Jendela kerja tabel kosong setelah nama fieldnya diubah

4. Modifikasi Tabel Setelah merancang tabel terkadang ada suatu perubahan yang mengharuskan modifikasi pada tabel yang dibuat. Diktat Microsoft Access 2007 | 7

Misalkan mengganti field, menambah atau menyisipkan field, ataupun menghapus field tersebut. Adapun bentuk modifikasi tabelnya adalah sebagai berikut : a. Memperbaiki nama field (Field Name) b. Memperbaiki jenis data (Data Type) c. Memindahkan letak field d. Menyisipkan/menambah field e. Menghapus field a) Memperbaiki Nama Field (Field Name) Untuk memperbaiki nama field caranya sebagai berikut : a. Buka field tabel yang ingin diperbaiki, misalkan tabel peserta didik. b. Pilih nama field yang akan diganti kemudian ketikkan nama field baru. Contoh ganti nama field TANGGAL LAHIR dengan TGL LAHIR.

Gambar 2.9 Tampilan field tgl lahir

b) Memperbaiki Jenis Data (Data Type) Untuk memperbaiki jenis data, caranya sebagai berikut : a. Misalkan akan mengganti data type Text dengan Number untuk field JK. b. Aktifkan atau tempatkan kursor pada field JK, lalu klik di bagian Data Type c. Pilih tipe data Number. d. Simpan kembali struktur tabel tersebut.

Gambar 2.10 Tampilan jenis data JK

5. Memindahkan Letak Field Cara memindahkan letak field adalah sebagai berikut :  Misalkan pindahkan letak field KELAS dan letakkan setelah field JK. Diktat Microsoft Access 2007 | 8

 Aktifkan kursor pada field KELAS lalu klik.  Tekan dan geser (drag dan drop) field KELAS lalu arahkan ke field JK lalu lepas mousenya.  Pindahkan kembali field KELAS ke tempatnya semula.  Simpan kembali struktur tabel tersebut.

Gambar 2.11 Tampilan field kelas setelah dipindahkan

c) Menyisipkan/Menambah Field Cara menambah atau menyisipkan field adalah sebagai berikut :  Misal sisipkan field JURUSAN, dengan data typenya text, sedangkan lebarnya 20 dan letakknya setelah field KELAS.  Aktifkan/tempatkan kursor pada field setelah KELAS lalu klik.  Klik Insert Rows di tab Design atau klik kanan lalu pilih Insert Rows.  Lalu ketik nama field JURUSAN.  Simpan kembali struktur tabel tersebut.

Gambar 2.12 Struktur tabel setelah insert

d) Menghapus Field Cara menghapus field adalah sebagai berikut :  Misal hapus field JK.  Aktifkan/tempatkan kursor pada field JK lalu klik.  Klik Delete Rows di tab Design atau klik kanan lalu pilih Delete Rows.

Gambar 2.13 Struktur tabel setelah JK dihapus

Diktat Microsoft Access 2007 | 9

6. Mengubah Ukuran Data Seperti halnya field, data/record pun dapat diubah ukurannya, baik lebar kolom maupun tinggi baris data. a. Mengubah lebar kolom  Aktifkan kolom yang akan diubah lebar kolomnya.  Masuk ke tab Home.  Klik tombol More yang ada di bagian record lalu pilih Column Width atau klik kanan pilih Column Width sengga muncul :

Gambar 2.14 Tampilan column width

Gambar 2.15 Isian column width

 Pada kotak isian Column Width, isikan angkanya.  Klik OK. Keterangan ; Standard Width : Mengubah lebar kolom ke lebar kolom semula (standar). Best Fit : Mengubah lebar kolom sesuai dengan banyaknya karakter pada kolom data. 7. Mengubah tinggi baris  Aktifkan baris yang akan diubah tinggi barisnya.  Masuk ke tab Home.  Klik tombol More yang ada dibagian Records lalu pilih Row Height atau klik kanan pilih Row Height sehingga muncul :

Gambar 2.15 Isian row width

 Pada kotak isian Row Height, isikan angkanya.  Klik OK. Diktat Microsoft Access 2007 | 10

8. Menyisipkan/Menambah Data Penyisipan data/record berarti penambahan jumlah data yang telah ada. Data baru akan selalu ditampilkan setelah data terakhir. Untuk menyisipkan data/record langkahnya sebagai berikut :  Pilih dan klik baris data/record yang akan disisipkan.  Masuk ke tab Home.  Klik tombol New yang ada pada bagian record atau klik kanan lalu pilih New Record. 9. Menghapus Data Untuk menghapus data yang tidak diperlukan lagi, langkahnya sebagai berikut :  Pilih dan klik baris data/record yang akan dihapus.  Masuk ke tab Home.  Klik tombol Delete yang ada pada bagian Records atau klik kanan lalu pilih Delete Record. 10. Mengurutkan Data (Data Sort) Anda dapat mengurutkan data dengan cara re;atif cepat dan singkat, baik diurutkan berdasarkan Ascending (menaik) maupun Descending (menurun). Misal urutkan data berdasarkan NAMA secara Ascending, langkahnya sebagai berikut :  Pilih dan klik kolom NAMA sehingga isi kolom NAMA akan terseleksi.  Masuk ke tab Home.  Klik tombol Ascending pada bagian Sort & Filter. Untuk mengurutkan data secara Descending langkahnya hampir sama dengan Ascending, hanya tombolnya yang berbeda. 11. Mencetak Tabel Untuk mencetak tabel yang telah dibuat, langkah-langkahnya sebagai berikut :  Buka basis data tempat tabel yang akan dicetak berada.  Kemudian pilih tabel yang akan dicetak dengan cara mengkliknya, kemudia klik Office Button  Print. Selanjutnya muncul jendela Print. Anda bisa melakukan pengaturan pada jendela Print. Selanjutnya OK.  Tabel hasil cetakan akan terlihat seperti berikut.

Gambar 2.16 Hasil mencetak tabel

Diktat Microsoft Access 2007 | 11

KD-2

: MELAKUKAN ENTRY DATA APLIKASI DENGAN MENGGUNAKAN KEYBOARD

A. PENGENALAN KEYBOARD Keyboard merupakan salah satu perangkat masukan yang berfungsi untuk memasukkan perintah-perintah ke dalam komputer. Selain itu, kewyboard juga digunakan untuk memasukkan data, baik berupa huruf maupun simbol. 1. Jenis-jenis Keyboard Secara fisik keyboard dibedakan menjadi 4, yaitu :  Keyboard Serial  Keyboard PS/2  Keyboard USB  Keyboard Wireless 2. Struktur dan Fungsi Tombol Keyboard Struktur dan fungsi tombol keyboard telah dibahas di kelas X. Berikut diingatkan lagi beberapaa tombolfungsi pada keyboard.
Tabel 2.1 Kelompok tombol pada keyboard

Tombol Modifikasi Tombol Pengunci Tombol Navigasi Tombol Edit Tombol Ketik Alt + F4 Ctrl + Alt + Del F1 Esc (Escape) Arah (tanda panah) Enter Delete Home End

Ctrl, Shift, dan Alt Caps Lock, Num Lock, dan Scroll Lock Up, Down, Right, Left, Page Up/Page Down, Home/End Enter, Backspace, Insert, Delete, Tab, dan Space Bar Semua tombol yang belum disebutkan di atas Berfungsi sebagai jalan pintas (shortcut) untuk menutup program aplikasi yang sedang aktif. Berfungsi untuk menampilkan task manager. Berfungsi untuk menampilkan menu bantuan. Berfungsi untuk membatalkan pelaksanaan perintah. Berfungsi untuk mengarahkan kursor. Berfungsi untuk mengeksekusi perintah. Berfungsi untuk menghapus huruf yang ada di sebelah kanan kursor Berfungsi untuk memindahkan kursor ke awal baris. Berfungsi untuk memindahkan kursor ke akhir baris.

Tabel 2.2 Beberapa fungsi dari tombol pada keyboard

B. MEMBUAT FORM 1. Membuat atau Merancang Form Form merupakan salah satu objek database yang digunakan untuk mempermudah Anda memasukkan data pada tabel, menampilkan data, mencari data, memperbaiki data dan mencetaknya. Dengan form, kita bisa membuat atau bahkan merancang form yang hanya memperlihatkan sebagian fielf dari sebuah tabel, atau bahkan menyertakan foto Anda maupun data siswa suatu sekolah yang datanya kita simpan. Tidak itu saja, dengan form kita bisa menampilkan recordrecord yang memenuhi kriteria tertentu. Diktat Microsoft Access 2007 | 12

2. Membuat Form dengan Fasilitas Form Wizard Access 2007 menyediakan fasilitas Form Wizard dimana dalam pembuatan formnya tidak perlu merancang lagi layout form maupun gaya (style) form. Kita cukup memilih bentuk yang sudah disediakan oleh Access 2007. Sebelum membuat form, terlebih dahulu buatlah file database dengan nama Database Pendidikan. Sedangkan nama file tabelnya yaitu Peserta Didik dengan struktur tabel sebagai berikut :

Gambar 2.1 Struktur tabel Peserta Didik

Untuk membuat form dengan fasilitas Form Wizard ikuti langkah berikut ini :  Buka tabel Peserta Didik  Klik tab Create.  Pada menu Forms klik tombol More Forms lalu pilih Form Wizard.  Pada form pertama pilih field-field yang akan ditampilkan pada formnya. Apabila ingin memilih salah satu field, anda bisa mengklik dua kali field yang diinginkan atau tinggal mengklik tombol >. Untuk memilih semua field klik tombol >>. Dalam kasus ini pilih semua field lalu klik Next.

Gambar 2.2 Form pemilihan field

 Pada form kedua pilih tampilan atau layout form yang diinginkan. Dalam hal ini ada empat pilihan yaitu :  Columnar  Tabular  Datasheet  Justified Pilih Columnar lalu klik Next.

Diktat Microsoft Access 2007 | 13

Gambar 2.3 Form pemilihan tampilan

 Pada form ketiga, anda bisa memilih style yang anda suka. Pilih Access 2007 lalu klik Next.

Gambar 2.4 Form pemilihan style

 Pada form keempat kita harus memasukkan nama dari form yang kita buat. Pada form tersebut, kita juga bisa memilih untuk membuka form atau memodifikasi tampilan form yang sudah dibuat. Masukkan form Peserta Didik pada isian nama form lalu pilih Open the form to view or enter information. Klik Finish untuk melihat hasil formnya.

Gambar 2.5 Form isian nama

 Maka tampilan formnya adalah sebagai berikut : Diktat Microsoft Access 2007 | 14

Gambar 2.6 Tampilan form peserta didik

 Di bawah ini tampilan form, ada sebuah bar yang dapat digunakan untuk berpindah ke record selanjutnya maupun mencari record yang diinginkan.  Setelah itu anda dapat mengisikan data baru dengan mengklik tombol .

3. Mengubah Desain Form Jika form yang dibuat ingin dimodifikasi sehingga menghasilkan form yang menarik, anda harus melakukan perubahan. untuk melakukan perubahan tersebut, anda bisa mulai melakukan pengaturan ulang pada form tersebut. Langkahlangkahnya adalah sebagai berikut :  Buka kembali Database Pendidikan. Pada jendela Navigation Pane, klik kanan form Peserta Didik dan pilih Design View.

Gambar 2.7 Tampilan mengubah form

Diktat Microsoft Access 2007 | 15

 Selanjutnya muncul tampilan berikut.

Gambar 2.8 Desain form siap diubah

 Sekarang coba anda merubah judul pada Form Header. Hal ini dapat dilakukan dengan meletakkan kursor di Form Header dan kemudian ketiklah perubahan judul yang diinginkan. Misal judulnya diubah menjadi “Peserta Didik SMK Yos Sudarso Kawunganten”, hasilnya seperti terlihat pada gambar berikut.

Gambar 29 Mengubah judul form

 Setelah selesai melakukan perubahan klik tab Design  pada ribbon yang tampil pilih View  Form View. Maka terlihat hasilnya seperti pada gambar. Diktat Microsoft Access 2007 | 16

Gambar 2.9 Hasil perubahan desain form peserta didik

4. Menambahkan Fungsi Matematika pada Form Dalam bahasan menambahkan Fungsi Matematika ini kita akan menggunakan form Daftar Nilai yaitu menghitung Jumlah Nilai secara otomatis, langkahnya sebagai berikut :  Buka kembali tabel Daftar Nilai pada basis data Database Pendidikan. Musuk ke Design View tabel tersebut dan tampilkan field Jumlah Nilai dan Rata-rata. Keduanya memiliki tipe data Number.  Selanjutnya simpan perubahan tabel dengan menekan Ctrl + S. Buatlah kembali sebuah form baru dengan nama Penilaian yang menampilkan semua field yang telah ada. Buat form dengan menggunakan Form Wizard. Hasilnya dapat anda lihat seperti berikut :

Gambar 2.10 Penambahan Jumlah nilai dan rata-rata pada Penilaian

Untuk membuat rumus di kolom jumlah nilai dan rata-rata caranya adalah: anda masuk ke Design View dari Penilaian. Klik ganda textbox jumlah nilai. Jika anda mengklik dengan benar, maka akan muncul properties box Diktat Microsoft Access 2007 | 17

seperti pada gambar. Jika Control Source diklik, akan muncul tombol sebelah kanan kotak Jumlah Nilai.

di

Gambar 2.11 Properties box dari textbox

Jika tombol

diklik, anda akan memasuki Expression Builder.

Gambar 2.12 Expresion Builder

Ganti kotak dengan persamaan jumlah nilai yang sebelumnya telah diberikan, caranya :  Ketik tanda “=” (tanpa tanda “ “), kemudian klik ganda pada nilai yang akan dijumlah.  Klik sekali tanda tambah (+), lalu klik lagi nilai berikutnya yang akan dijumlah, dan seterusnya sampai semua nilai yang akan dihitung dimasukkan. Hasilnya dapat anda lihat seperti pada gambar. Setelah selesai memasukkan persamaan, klik OK.

Gambar 2.13 Expresion Builder telah diisi dengan persamaan jumlah nilai

Diktat Microsoft Access 2007 | 18

Kemudian akan diperoleh tampilan seperti berikut. Hal ini menunjukkan bahwa Control Source (sumber control) dari Text Box: jumlah nilai telah berubah.

Gambar 2.14 Control source dari text box

Jika telah berhasil mencapai langkah ini, simpan hasil kerja anda. Selanjutnya keluar dari Design View dan buka kembali form Penilaian. Maka akan diperoleh hasil seperti gambar berikut.

Gambar 2.15 Text box jumlah nilai telah menunjukkan data nilai total

5. Menambah Fungsi Seleksi pada Form Keterangan yang ditambahkan pada form Penilaian masih bersifat subjektif, sehingga perlu dibuat ukuran-ukuran yang jelas agar keterangan yang disampaikan memiliki makna. Sebagai contoh, jika seorang siswa mendapatkan nilai rata-rata di atas 65, maka siswa dinyatakan lulus, jika sebaliknya maka siswa tidak lulus, dapat juga diberi batasan, jika siswa mendapatkan nilai diatas atau sama dengan 85 maka siswa mendapatkan keterangan istimewa, sebaliknya siswa hanya mendapatkan nilai cukup. Untuk menyelesaikan kasus tersebut, Microsoft Access telah menyediakan fungsi seleksi yaitu fungsi IIf. Format dari fungsi ini adalah : IIf(Pernyataan, A, B) Maksud dari fungsi tersebut, jika pernyataan benar, maka yang diambil adalah nilai A, namun jika pernyataan salah, maka yang diambil adalah nilai B. Sekarang, untuk contoh kasus Database Pendidikan ini, kita buat syaratsyarat, sebagai berikut : a) Nilai rata-rata ≥ 85; keterangan = Istimewa b) Nilai rata-rata < 85; keterangan = Cukup Diktat Microsoft Access 2007 | 19

Kita berikan cukup dua syarat agar mudah bagi anda mempelajari fungsi seleksi ini. Langkah-langkahnya adalah sebagai berikut.  Buka kembali Design View dari form Penilaian. Kemudian klik ganda textbox Keterangan dan ubah Control Source melalui Expression Builder.

Gambar 2.16 Properties box dari text box: Keterangan

Ketikkan fungsi berikut di dalam Expression Builder. =IIf([RATA-RATA]>=85;"Istimewa";"Cukup")

Gambar 2.17 Mengubah control source dari text box: keterangan di expression builder

Perhatikan dengan baik penulisan fungsi seleksi, karena kesalahan kecil saja akan memyebabkan Microsoft Access tidak mengeksekusi perintah yang diberikan.  Penulisan harus diawali dengan tanda sama dengan (“=”).  Penulisan yang tepat adalah IIf. Walaupun demikian Microsoft Access tetap mengenali fungsi ini sekalipun ditulis dengan huruf kecil.  Perhatikan tanda kurung buka.  Jika yang ditampilkan pada textbox adalah kata (bukan angka), gunakan tanda kutip dua(“ “). Dalam hal ini kita gunakan kata “Istimewa” dan “Cukup”. Kedua kata ditulis lengkap dengan tanda kutip dua.  Jangan lupa meletakkan tanda kurung tutup! Klik OK, simpan hasil perubahan yang anda lakukan dengan menekan Ctrl+S.  Selanjutnya, buka kembali form Penilaian. Anda akan melihat bahwa keterangan siswa telah berubah.

Gambar 2.18 Textbox keterangan telah menunjukkan perubahan

Diktat Microsoft Access 2007 | 20

Setelah anda mampu membuat suatu program seleksi di Expression Builder, mungkin anda akan lebih tertantang membuat syarat-syarat yang lebih ketat. Misalnya, nilai 85 – 100 adalah istimewa, 70 – 84 adalah baik, 60 – 70 adalah kurang, sedangkan kurang dari 60 dapat diberi keterangan tidak lulus. Dapatkan anda melakukannya? 6. Entry Data pada Form dengan Menggunakan Keyboard Dalam hal ini, asumsikan bahwa anda sudah mempunyai sebuah basis data yang didalamnya sudah terdapat tabel dan form. Aturan yang ada di dalam sistem manajemen basis data menyebutkan bahwa untuk memasukkan (entry) data ke dalam suatu basis data sebaiknya dilakukan melalui suatu form. Selain mudah dan praktis, pengguna form dimaksudkan untuk menghindari adanya duplikasi data. Untuk entry data tersebut dapat dilakukan dengan menggunakan mouse atau keyboard. Tetapi dari kedua alat tersebut, penggunaan keyboard biasanya lebih dominan perannya. Sebelum anda mulai memasukkan data, anda harus mengenal beberapa fungsi tombol pada keyboard yang digunakan saat memasukkan data pada form.  Untuk berpindah dari field satu ke field yang lain anda dapat menekan tombol Enter, Tab, dan Arrow (panah).  Jika anda telah mengisikan data pada semua field dan akan pindah ke lembar form yang baru dapat menekan tombol Page Down atau tekan Enter pada field terakhir.  Jika kamu ingin kembali ke lembar form sebelumnya, anda dapat menekan tombol Page Up. Selanjutnya anda dapat mulai memasukkan data pada form, perhatikan langkah berikut :  Buka form yang telah dibuat, misalnya form Penilaian.  Setelah form terbuka, anda bisa mulai mengisikan data. Jika lembar form telah terisi anda harus mencari lembar form yang kosong dengan menekan   Page Down atau dengan menekan pada form. Selanjutnya isikan data sesuai yang diinginkan sampai sesasai. Setelah selesai melakukan input data jangan lupa untuk menyimpannya.

7. Memeriksa Hasil Entry Data Untuk memeriksa apakah data yang kamu masukkan sudah benar dan sudah tersimpan pada basis data, dapat dilakukan dengan berbagai cara. Salah satunya dengan melihat tabel yang menyimpan data tersebut. Sebagai contoh, sekarang akan dilihat data yang baru saja dimasukkan pada bagian sebelumnya. Caranya adalah sebagai berikut :  Buka tabel Penilaian. Tabel Penilaian mengalami beberapa penambahan data.

Gambar 2.19 Tabel Penilaian telah mengalami penambahan data

Diktat Microsoft Access 2007 | 21

Data yang baru dimasukkan ada pada baris ketiga, artinya data yang dimasukkan tersimpan. Anda bisa mengecek apakah datanya sudah benar atau belum. Anda juga bisa memeriksa hasil entry data dengan menggunakan form. Caranya adalah dengan membuka form Penilaian, kemudian kamu periksa record pada setiap lembar form dengan menggunakan tombol navigasi yang terdapat pada bagian bawah jendela form Penilaian.

Gambar 2.20 Memeriksa hasil entry data menggunakan form

Keterangan :  Tombol  Tombol digunakan untuk menuju ke record pertama. digunakan untuk menuju ke record sebelumnya.

 Kotak digunakan untuk menuliskan nomor record yang akan dipilih untuk ditampilkan.  Tombol  Tombol digunakan untuk menuju ke record berikutnya. digunakan untuk menuju ke rocord terakhir.

8. Mencetak Hasil Entry Data Ada baiknya yang sudah anda masukkan ke dalam basis data juga dicetak ke atas kertas agar anda mempunyai arsip data tersebut secara fisik. Langkah untuk mencetak sebagai berikut :  Tekan tombol office  Print atau Ctrl+P.  Klik All untuk mencetak semua data.  Untuk melakukan pengaturan jenis kertas, pewarnaan dan sebagainya, anda dapat menggunakan tombol Properties. Gambar 2.21 Mencetak hasil entry data  Tekan Enter atau klik OK jika sudah selesai. Diktat Microsoft Access 2007 | 22

KD-3

: MELAKUKAN UPDATE DAN DELETE DATA DENGAN UTILITAS APLIKASI

A. PERSIAPAN MENG-UPDATE DAN MEN-DELETE DATA Salah satu peristiwa yang selalu terjadi adalah perubahan. Kebutuhan dan minatmu dapat berubah seiring anda tumbuh dan berkembang. Sebuah informasi yang dahulu sangat penting bisa berubah menjadi tidak penting. Sementara, informasi yang semula dianggap tidak berguna sama sekali bisa berubah menjadi informasi berharga. Seiring meningkatnya jumlah informasi dalam bidang bisnis dan kehidupan sehari-hari, anda mungkin perlu menata atau mendistribusi ulang informasi tersebut. Oleh karena itu untuk mengantisipasi terjadinya perubahanperubahan pada data yang dimiliki, ada baiknya mempelajari bagaimana cara meng-update (mengubah) atau men-delete (menghapus) data pada basis data. 1. Memilih Field dan Record Anda harus memiliki data sebelum melakukan editing pada sebuah jendela datasheet. Untuk memilih data atau record pada sebuah jendela datasheet dapat dilakukan dengan beberapa cara, untuk lebih jelasnya lihat pada daftar dibawah ini : Pilihan Sebuah sel Beberapa sel Sebuah Kolom Beberapa Kolom Sebuah record Beberapa record Semua Record Perintah Klik pada posisi sel tersebut. Drag drop pointer pada sisi kiri sel tersebut sampai melintasi beberapa sel yang ingin dipilih. Klik pada pisisi selektor Kolom. Drag drop Pointer pada posisi selektor Kolom sesuai kebutuhan. Klik pada pisisi selektor baris. Drag drop Pointer pada posisi selektor baris sesuai dengan kebutuhan.  Klik tombol Select All pada selector baris.  Pilih perintah Select All Record dari menu Edit.  Tekan kombinasi tombol Ctrl + A pada keyboard.

2. Memindahkan Insertion Point Untuk memindahkan Insertion Point atau data Record dalam sebuah datasheet dapat menggunakan fasilitas yang ada diperintah Go To dari menu Edit, Panah atas, panah bawah, Page Up, Page Down atau menggunakan Vertikal scroll Bar. Selain itu Anda dapat juga memindahkan posisi Record Aktif dengan memilih tombol navigasi yang ada pada bagian bawah dari jendela datasheet sebuah tabel. Perhatikan tabel berikut :

Diktat Microsoft Access 2007 | 23

Pindah Ke Awal record Akhir record Record Sebelumnya Record berikutnya Record Baru Record tertentu First Record Last record

Perintah Klik

Previus Record Next Record New Record Atau tekan tombol F5 atau ketik nomor Record yang Anda inginkan dan lanjutkan dengan menekan tombol enter.

B. MENG-UPDATE (MENGUBAH) DATA Ada beberapa cara untuk melakukan update data pada suatu aplikasi basis data. Pada Microsoft Access, update data dapat dilakukan melalui tabel, query,dan form. Pada buku ini, update data akan dilakukan melalui tabel dan query. 1. Update Data Melalui Tabel Untuk meng-update data melalui tabel, bukalah tabel yang ingin diubah terlebih dahulu. Misalkan anda ingin meng-uodate data pada tabel “Peserta Didik” yang kita buat sebelumnya. Langkahnya sebagai berikut :  Buka basis data Database Pendidikan yang telah dubuat sebelumnya. Selanjutnya buka tabel Peserta Didik.  Anda bisa mulai meng-update data setelah muncul jendela berikut ini.

Gambar 3.1 Tabel Daftar

Misalkan data di-update dengan menambahkan dua record baru dengan siswa bernama Dian Sastro dan Nicolas Saputra. Caranya, klik kanan pada selektor kolom, lalu pilih New Record, seperti pada gambar.
Klik New Record

Gambar 3.2 Update tabel

Selanjutnya masukkan data dari Dian Sastro dan Nicolas Saputra dengan benar. Diktat Microsoft Access 2007 | 24

Gambar 3.3 Memasukkan dua record baru

 

Setelah data selesai di update, klik Tombol Office  Save atau klik ikon pada toolbar untuk menyimpan hasil update data. Langkah terakhir tutup tabel dengan mengklik Tombol Office  Close Database atau dengan mengklik ikon .

2. Update Data Melalui Query a. Membuat Query Query adalah sarana untuk mengatur data yang disimpan dalam tabel, sehingga hanya data-data tertentu saja yang akan dimunculkan dalam tabel. Secara fisik query adalah tabel juga. Jadi query adalah tabel yang dibuat dari beberapa tabel lainnya dengan tujuan untuk mengelompokkan data baru berupa tabel dengan sumber tabel-tabel yang sudah ada. Query dapat menyortir data atau menampilkan data-data yang memenuhi kriteria tertentu atau juga dapat berupa ekspresi. Sebelum membuat query, tabeltabel yang akan digunakan harus dihubungkan terlebih dahulu satu sama lain karena ketika memuat query kita akan menggunakan kombinasi dari tabel-tabel tersebut. Cara membuat relationship pada tabel-tabel tersebut adalah sebagai berikut :  Klik tab Database Tools.

Gambar 3.4 Tab menu Database Tools

 

Klik Relationship yang ada di bagian Show/Hide. Timbul sebuah tampilan relationship. Klik Show Table yang ada dibagian Relationship. Pada Form Show Table pilih tabel yang ingin kita hubungkan dengan cara sorot nama tabelnya kemudian klik Add.

Gambar 3.5 Form show table

Diktat Microsoft Access 2007 | 25

Setelah memilih kemudian klik Close.

Gambar 3.6 Tampilan relationship

Untuk membuat sebuah relasi antar tabel anda bisa langsung menyorot field yang ingin direlasikan kemudian drag dan drop di field relasinya pada tabel yang berbeda. Sebagai contoh anda klik field NIS yang ada di tabel Peserta Didik kemudian drag dan drop field tersebut dengan field NIS yang ada di tabel Penilaian. Kemudian pada form Edit Relationship klik Create.

Gambar 3.7 Form edit relationships

Gambar 3.8 Tampilan relasi tabel Peserta Didik dan Daftar Nilai

Setelah anda selesai membuat relasi antar tabel, maka sekarang bisa dimulai membuat query. Terdapat dua cara membuat query yaitu :  Membuat Query dengan Fasilitas Query Wizard.  Membuat Query dengan Query Design 1) Membuat Query dengan Fasilitas Query Wizard. Sebuah query dapat dibuat dengan fasilitas yang telah disediakan oleh Access 2007 yaitu dengan fasilitas query wizard. Cara untuk membuat query dengan query wizard adalah sebagai berikut :  Buka Database Pendidikan yang telah dibuah sebelumnya.  Klik tab Create.  Klik Query Wizard yang ada di bagian Other.

Gambar 3.9 Tampilan query wizard

Diktat Microsoft Access 2007 | 26

Pada isian New Query, pilih Simple Query Wizard lalu klik OK.

Gambar 3.10 Form new query

Pada form Simple Query Wizard lakukan pemilihan sebagai berikut :  Pada kotak daftar pilihan Table/Query, pilih dan klik nama tabel/query yang diinginkan, misal:  Tabel Peserta Didik nama field yang diinginkan NIS, NAMA SISWA, KELAS, dan JURUSAN.  Tabel Penilaian nama field yang diinginkan yaitu BIND, BINGG, MTK, PRODUKTIF, JUMLAH NILAI, dan RATA-RATA.  Pada kotak daftar pilihan Selected Field, pilih field-fieldnya dengan menekan tombol >. Jika ingin semua field tekan tombol >> sehingga field yang terseleksi akan tampak pada gambar di bawah ini.

Gambar 3.11 Form Simple query wizard

Klik tombol Next untuk menuju tahap berikutnya. Pada form Simple QueryWizard pilih Detail (Shows every field of every record). Kalau memilih Summary kita bisa menambahkan kesimpulan dari query yang akan dibuat. Sebagai contoh kita bisa menambahkan SUM untuk query yang telah dibuat. Selanjutnya klik Next. Masukkan nama query yang diinginkan pada isian yang telah disediakan. Kemudian anda bisa memilih Open the query to view information (melihat hasil query dalam bentuk tabel) atau Modify the query design (melihat hasil query dalam bentuk design view). Klik Finish. Diktat Microsoft Access 2007 | 27

Gambar 3.12 Tampilan masukan nama query

Maka hasil querynya adalah sebagai berikut.

Gambar 3.13 Tampilan Peserta Didik Query

2) Membuat Query dengan Query Design Selain cara di atas, query juga dapat dibuat dengan cara manual. Langkahlangkah pembuatan query manual adalah sebagai berikut:  Bukalah Database Pendidikan yang telah dibuah sebelumnya.  Klik tab Create.  Klik Query Design di bagian Other.  Pada form Show Table pilih tabel yang ingin di jadikan query dengan cara mengklik Add. Lalu klik Close.

Gambar 3.14 Form show table

Pada jendela yang tampil, pilih field-field yang diinginkan sesuai urutan pada kolom-kolom yang disediakan. Untuk itu ada tiga cara yang dapat digunakan, antara lain :  Pada kolom pertama, klik tombol daftar pilihan pada baris Table. Pilih tabel yang diinginkan. Lalu klik pada tombol daftar pilihan pada baris Field, pilih dan klik nama field yang diinginkan. Ulangi langkah tersebut untuk mengisi kolom-kolom berikutnya. Diktat Microsoft Access 2007 | 28

 Pada kotak daftar pilihan field yang ada di bagian atas jendela kerja, pilih dan klik nama field yang diinginkan lalu geser (drag) ke posisi kolom yang diinginkan. Ulangi langkah tersebut untuk mengisi kolom berikutnya.  Pada kotak daftar pilihan field yang ada di bagian atas jendela kerja, klik dua kali nama field yang ingin ditampilkan. Dengan langkah ini secara otomatis field-field tersebut akan mengisi kolom berikutnya yang masih kosong.

Gambar 3.15 Jendela kerja query1

Gambar 3.16 Isian query yang telah terisi

Untuk melihat hasil query yang dibuat, klik Run Results, sehingga hasilnya adalah sebagai berikut.

yang ada di bagian

Gambar 3.17 Hasil Query1

Kemudian simpan query tersebut dengan nama Peserta Didik Query1.

Bagaimana menampilkan jumlah nilai dan rata-rata pada query? Perhatikan langkah berikut : Diktat Microsoft Access 2007 | 29

Buka query Peserta Didik Query1. Masuk ke dalam Design View, pada kolom jumlah nilai, ketikkan rumus berikut : JML NILAI:[BIND]+[BINGG]+[MTK]+[PRODUKTIF] Perhatikan penggunaan tanda “:” dan bukan tanda “=”. Simpan hasil perubahan yang dilakukan di Design View.

Gambar 3.18 Memasukkan rumus

 

Selanjutnya, kamu dapat melihat query Peserta Didik Query1 telah menunjukkan jumlah nilai siswa. Jika ingin rata-rata ikut diperlihatkan dalam query, beri tanda checklist pada kolom rata-rata di Design View, kemudian ketikkan persamaan berikut : RATA-RATA:[JML NILAI]/4
Gambar 3.19 Memasukkan rumus rata-rata

Simpan perubahan yang anda lakukan dan keluarlah dari Design View. Selanjutnya, buka kembali Peserta Didik Query. Hasilnya sebagai berikut.

Gambar 3.20 Jumlah nilai dan rata-rata telah ditampilkan pada query

Anda dapat mengubah jumlah desimal dengan mengklik kanan kolom ratarata pada jendela Design View, kemudian klik Properties.

Gambar 3.21 Melihat dan mengubah properties field rata-rata

Ubah Format pada field properties menjadi Standard.

Gambar 3.22 Mengubah format dari field rata-rata menjadi tipe Standard

Simpan hasil perubahan query dengan menekan Ctrl+S dan buka Peserta Didik Query1 dengan cara klik View  Datasheet View. Diktat Microsoft Access 2007 | 30

b.

Update data melalui query Untuk melakukan update data melalui query caranya tidak jauh berbeda dengan update data melalui tabel. Berikut langkah-langkahnya :  Buka basis data Database Pendidikan, kemudian masuklah ke Peserta Didik Query1.  Pada record terakhir, masukkan data yang ingin anda tambahkan dengan tepat. Misalkan menambahkan data peserta didik berikut NIS: 3015, Nama Siswa: Firman, Kelas: XI Oto 2, Bind: 75, Bingg: 82, Mtk: 70, Produktif: 90.

Gambar 3.23 Perubahan data melalui query

Simpan hasil perubahan yang dilakukan.

C. MEN-DELETE (MENGHAPUS) DATA Data yang terdapat di dalam suatu basis data boleh jadi ada yang sudah tidak digunakan lagi. Oleh karena itu, data tersebut perlu kita hapus agar tidak memenuhi ruang penyimpanan dalam basis data. Agar tidak terjadi kesalahan menghapus data, terlebih dahulu harus dipastikan bahwa memang data tersebut adalah data yang dihapus. Penghapusan data dalam basis data bisa dilakukan dengan berbagai bentuk, yaitu dengan men-delete (menghapus) record, menghapus field, dan menghapus tabel. 1. Menghapus Record Sebelum menghapus data dalam bentuk record, anda harus membuka tabel yang datanya akan dihapus. Pada bagian ini kita akan menghapus record pada tabel Peserta Didik. Berikut langkah-langkahnya :  Buka tabel Peserta Didik, kemudian pilih record yang hendak dihapus. Misalnya, jika kita menginginkan record dari siswa bernama Dewi Persik untuk dihapus, maka klik kanan pada selektor record tersebut dan pilih Delete Record. Atau anda juga dapat menghapusnya dengan cara menekan tombol Delete pada keyboard atau melalui tab menu Home  .

Gambar 3.26 Menghapus record siswa

Setelah memilih Delete Record, anda akan dihadapkan pada dialog box. Pilih Yes jika memang pasti data tersebut yang harus dihapus, atau pilih No untuk membatalkan penghapusan data. Diktat Microsoft Access 2007 | 31

Setelah record dihapus, maka tabel akan tampak seperti pada gambar.

Gambar 3.27 Tabel setelah penghapusan record

2.

Menghapus Field Field pada suatu tabel yang sudah tidak diperlukan lagi dapat dihapus agar mengurangi kepadatan penyimpanan data dalam database. Penghapusannya dapat dilakukan melalui tabel dalam format Design View. Langkah-langkahnya sebagai berikut :  Buka kembali basis data Database Pendidikan.  Selanjutnya, buka Design View dari tabel Peserta Didik.  Klik kanan selektor field yang ingin dihapus dan pilih Delete Rows. Jika field yang ingin dihapus adalah field JK, maka klik kanan selektor field-nya dan pilih Delete Rows.  Selesai mengklik perintah Delete Rows, akan keluar jendela validasi. Jendela tersebut berisi Gambar 3.28 Menghapus field JK pilihan Yes jika anda hendak menghilangkan dari tabel peserta didik field secara permanen dan pilihan No jika anda ingin membatalkan penghapusan. 3. Menghapus Tabel Kita sudah mengetahui bahwa di dalam suatu basis data itu terdapat banyak tabel yang saling berhubungan antara tabel satu dengan tabel yang lain. Jika terdapat satu atau sejumlah tabel yang sudah tidak digunakan lagi, maka tabel tersebut sebaiknya dihapus. Hal ini dimadsudkan untuk mengurangi kepadatan penyimpanan data di dalam basis data. Adapun langkah-langkah untuk menghapus tabel adalah sebagai berikut :  Buka jendela Navigation Pane.  Kemudian pilih tabel yang akan dihapus (Misalkan, tabel Peserta Didik).

Gambar 3.29 Memilih tabel Peserta didik

Diktat Microsoft Access 2007 | 32

Klik kanan tabel Peserta Didik, kemudian pilih Delete.

Gambar 3.30 Perintah menghapus

Setelah memilih Delete, akan muncul kotak konfirmasi. Pilih Yes untuk melanjutkan menghapus tabel atau pilih No untuk membatalkan penghapusan tabel. Semua data yang telah dihapus tidak akan bisa dikembalikan lagi, kecuali anda memasukkan ulang data tersebut. Maka berhati-hatilah dalam menghapus data. D. MEMERIKSA HASIL UPDATE DATA Setelah data di-update, sebaiknya diperiksa apakah data yang di-update sudah benar atau belum. Tujuannya adalah untuk menghindari kesalahan dalam meng-update data. Salah satu cara untuk memeriksa data yang telah di-update adalah dengan menggunakan report. Langkah-langkah membuat report sebagai berikut :  Buka kembali file basis data Database Pendidikan.  Pilih tabel/query yang akan dibuat report-nya.  Klik tab menu Create, lalu klik/pilih , akan muncul gambar berikut.

Gambar 3.31 Jendela Report Wizard

Selanjutnya pindahkan nama field-field yang akan dibuatkan report-nya dari Available Fields ke dalam Selected Fields. Tekan > untuk memidahkan nama field satu per satu, atau klik >> untuk memindahkan seluruh field kedalam Selected Fields. Klik Next. Diktat Microsoft Access 2007 | 33

 

Klik Next lagi, lalu atur penyortiran data jika diperlukan Ascending (menaik) atau Descending (menuru), kemudian klik Next. Pilih layout untuk report yang anda buat. Misalnya layout yang dipilih Tabular dan Orientation yang digunakan Landscape seperti pada gambar.

Gambar 3.32 Jendela pengaturan layout pada Report Wizard

 

Klik Next untuk menuju ke tahap berikutnya. Selanjutnya tentukan style (gaya) dari report yang akan ditampilkan.

Gambar 3.32 Jendela pengaturan style pada Report Wizard

 

Setelah anda memilih salah satu style yang tersedia, klik Next. Masukkan nama report yang diinginkan pada isian yang telah disediakan. Kemudian anda bisa memilih Preview the report (melihat hasil report) atau Modify the report’s design (melihat hasil report dalam bentuk design view). Klik Finish.

Gambar 3.33 Tampilan masukan nama report

Diktat Microsoft Access 2007 | 34

Maka hasil querynya adalah sebagai berikut.

Gambar 3.34 Tampilan report Peserta Didik SMK Yos Sudarso

 

Jangan lupa untuk menyimpan report tersebut. Setelah report dibuat, anda bisa memeriksa data-data melalui report.

E. MENCETAK HASIL UPDATE DAN DELETE DATA Untuk mencetak hasil update dan hasil delete data, anda dapat menggunakan cara seperti pada bagian sebelumnya, yaitu :  Tekan Tombol Office  Print atau Ctrl+P, maka akan tampil gambar berikut.

Gambar 3.35 Mencetak hasil entry data

    

Pilih nama printer pada kotak Name: Isikan nomor halaman yang hendak dicetak, pada kotak isian Page From: Klik All untuk mencetak semua data. Untuk melakukan pengaturan jenis kertas, pewarnaan dan sebagainya, anda dapat menggunakan tombol Properties. Tekan Enter atau klik OK jika sudah selesai, maka tabel akan tercetak beserta datanya.

**** ooOOoo ****

Diktat Microsoft Access 2007 | 35

DAFTAR PUSTAKA

Modul KKPI VEDC Malang Mintana, Anjrah. 2008. Ketrampilan Komputer dan Pengelolaan Informasi untuk SMK dan MAK Kelas XI. Penerbit Erlangga, Jakarta. D Fauzi, Harry. 2006. Memahami KKPI SMK. Penerbit Armico, Bandung. Alexander Mangkulo, Hengky. 2005. Bank Soal Access. Penerbit PT Elexmedia Komputindo, Jakarta . Buku Diktat Mata Kuliah Software Terapan II. Unikom. www.google.co.id

Diktat Microsoft Access 2007 | 36

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->