P. 1
Microsoft Access 2002

Microsoft Access 2002

|Views: 3|Likes:
Published by Muhammad Isra

More info:

Published by: Muhammad Isra on Jul 10, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

10/06/2013

pdf

text

original

Sections

  • 2.1. Create table in design view
  • 2.2. Memasukkan Data pada Tabel
  • 2.3. Mengolah Field, Record dan Tabel
  • 3.2. Menciptakan Formulir dengan AutoForm:Columnar
  • 3.3. Menciptakan Formulir dengan AutoForm:Tubular
  • 3.4. Menciptakan Formulir dengan AutoForm:Datasheet
  • 3.5. Menyaring Tampilan Database
  • 3.6. Memfilter berdasarkan Form
  • 3.7. Membuat AutoForm: Pivot Tabel
  • 3.8. Membuat AutoForm: Pivot Chart
  • 3.9. Mengubah Urutan Tab pada Form
  • Menghubungkan Beberapa Tabel
  • 4.2. Memahami hubungan Tabel
  • 4.3. Menggunakan Form Wizard untuk membuat Form dan SubForm
  • 5.3. Menampilkan Data dalam bentuk diagram (Grafik)
  • Bekerja dengan File External
  • 6.2. Me-Link ke Tabel Database Eksternal
  • 6.4. Mengekspor table untuk Microsoft Excell
  • 7.2. Membuat halaman data Access dengan Wizard
  • 7.3. Mengubah format Theme pada Design Page
  • 7.4. Menampilkan Hyperlink pada Design Page
  • 7.5. Menghapus Hyperlink
  • Fasilitas Command Boxes dan Macro
  • 8.2. Command Button Sebagai pengontrol Record
  • 8.3. Command Button Sebagai penutup Record

PENDIDIKAN JARINGAN KOMPUTER DAN SISTEM INFORMASI

©Copyright PIKSI-ITS 2002

Ruang C.203 Jurusan Teknik Elektro ITS Keputih Sukolilo - Surabaya Telp: (031)5929871 Fax: (031)5929870 : piksi-its@ee.its.ac.id

Microsoft Access i

Hak Cipta
Buku dan Logo dari PIKSI – ITS ini adalah merupakan hak cipta dari PIKSI-ITS. Dilarang memperbanyak, memfotocopy sebagian atau seluruh isi dari buku dan logo tanpa seijin dari pihak PIKSI-ITS

Disclaimer
Book and Logo PIKSI-ITS are copyright© of PIKSI-ITS No part of this book, including interior design , cover and logo maybe reproduce without any permission from PIKSI-ITS

Microsoft Access ii

Kata Pengantar
Jenis pendidikan satu tahun sekarang ini sudah mulai banyak jumlahnya. Salah satunya adalah Pendidikan Jaringan Komputer dan Sistem Informasi – ITS atau disingkat PIKSI – ITS. PIKSI pertama mengkhususkan diri pada bidang Jaringan Komputer dan Basis Data. Kemudian menyesuaikan diri dengan perkembangan dan minat masyarakat, dibuka kelas baru Aplikasi Perkantoran. Salah satu bidang yang diajarkan PIKSI sekarang ini adalah Microsoft Access. Diharapkan bahwa buku ini akan menunjuang bagi mereka yang berminat mendalami bidang ini, juga sebagai pembantu dalam perkuliahan PIKSI-ITS. Saran dan kritik anda tentang buku atau kualitas pengajaran dapat anda kirimkan ke email : piksi-its@ee.its.ac.id.

Ketua PIKSI-ITS

I Ketut Edi Purnama, MT

........3............................................ Mengubah format Theme pada Design Page..................7.......... Pendahuluan........... Membuat Query ..........................................................2........ Pendahuluan............................................. Menggunakan Form Wizard untuk membuat Form dan SubForm................... 5-2 5.......................................................... 6-5 Bekerja dengan Web .. Membuat AutoForm: Pivot Tabel....... Mengolah Field.............. 2-2 2....... Pendahuluan...ii Daftar Isi .....................................................................................2.................... 3-2 3...........3.................................1............................ 4-2 4................... 7-5 7................................ Record dan Tabel............ 7-5 ....8.....................4................9........................................................................................................... 6-1 6.......................... 4-2 4.................2..............................................5..........................3...... 6-2 6...............................5....... Memfilter berdasarkan Form ............... 3-4 3...................2... 3-6 Menghubungkan Beberapa Tabel .....................................................................................................4.... 1-2 1........... 1-4 Membuat Database dan Tabel................................. 3-3 3.................. Me-Link ke Tabel Database Eksternal...................................................... Menciptakan Formulir dengan AutoForm:Tubular ...................... 3-1 3........................ Membuat AutoForm: Pivot Chart ..... Memasukkan Data pada Tabel......................... 6-3 6....................3......1........ Membuat Query .1........... 5-13 Bekerja dengan File External.......................................................................1.................. Memahami hubungan Tabel .................................................................... 7-2 7...................4......................................2................................................ Pendahuluan... Menampilkan Hyperlink pada Design Page................. Create table in design view ........... 4-6 Query dan Report.. 3-6 3............................1.......3.......................................... iii Pengenalan . 6-2 6...............Microsoft Access iii Daftar Isi Kata Pengantar ................................. Membuat halaman data Access dengan Wizard ............................................................. 3-4 3.................... ..........................................................4.......................................................................1..................... Pengenalan Database .....................2....................... Membuka Database........................................................................................................................................... 5-1 5....... 1-2 1.. ........................................... 1-1 1................................3........... Menggunakan Toolbar .. 7-1 7........................ Pengenalan ........ 1-3 1............ 3-3 3............. 7-5 7................................. Menyaring Tampilan Database ............................................................... Mengubah Urutan Tab pada Form........................................................................... Menghapus Hyperlink.... 3-2 3......... Mengimpor table................................................................................. Mengekspor table untuk Microsoft Excell................................................................ Menciptakan Formulir dengan AutoForm:Datasheet ..........................2...................... 2-5 2........................................3.......... 3-4 3............................................. 7-2 7................................................................... 5-9 5............................. 2-1 2.......... Menciptakan Formulir dengan AutoForm:Columnar ... Menampilkan Data dalam bentuk diagram (Grafik)......................... 2-7 Menciptakan Form .............6..................1................................................................ 4-1 4............................................................

....1.......................... 8-4 ............. 8-2 8..........3...... 8-4 8................... Macro ...................... 8-3 8................................................2.....................................................4.......... Command Button Sebagai pengontrol Record ..............................Microsoft Access iv Fasilitas Command Boxes dan Macro ............................... Command Button Sebagai penutup Record.................................................... Pendahuluan................................... 8-1 8..........

1 BAB 1 Pengenalan Tujuan : Pada Bab Ini diharapkan mahasiswa : • Mengenal Menu & Tool dalam Microsoft Access 2002 • Memahami lingkungan Microsoft Access 2002 .Microsoft Access Pengenalan 1 .

dan satu tempat untuk menyimpan data anda disebut database. kotak teks interaktif. Membuka Database Jika Anda baru mulai menggunakan Accees 2000 dengan bab ini. 4. Forms berfungsi memasukkan data. Form menggantikan Form kertas yang biasa anda pakai. Macros berfungsi mengotomatiskan perintah-perintah yang kita kehendaki dalam mengolah data 7. 1. Pada sebuah database Access data dimasukkan dan dimanipulasi dalam Form dan disimpan dalam tabel. Anda bisa mengetikkan pertanyaan pada kotak pertanyaan lalu klik search. Informasi yang anda simpan untuk referensi masa depan disebut data. Microsoft Access 2002 juga merupakan sistem manajemen database yang canggih yang bisa digunakan secara efisien menampilkan dan mengelola database. Office Assistant Office Assistant animasi menawarkan pesan-pesan berguna saat anda bekerja. Reports berfungsi mencetak data dalam bentuk laporan 5. Queries berfungsi menyaring data dari berbagai kriteria dan urutan yang kita kehendaki 3.1. Seluruh field pada form menyusun sebuah Record.2. menampilkan data dan mengedit data dari suatu tabel dengan bentuk tampilan formulir yang kita rancang sendiri. Pages berfungsi menciptakan halaman Web berupa data Access page 6. Memulai Microsoft Access 2000 • • • Pada taskbar. klik tombol start Tunjuk Programs. seringkali disebut field.2 1. Pengenalan Microsoft Access 2002 adalah salah satu aplikasi dari Microsoft office 2002. ikuti langkahlangkah untuk memulai Access dan membuka sebuah database. Tables adalah tabel kumpulan data sebagai komponen utama pada database 2. Database Access 2002 terdiri dari 7 hal yaitu : 1.Microsoft Access Pengenalan 1 . lalu klik Microsoft Access kotak dialog Microsoft Access muncul . Modules berfungsi merancang bermacam-macam modul aplikasi dalam mengolah database tingkat lanjut sesuai yang kita inginkan.

3 Gambar 1. berubah ketika anda berpindah dari jendela database ke jendela lain. . pilihannya adalah • Blank Database berfungsi untuk menciptakan database baru yang • Blank Data Access Page berfungsi untuk menciptakan halaman web baru berupa Data Access Page • Project (Existing Data) berfungsi untuk menciptakan project berdasarkan data yang sudah pernah kita ciptakan.Microsoft Access Pengenalan 1 . • Project (New Data) berfungsi untuk menciptakan project baru .1 Kotak dialog Microsoft Access StartUp Pada New File terdapat beberapa pilihan sebagai berikut : Open a file berfungsi menampilkan file-file yang terakhir kali dipakai Pilihan More files berfungsi untuk membuka file-file lainnya yang pernah kita buat. Menggunakan Toolbar Toolbar yang muncul pada baris menu Microsoft Access 2002 bersifat dinamis.3. lalu klik OK 1.New from existing file berfungsi untuk menciptakan database baru berdasarkan file yang pernah kita ciptakan . - New berfungsi untuk menciptakan database baru. Untuk Toolbar Form View atau Toolbar Table datasheet memiliki tombol yang spesifik untuk form bersama tombol yang berfungsi umum untuk mengedit teks.New from template berfungsi untuk menciptakan database baru dengan menggunakan Template atau Wizard Setelah memilih salah satu pilihan diatas.

mdb.3 Toolbar Database 1.mdb . Sebagai contoh kita menggunakan file Database contoh yaitu Nwind. File tersebut bisa anda temukan pada Program Files/ DevStudio/ Vb/ Nwind.2 Toolbar Table datasheet Gambar 1.Microsoft Access Pengenalan 1 .4. Pengenalan Database Sebagai pengenalan terhadap Database apa yang kita akan buat.4 Gambar 1.

Record dan Tabel .Microsoft Access Membuat Database dan Tabel 2 .1 BAB 2 Membuat Database dan Tabel Tujuan : Pada Bab ini mahasiswa akan mempelajari cara : • Mendesain suatu tabel baru • Menambah data pada tabel • Mengolah Field.

Jika kita tidak memberi nama file maka otomatis akan diberi nama db1. Lalu Klik Create g. lalu klik Microsoft Access c. Pilih Create Tabel in Design View lalu klik Design .mdb f. Tunjuk Programs.4. Kotak dialog File New Database e. Kotak isian File Name diisi dengan nama file yang kita inginkan misalkan kita isi dengan nama mahasiswa. klik start b. Create table in design view Langkah-langkah dalam menciptakan database baru : a.1.Microsoft Access Membuat Database dan Tabel 2 . Akan muncul dialog file New Database Gambar 1. Pilih Blank Database d.mdb.2 2.

3 Gambar 2. Nama. Field Size kita isi dengan 10 . Tanggal Lahir. dan description kita isi dengan Nomor Registrasi Pokok.Microsoft Access Membuat Database dan Tabel 2 . Data type berupa Text. Misalkan field yang kita rencanakan adalah NRP.3 Lembar kerja database baru Akan Muncul tabel yang akan kita ciptakan : Ada 3 kolom yang akan kita isi yaitu Field name adalah nama field yang dibutuhkan untuk membuat database yang kita inginkan Data Type adalah tipe data dari nama field yang kita buat Description berfungsi sebagai keterangan h. Alamat dan Foto • Field Name kita isi dengan NRP. Gender.

Field Size kita isi dengan 10 Field Name kita isi dengan Alamat. form atau laporan Default Value Meletakkan data yang sering dipakai atau data yang sama untuk field tertentu untuk sebuah record baru yang diciptakan Validation Rule Mengontrol masuknya data pada field yag sudah ditentukan Validation Text Menampilkan keterangan jika data kita masukkan tidak cocok dengan batasan data yang sudah ditentukan Required Mengatur boleh tidaknya sebuah field dikosongkan ketika record baru diisi Allow Zero Length Menentukan definisi nilai blank (“ ”) serta membedakannya dengan nilai null Indexed Membuat index pada field yang sedang aktif .Microsoft Access Membuat Database dan Tabel 2 . dan description kita isi dengan Alamat Mahasiswa. dan description kita isi dengan Tanggal Lahir Mahasiswa. Field Size kita isi dengan 30 Field Name kita isi dengan Foto.4 • • • • • Field Name kita isi dengan Nama. Data type berupa Text. Misalnya untuk untuk field NRP membutuhkan 10 karakter Format Menentukan format tampilan data Input Mask Menentukan tampilan ketika menuliskan data di layar Decimal Places Menentukan jumlah angka desimal yang dibutuhkan Caption Meletakkan keterangan judul kolom. Data type berupa Text. Data type berupa Date/Time. dan description kita isi dengan Foto diri Maka Tampilan lengkap dari Table Design adalah sebagai berikut Properti Field • • • • • • • • • • • Field Size Ukuran field berupa jumlah karakter yag dibutuhkan. dan description kita isi dengan Nama Lengkap Mahasiswa. Data type berupa OLE Object. dan description kita isi dengan Jenis Kelamin. Field Size kita isi dengan 20 Field Name kita isi dengan Tgl Lahir. Field Name kita isi dengan Gender. Data type berupa Text.

kita perlu menentukan field name yang akan dijadikan primary key. Sebuah identifikasi mahasiswa (NRP) seringkali digunakan sebagai kunci primer dalam sebuah sistem informasi mahasiswa karena setiap mahasiswa harus memilikinya. Kemudian klik Primary Key. memungkinkan seluruh record pada satu tabel disesuaikan dengan record pada tabel lain. Misalkan field NRP kita jadikan primary key. Lalu kita akan Menyimpan Tabel yang kita buat dengan meng-klik Menu File lalu klik Save. primary key dengan banyak field digunakan ketika nilai pada field yag dipilih sebagai field primer tidak bisa unik. Klik Ok k. Lalu masukkan Nama Tabel yang kita inginkan atau default name adalah Tabel1 j. Tidak ada dua record dalam tabel tersebut yang akan memiliki nilai yang sama pada field kunci primer masing-masing. Field primary key memiliki banyak kegunaan. Membiarkan Microsoft Access 2002 menggunakan field autonumber sebagai primary key biasanya merupakan cara termudah dan teraman. caranya letakkan pointer di field NRP lalu klik Menu Edit. Primary Key / Kunci primer Primary key adalah sebuah field atau sekelompok field yang secara unik mengidentifikasikan masing-masing record pada sebuah tabel. Jika tidak ada urutan penyortiran tertentu.5 • Unicode Compression Secara standar diisi dengan yes Catatan : Setelah selesai. Setelah Menutup Database maka tampilan Access akan seperti : . klik Menu File lalu Close atau klik saja tombol close (X) 2. Memasukkan Data pada Tabel l. Sebuah primary key bisa terdiri dari satu atau lebih field.Microsoft Access Membuat Database dan Tabel 2 . Field autonumber sangat berguna untuk menjadi primary key. Microsoft Access 2002 memiliki fasilitas autonumber yang menentukan nomor unik pada masing-masing record segera setelah membuatnya. i. record dalam tabel disortir (diurutkan) berdasarkan primary key. dan setiap identifikasi adalah unik (tidak ada yang menyamainya). primary key digunakan untuk membuat hubungan antar tabel. Karena primary key secara unik mengidentifikasi masing-masing record dalam sebuah tabel. Setelah selesai Kita tutup tabel dengan cara .2.

Klik Table1 lalu Klik Open akan muncul : n. untuk memasukkan data tanggal sekarang • Ctrl: untuk memasukkan data waktu sekarang.Microsoft Access Membuat Database dan Tabel 2 . Isi Data pada field-field yang ada sesuai yang dibutuhkan Contohnya Adalah Cara mengisi Data : • Tab untuk berpindah dari satu field ke field berikutnya • Shift Tab untuk berpindah dari satu field ke field sebelumnya • Ctrl.6 m. • Ctrl’ untuk mengisi data dengan data yang sama seperti record sebelumnya pada field yang sama • Home untuk berpindah ke field awal pada record yang sama .

3. Rows atau klik toolbar Insert Rows b. Catatan : Anda juga bisa mengimport Table dan Object lain kedalam database yang ada langkah-langkahnya : Buka file database yang akan di copy lalu klik Tables yang berada dibawah Objects. Menyisipkan field Langkah-langkahnya : ƒ ƒ Klik nama tabel yang akan disisipi field baru. Menghapus field Langkah-langkahnya : ƒ Klik nama tabel yang akan disisipi field baru. lalu klik toolbar design Tentukan posisi field baru lalu klik menu Insert. Record dan Tabel a. Selain itu anda juga mengimport Table dari file Database lain yaitu dengan memilih pilihan Import Table dari dialog New Table. lalu klik Ok. Selain itu database baru juga bisa dibuat Create Table in Datasheet View atau Dengan Create Table by Using Wizard.Microsoft Access Membuat Database dan Tabel 2 . Mengolah Field. lalu klik toolbar design . Klik New lalu muncul dialog - - Lalu pilih Link Table. Lalu Klik Menu File lalu Close atau klik tombol close (X) Akhirnya kita telah membuat database mahasiswa sederhana hanya dengan menggunakan satu tabel. Pilih database yang tabelnya akan di Link dengan Database yang akan anda buat.7 • • • • • End untuk berpindah ke field paling akhir pada record yang sama Anak panah Atas Untuk berpindah dari record satu ke record sebelumnya Anak Panah bawah Untuk berpindah dari record satu ke record selanjutnya Ctrl Home Untuk berpindah ke record pertama pada field pertama Ctrl End Untuk berpindah ke record terakhir pada field terakhir o. 2.

Mengcopy Tabel dengan nama baru ke database laim Langkah-langkahnya : ƒ ƒ Buka file database yang akan di copy lalu klik Tables yang berada dibawah Objects. Delete Record atau klik toolbar Delete record g. Menghapus Tabel pada Database Langkah-langkahnya : ƒ ƒ Buka file database yang salah satu tabelnya akan dihapus klik Tables yang berada dibawah Objects. Dalam hal ini file database tersebut harus sudah ada sebelumnya. Menghias datasheet tabel Langkah-langkahnya : . Mengganti Nama Field/kolom Langkah-langkahnya : ƒ ƒ Klik nama tabel dua kali atau klik toolbar Open Pindahkan petunjuk sel pada batas kana judul kolom / field yang akan kita ganti namanya. e. Delete setelah muncul kotak dialog peringatan Yes No klik Tombol Yes f.8 ƒ Tentukan posisi field baru lalu klik menu Edit. Klik nama tabel yang diinginkan Lalu klik menu File. Export lalu klik nama database yang kita inginkan. Delete Rows atau klik toolbar Delete Rows c. Lalu klik menu Format .Microsoft Access Membuat Database dan Tabel 2 . Mengcopy Tabel dengan nama baru dalam satu database Langkah-langkahnya : ƒ ƒ Buka file database yang akan di copy lalu klik Tables yang berada dibawah Objects. Save As lalu isi dengan nama tabel lain. Menghapus Record Langkah-langkahnya : ƒ ƒ Klik nama tabel dua kali atau klik toolbar Open Blok record yang akan dihapus lalu klik menu Edit . Rename Column h. Klik nama tabel yang diinginkan Lalu klik menu File. d. Klik nama tabel yang diinginkan Lalu klik menu Edit.

9 ƒ ƒ Klik nama tabel dua kali atau klik toolbar Open Lalu klik menu Format . Datasheet maka akan muncul menu dialog Datasheet Keterangan : Cell Effect untuk mengatur efek khusus tampilan sel pada tabel Gridlines Shown untuk mengatur corak garis bantu tegak dan garis bantu datar Backgroud Colour untuk menentukan warna latar belakang sel pada tabel Gridline Color untuk menentukan warna garis bantu Border and Line Styles untuk memilih variasi bingkai i.Microsoft Access Membuat Database dan Tabel 2 . Font Lalu klik Ok . Mengganti Font Data pada Tabel Langkah-langkahnya : ƒ ƒ ƒ Klik nama tabel dua kali atau klik toolbar Open Lalu klik menu Format .

setelah petunjuk mouse berubah bentuk menjadi tanda panah dan arah.10 j. Mengubah tinggi baris sebuah Tabel ƒ Klik nama tabel dua kali atau klik toolbar Open ƒ Pindahkan mouse petunjuk sel pada batas bawah baris diarea pemilihan Record.Microsoft Access Membuat Database dan Tabel 2 . . geser (drag) tanda panah dua arah tersebut keatas dan kebawah hingga kita memperoleh tinggi baris yang dikehendaki.

Microsoft Access Menciptakan Form 3 .1 BAB 3 Menciptakan Form Tujuan : Pada Bab ini mahasiswa akan mempelajari cara : • Mengenal Form • Mengenal komponen dalam Form • Dapat membuat Form Access sendiri .

Seluruh data dimasukkan kedalam form melalui kontrol Form. Buka File Database yang kita perlukan.2. maka akan muncul Kotak dialog New Form seperti berikut ini. Obyek-obyek ini disusun dari obyek-obyek yang lebih kecil—kontrol-. Pendahuluan Microsoft Access 2002 menampilkan data dalam obyek grafis : form.Autoform PivotChart Dibawah ini akan kita bahas untuk bentuk Form tertentu. menampilkan atau mencari data.yang menerima. Klik New. Dengan mengubah properti sebuah kontrol form atau mengganti satu kontrol dengan kontrol lain.Autoform Columnar . anda bisa mengubah cara data dimasukkan dalam form. 3. report. Segala hal yang anda lihat pada sebuah form adalah kontrol. Ada beberapa bentuk Autoform (Formulir / Form) yang disediakan oleh Microsoft Access antara lain . lalu klik Forms b.Autoform PivotTable .2 3.Autoform Datasheet .1. Menciptakan Formulir dengan AutoForm:Columnar Langkah –langkah membuat autoform dengan bentuk Columnar a. query.Autoform Tabular .Microsoft Access Menciptakan Form 3 . lalu klik AutoForm: Columnar . halaman akses data dan tabel.

Microsoft Access Menciptakan Form 3 - 3

c. Klik Nama tabel yang diinginkan lalu klik Ok. Maka akan muncul hasil rancangan form yang sudah diisi.

3.3. Menciptakan Formulir dengan AutoForm:Tubular
Menggunakan cara yang sama dengan Autoform Columnar

3.4. Menciptakan Formulir dengan AutoForm:Datasheet
Menggunakan cara yang sama dengan Autoform Columnar

Microsoft Access Menciptakan Form 3 - 4

3.5. Menyaring Tampilan Database
Tampilan datasheet bisa sulit digunakan jika ada banyak field. Anda seringkali tersesat dan bingung. Ada dua strategi dalam menyaring tampilan database yaitu Membekukan kolom datasheet. Yaitu dengan klik field yang dinginkan pada baris manapun. Lalu Pada menu Format klik Freeze Columns Menyembunyikan kolom datasheet. Misalnya Untuk field picture, klik field tersebut lalu pada menu Format klik Hide Columns. Untuk mengembalikan pilih unhide Columns pada menu Format

3.6. Memfilter berdasarkan Form
Pada Form yang telah dibentuk Datasheet pilih field yang akan dijadikan acuan filter lalu klik Tombol Filter by Form maka tampilan database mengcollapse menjadi satu record saja. Lalu tekan tombol Apply/ remove Filter

Filter by Form

Apply/Remove Filter

3.7. Membuat AutoForm: Pivot Tabel
Caranya : • Klik New, maka akan muncul Kotak dialog New Form seperti berikut ini, lalu klik AutoForm: PivotTable

Microsoft Access Menciptakan Form 3 - 5

Maka hasilnya akan seperti ini

Drag field yang ada pada Field List Pivot Table lalu Drag field tersebut ke tempat yang telah disediakan

hal ini dikarenakan agar perpindahan urutan dari satu field ke field yang lain menjadi baik. maka akan muncul Kotak dialog New Form seperti berikut ini. 3. l alu klik AutoForm: PivotChart Drag field yang ada pada Field List Pivot Table lalu Drag field tersebut ke temapat yang telah disediakan Maka hasilnya adalah sebuah chart / Grafik. Membuat AutoForm: Pivot Chart Caranya : Klik New.Microsoft Access Menciptakan Form 3 .6 3. Langkah-langkahnya • • Pada daftar form jendela database pilih Form yang ada lalu klik Design Lalu klik menu View . Hal ini sangat membantu agar aliran dalam memasukkan (entri ) data menjadi urut dari satu bagian ke bagian lain.8. Tab Order akan muncul menu tab order . Mengubah Urutan Tab pada Form Urutan tab dalam sebuah Form adalah sebuah hal yang penting.9.

1 BAB 4 Menghubungkan Beberapa Tabel Tujuan : Pada Bab ini mahasiswa akan mempelajari cara : • Mengenal Form • Mengenal komponen dalam Form • Dapat membuat Form Access sendiri .Microsoft Access Menghubungkan Beberapa Tabel 4 .

Membuat tabel yang kita perlukan. Pendahuluan Microsoft Access 2002 membuat relational database : database yang menggabungkan data dari banyak tabel. Misalnya Untuk Tabel Karyawan fieldnya adalah NIP. Sebaiknya anda memahami bagaimana tabel yang baru akan berinteraksi dengan tabel yang sudah ada. Caranya seperti yang ada pada Bab2. Nama. Misalnya Untuk Tabel gaji fieldnya adalah Golongan. Misalnya Untuk database Jual-Beli diman satu customer (pelanggan) bisa melakukan banyakl pesanan. dimana satu record pada sebuah tabel bisa dihubungkan ke banyak record pada tabel lain.2 4. Ini dilakukan menggunakan hubungan antara beragam tabel pada database.Microsoft Access Menghubungkan Beberapa Tabel 4 . 5. Agar data pada tabel berguna. Membuat sebuah link antara field kunci primer pada tabel primer dan sebuah field yang memiliki nilai yang sesuai –disebut foreign key. Dalam satu database bisa mengandung beberapa tabel yang jumlahnya tergantung dari struktur database yang akan dibuat. anda bisa menggunakan hubungan tersebut untuk menggabungkan data dari satu tabel dengan data pada tabel lain. NIP. dengan demikian masing-masingrecord pada tabel pelanggan bisa terhubung ke banyak record pada Tabel Pemesanan. Tabel primer dalam hubungan tersebut bisa memiliki banyak record yang sesuai pada tabel terhubung.2. anda harus menghubungkannya ke database dengan membuat link logical atau hubungan ke tabel lain. 3. Hubungan paling umum digunakan adalah hubungan satu-ke-banyak.pada tabel terhubung. Bulan. mengikuti garis hubungan tersebut. Pada hubungan satu-ke-banyak tabel pada sisi ‘satu’ disebut tabel primer dan tabel pada sisi ‘banyak’ disebut tabel terhubung.Ltd. report atau query. tabel Karyawan dan tabel Jabatan. Hubungan digunakan untuk mengumpulkan data dari sejumlah tabel dan menempatkannya pada satu form. 2. Jadi pada contoh database Jual-beli tabel pelanggan merupakan tabel primer dan tabel pemesanan merupakan tabel terhubung. Maka Sekarang kita mempunyai 3 Table . sebagai contoh kita akan membuat 3 tabel yaitu tabel gaji. Gaji. Jabatan 4. Tgl Lahir. anda bisa membuat satu atau dua tipe hubungan : satu-kebanyak atau satu-ke-satu. 4. Misalnya Untuk Tabel Data Kerja fieldnya adalah No. Langkah-langkahnya adalah sebagai berikut : 1. Gender. Memahami hubungan Tabel Antara dua tabel. Golongan. Jika anda telah membuat hubungan antara tabel tertentu. Saat menambahkan tabel baru. Golongan. Alamat. Sebagai contoh kita akan membuat database Karyawan Piksi International Co. Hari Kerja dan Jam Lembur.1. Uang makan dan Uang Lembur.

Microsoft Access Menghubungkan Beberapa Tabel 4 . lalu klik tombol Close 8.3 6. Maka kita akan masuk Jendela Relationship . Klik Tables dan nama tabel . kemudian klik toolbar Relationships akan muncul dialog Show Table 7. Klik Semua nama Tabel.

Isilah masing-masing Tabel dalam Database sesuai field yang ada. 9. dan sangat cocok untuk membuat hubungan kompleks.4 Keterangan : Jika kita akan menambah Tabel lain kedalam jendela Relationship.Primary key mencakup lebih dari satu field . yang memastikan bahwa hubungan antar record pada tabel terhubung adalah valid dan anda tidak akan secara sengaja menghapus atau mengubah data yang terhubung. 11. dengan cara men-drag field Golongan dari Gaji ke Field Golongan dari Tabel Karyawan. Sekarang kita hubungkan antara tabel Gaji dan Karyawan. Keterangan : Integritas referensial / Referential integrity Perangkat utama untuk membuat dan mengelola hubungan pada Microsoft Access 2002 adalah jendela Relationshipd.Integritas Referensial dibutuhkan . Maka akan muncul kotak dialog Edit RelationShip. maka kita harus klik toolbar Show Table. pilih enforce referential integrity Klik create. integritas referensial juga mencegah pemasukan record terhubung yang tidak memiliki record primer yang sesuai.Microsoft Access Menghubungkan Beberapa Tabel 4 .Tidak ada field bersama yang sama untuk kedua tabel Microsoft Access 2002 menggunakan sebuah sistem aturan untuk membuat integrasi referensial antar tabel. 10. Jendela ini memungkinkan anda membuat hibingan sederhana. . Coba bedakan antara yang ada integritas referensial dengan hubungan yang tidak ada integritas referensial. khususnya ketika : . Selain itu integritas referensial mencegah adanya perubahan pada tabel primer yang akan merusak validasi record yang terhubung.

Dan kita misalkan karyawan sebagai tabel primer kita dan datakerja sebagai tabel terhubung.Microsoft Access Menghubungkan Beberapa Tabel 4 . Cascading delete menghapus seluruh record yang sesuai pada tabel terhubung ketika sebuah record pada tabel primer dihapus. Perubahan yang dilakukan pada tabel primer secara otomatis diterapkan pada tabel yang terhubung melalui proses yang disebut cascading. Jika kita melakukan perubahan pada field NIP maka field NIP pada tabel data kerja akan terupdate sesuai dengan tabel primer karyawan. Misalnya pada Kotak diaolog Edit RelationShips kita pilih (Checkbox) Cascade Update Related field. Pertama kali sebelum cascading delete diterapkan anda tidak bisa menghapus sebuah record di tabel karyawan. 12. tanpa melanggar integritas referensial.5 Cascading Update dan Delete Microsoft Access 2002 menyediakan sebuah fasilitas yang memungkinkan anda membuat perkecualian pada aturan dalam penghapusan record atau pengubahan kunci primer. Cascading Update menerapkan setiap perubahan yang anda buat pada tabel primer ke record yang sesuai pada tabel yang terhubung. Sekarang buka kembali Tabel Gaji yang sudah berkaitan dengan Tabel Karyawan dan Data kerja. . Maka hasilnya akan seperti gambar dibawah ini. dengan cara men-drag field Golongan dari Gaji ke Field Golongan dari Tabel Karyawan. 13. Sekarang kita hubungkan antara tabel Karyawan dan Data Kerja. Apabila cascading delete diterapkan maka penghapusan pada tabel karyawan akan menghapus record yang sesuai pada tabel Data kerja.

Lalu ada dua pilihan apakah Form with subform(s) atau Linked Forms .Microsoft Access Menghubungkan Beberapa Tabel 4 . begitu juga untuk tabel datakerja .Maka hasilnya kurang lebih sama seperti gambar dibawah ini . lalu pada dialog form wizard yang pertama klik panah drop down tables/query lalu pilih table Gaji pilih semua field yang ada. Sebagai form utama kita gunakan Tabel gaji sedangkan subform kita gunakan tabel karyawan dan tabel Data kerja. Lalu beri judul untuk form dan subform yang baru saja dibuat.Lalu pilih style yang diinginkan. Menggunakan Form Wizard untuk membuat Form dan SubForm Pada Bab 3 anda hanya menggunakan satu form untuk satu tabel yang anda buat. . Langkah-langkah : . Sekarang dengan menggunakan Form Wizard anda akan membuat form dengan 3 tabel yang ada. Lalu pilih table karyawan pilih field yang anda kehendaki.3.Pada jendela database. Field-field pada form utama berisikan data dari satu tabel atau query. pilih Form pada baris Object lalu klik New pada jendela database .Klik Next. Sementara subform berisi data dari tabel atau query lain. Pivot Table dan Pivot Chart .Pilih Form wizard. kemudian pilih layout dari subform apakah berupa Tabular. Dimana pengertian subform adalah form didalam form yang memungkinkan anda bekerja dengan record dari lebih dari satu tabel atau query terpisah sekaligus dalam satu form.6 4.Pilih Form with subform(s). datasheet.

7 .Microsoft Access Menghubungkan Beberapa Tabel 4 .

Microsoft Access Query dan Report 5 .1 BAB 5 Query dan Report Tujuan : Pada Bab ini mahasiswa akan mempelajari cara : • Mengenal Bentuk Query dan Report • Dapat menggunakan Query dan Report Wizard • Dapat membuat sendiri Query dan Report .

Query juga bisa mengambil informasi lebih dari satu tabel dan menyimpannya secara permanen. Query bekerja mirip dengan filter dimana Query berfungsi untuk menyaring / menampilkan data yang diinginkan dari berbagi kriteria / field dan urutan yang kita kehendaki. Filter memungkinkan anda mengeluarkan data yang tidak relevan. Membuat Query Microsoft Access 2002 Menawarkan metode fleksible dalam pengambilan data yang memungkinkan anda mencari informasi yang dibutuhkan untuk menjawab pertanyaan tertentu.2 5. memberi tampilan yang jelas terhadap data yang anda inginkan.Klik 2 kali Create Query by Using Wizard .Microsoft Access Query dan Report 5 . Ada 5 macam cara untuk menciptakan sebuah Query pada Microsoft Access 2002 yaitu → Create Query by Using Wizard Menciptakan sebuah query dengan wizard dengan menyeleksi field-field yang dibutuhkan → Create Query in Design View Menciptakan Sebuah Query tanpa menggunakan sebuah wizard → Crosstab Query menciptakan sebuah Crosstab Query yang menampilkan data dalam bentuk Compact atau sebuah spreadsheet → Find duplicates Query Wizard Menciptakan query dari wizard yang mencari record dengan nilai field yag sama dalam satu tabel atau query → Find Unmatched Query Wizard Menciptakan query dari wizard yang mencari record (rows) pada satu tabel yang memiliki record yang tidak berhubungan dengan tabel lain 1. Menciptakan query melalui Create Query by Using Wizard Langkah-langkahnya adalah : .1.

3 Maka akan muncul dialog - - Pilih field yang ada pada Tabel atau Query. Klik Next lalu muncul dialog simple Query Wizard - - Ada 2 pilihan yang ada pada dialog diatas a. . Klik >> jika kita ingin menampilkan semua field yang tersedia. Baru kita isikan judul Query sesuai yag kita inginkan. Detail (Show every field of every record) adalah untuk menampilkan semua field dan semua record datanya b.Microsoft Access Query dan Report 5 . lalu klik > atau klik < untuk membatalkannya. Summary adalah untuk menampilkan ringkasannya Pilih Detail (Show every field of every record) lalu klik Next.

Microsoft Access Query dan Report 5 .4 - Maka akan muncul Query / Tabel yang kita inginkan 2. Menciptakan query melalui Create Query in Design View Hampir sama dengan Menciptakan query melalui Create Query by Using Wizard Langkah-langkahnya adalah : • Buka File database yang kita perlukan . lalu klik Query • Lalu klik 2 kali Create Query in Design View .

tabel-tabel terpilih harus sudah saling berkaitan dalam Relationship. Klik nama tabel sambil menekan Ctrl jika kita memilih lebih dari satu tabel • Klik Coles Untuk menampilkan Jendela kerja Select Query atau klik Toolbar Show Table jika ingin kembali ke kotak dialog Show Table .Microsoft Access Query dan Report 5 .5 • Klik Tables atau Query lalu klik Add. Jika kita memilih lebih dari satu tabel.

6 • Masukkan nama tabel dan field kedalam kolom yang sudah disediakan oleh Query dengan cara klik dua kali pada Tabel yang ada. • Untuk menampilkan karyawan bergolongan 3 maka pada field golongan pada kolom criteria ketik 3m klik Run ( ! ) Pada Toolbar .Microsoft Access Query dan Report 5 .

Microsoft Access Query dan Report 5 .rumus1 : [Uang makan]*[Hari Kerja] .rumus2 : [gaji]+[Expr1]+[ Expr2] lalu klik Run .7 • Setelah klik Run Hasilnya adalah seperti berikut: • Jika ingin menampilkan seluruh penerimaan gaji karyawan maka pada kolom kosong kita buat field baru dengan cara ketikkan rumus : [Uang lembur]*[Jam Lembur] • • Pada kolom kosong berikutnya kita masukkan 2 field baru dengan mengetikkan 2 rumus yaitu: .

. Crosstab Query juga menyediakan kolom kalkulasi yang menyediakan informasi tambahan melalui kalkulasi otomatis.8 • Hasil Run hasilnya adalah : 3.Microsoft Access Query dan Report 5 . Crosstab Query Sebuah Crosstab Query menggunakan format baris dan kolom yang sama seperti sebuah tabel untuk menyediakan analisis rangkuman terhadap informasi.

Jika kita memilih dari satu tabel maka tabeltabel terssebut harus sudah saling berkaitan. Dengan fungsi Report pada Microsoft Access 2002 anda bisa membuat report berpenampilan profesional dalam sekejap. Sebuah report Columnar menampilkan seluruh data dalam satu kolom.Bagian Detail berada antara header halaman dan footer halaman. Membuat Query Jika anda telah mengumpulkan informasi yang relevan dan menatanya dalam tabel. ditambahkan pada halaman terakhir report . anda memerlukan cara untuk membuat report yang mudah dibaca.Header Report terletak dibagian atas halaman pertama yang menampilkan juduk report . - - Klik Next maka akan muncul Report Wizard yang kedua. lalu akan mucul dialog Report Wizard yang pertama Klik nama Tabel yang kita inginkan. query dan form. lalu klik Report Klik dua kali Create Report by Using Wizard.Header Halaman terletak dibagian atas setiap halaman yang menampilkan heading untuk setiap kolom data . . menampilkan record dari tabel atau Query Contoh Pembuatan sebuah report dengan Wizard Langkah-langkah penciptaan Report : Buka File database yang kita inginkan. sementara report tabular menampilkan data sebagai tabel.Footer Halaman terletak dibagian bawah setiap halaman yang menampilkan nomor halaman.9 5.Microsoft Access Query dan Report 5 . Sebuah desain report memiliki beberapa bagian utama : . total jumlah halaman dan tanggal report dicetak .2. pilih salah astu field sebagai field pengelompokan.Footer Report optional yang berisi informasi rangkuman relevan dari report anda (misal : grand total). Anda bisa membuat report yang baik dalam format Columnar atau tabular.

lalu pilih salah satu field yang akan dijadikan dasar sorting (pengurutan).Microsoft Access Query dan Report 5 . lalu klik Summary Options.10 - Klik Next. Pilih Detail and Summary untuk menampilkan detail perincian atau Summary Only untuk menampilkan garis besarnya saja. . misalnya NIP atau Nama. - Akan muncul Dialog Summary Option lalu pilih field dan nilai summary yang diinginkan.

corporate.11 - Lalu akan muncul dialog untuk format layout dan Orientation yang diinginkan untuk laporan - Setelah itu baru kita pilih Style dari laporan kita. Casual . Dimana disana ada 5 pilihan yaitu Bold.Microsoft Access Query dan Report 5 . compact. Formal dan Soft Gray .

Microsoft Access Query dan Report 5 .12 - Klik Next dan kita buat Judul (title) dari Laporan kita - Lalu ada 2 pilhan untuk Preview the report jika kita ingin mengetahui terlebih dahulu tampilan lampiran yang telah kita buat. Lalu klik Finish. Jika ada field –field yang terpotong maka kita harus pindah ke mode design atau Kilk Design lalu drag field sesuai yang diinginkan .

13 Keterangan : • Anda dapat menambahkan Label lain pada laporan pada area Header / Footer. Buka salah satu file yang terdapat pada Object Reports b. Selain itu Diagram juga menawarkan pendiagraman vertikal. Warna yang cerah membedakan sel-sel atau field-field pada sebuah tabel atau query ketika ditampilkan dalam bentuk diagram. dengan Microsoft Access 2002 anda bisa menampilkan informasi yang sama dalam bentuk grafis. pilih salah satu tabel atau Query .langkahnya : a. spherical dan conocal. Lalu ubah Properties Format dari fieldnya 5.3. • Untuk menampilkan Laporan dalam format mata uang rupiah maka pertama anda ubah Regional Setting pada Control Panel. horizontal. Dimana data yang ditampilkan dalam bentuk grafik seringkali lebih jelas daripada dalam bentuk kolom angka-angka. Dan klik Print Preview untuk melihat hasil Laporan anda.Microsoft Access Query dan Report 5 . Langkah. Klik New lalu pilih Chart Wizard. Pada Microsoft Access 2002 menyediakan 20 type diagram pada chart Wizardnya. Menampilkan Data dalam bentuk diagram (Grafik) Setelah anda membuat Query dan Report.

Setelah selesai klik Next .14 c. Pilih jenis grafik yag anda inginkan klik Next e. Pada kotak dialog ini kita dapat mengubah letak data pada grafik dengan men-drag nama field. Pilih field yang diperlukan lalu klik Next d.Microsoft Access Query dan Report 5 .

Untuk melakukan tampilan grafik yang lebih lengkap pilih nama report grafik anda lalu Klik mode Design. Isikanlah Judul dari Grafik yang anda buat. hasilnya adalah berupa grafik seperti dibawah ini.Microsoft Access Query dan Report 5 .15 f. . g. Klik Finish.

.1 BAB 6 Bekerja dengan File External Tujuan : Pada Bab ini mahasiswa akan mempelajari: • Jenis-jenis File External database yang lain • Dapat menghubungkan antara file external dengan Access.Microsoft Access Bekerja dengan File External 6 .

6.File teks seperti yang dibuat pada program pengolah kata atau pengedit teks. Dimana setiap program database mempunyai format tertentu dalam menyimpan informasi sehingga ada kemungkinan tidak kompatibel (sesuai) dengan program database lain yang menyimpan data dalam format yang berbeda. sebagai pilihan mereka untuk menata data. Dan Microsoft Access 2002 tidak hidup sendiri. Untuk menintegrasikannya anda harus me-link database yang kita punya ke file database external tersebut. Me-Link ke Tabel Database Eksternal.Microsoft Access Bekerja dengan File External 6 . spreadsheet dan format file teks lain : . Seperti yang dibuat pada Microsoft IIS . Microsoft Outlook. bukan database. Pada Microsoft Access 2002 anda bisa mengimpor.0 atau yang lebih baru dan Microsoft Access versi sebelumnya. . .2. Microsoft Access 2002 bekerja dengan file database yang dibuat dalam dBASE III atau yang lebih baru. Seperti yang digunakan pada Microsoft SQL Server. Serta bekerja dengan File RTF yang digunakan pada seluruh program dalam Microsoft Office.File Spreadsheet seperti yang dibuat pada Microsoft Excel.File database. Pada menu File pilih Get External Data lalu klik Link Tables Pada daftar Files of type pilih dBASE IV (*. Microsoft Access 2002 juga bekerja pada file Lotus 1-2-3 . . walaupun didesain dengan bagus dapat memenuhi setiap kebutuhan. Sebagian besar orang menggunakan spreadsheet. ada banyak database ralational lain. Database juga bukan satu-satunya cara untuk menata informasi. seperti yang dibuat di Access.File dalam format HTX dan IDC. . Microsoft Exchange.dbf) Coba cari file dbf pada komputer anda. mengexport atau me-link data dari sejumlah database. .File Rich Text.1.2 6. seperti yang dibuat pada halaman Web. Misalnya kita akan memasukkan data dengan format DBF yang biasanya digunakan dalam dBASE. Paradox 3. seperti pada Microsoft Word.0 atau yang lebih baru dan Oracle.Daftar dan Tabel HTML.Link Open Database Connecttivity (ODBC) dan Tabel SQL. Pendahuluan Tidak ada satupun database. Microsoft Access 2002 bekerja dengan link ODBC dan tabel SQL yang dibuat dalam Microsoft Foxpro 2.

tidak berbeda dari tabel yang anda buat sendiri pada Access. Tetapi anda tidak bisa menambah field baru pada tabel external anda. Setelah data diimpor tidak ada koneksi antara sumber data dan tujuannya sehingga setiap perubahan yang dilakukan pada salah satu salinan tabel tidak akan berpengaruh pada salinan lainnya. Dan selalu tersedia. maka file tabel anda ada sebuah icon baru → dB yang menunjukkan bahwa ini merupakan file dBASE yang dilink Sekarang setelah file dbf anda link dengan database anda maka anda hanya bisa mengubah format fieldnya. 6. lalu Klik Close.Microsoft Access Bekerja dengan File External 6 . lalu klik Import Kotak dialog import muncul .3 - - Pilih file anda tersebut lalu klik Link Setelah itu klik Cancel karena tabel yang anda pilih tidak memiliki index yang terhubung.3. Mengimpor table Data yang anda impor menjadi bagian database Microsoft Access 2002. Maka sebuah pesan muncul menginformasikan bahwa tabel anda telah sukses di link Klik Ok. Pada Menu file pilih Get external data.

.Microsoft Access Bekerja dengan File External 6 .4 - Pilih nama file excel yang anda punya maka akan muncul tabel - Maka akan mucul Import Spreadsheet wizard ikuti wizard tersebut maka anda akan menciptakan tabel baru.

Mengekspor table untuk Microsoft Excell Seperti halnya Microsoft Access 2002 bisa mengumpulkan dan bekerja dari sumber lain. karena mereka bisa menghubungkan data secara langsung. Anda tidak perlu berbagi salinan database denagn pengguna Access 97 yang bisa melink database Access 2002 anda. tanpa mengalami masalah karena perbedaan format. Microsoft Access 2002 bisa mengkonversi tabel ke dalam spreadsheet Microsoft Excel 2002 secara langsung menggunakan fasilitas drag-and-drop. Anda bisa menarik tabel manapun dari jendela database pada Microsoft Access 2002 ke workbook excel 2002 yang sedang terbuka. Pada Menu Tools. mengekspor dan me-link.Lalu Pilih file Excel yang akan menerima tabel dari Microsoft Access.Pilih Tabel yang akan diekspor. Untuk mengeksport caranya . Export . . tunjuk Database Utilities.Microsoft Access Bekerja dengan File External 6 . lalu klik kanan tabel tersebut atau pilih menu File.Maka tabel dari Access akan ditampilkan di worksheet baru dari file excel tersebut. dan secara otomatis tabel tersebut menjadi spreadsheet Excel 2002. tunjuk Convert Database lalu klik To Prior Access Database Version. Microsoft Access 2002 juga bisa menyimpan salinan database dalam format Access 97 untuk bekerja bersama dengan pengguna lain yang belum siap meng-upgrade ke Microsoft Access 2002.4. .5 6. Data digunakan bersama antar database dengan mengimport. Microsoft Access 2002 juga bisa bekerja sebagai sumber data bagi program database lain.

1 BAB 7 Bekerja dengan Web Tujuan : Pada Bab ini mahasiswa akan mempelajari: • Fungsi Database di Web • Menghubungkan file Access dengan Web. .Microsoft Access Bekerja dengan Web 7 .

form. Microsoft Access 2002 sekarang memungkinkan database. Dimana setiap orang yang tertarik dengan perusahaan atau produk yang dihasilkan hanya perlu mem-browse situs web perusahaan tersebut dari manapun diseluruh dunia. tabel. lalu klik Pages . Anda menggunakan hyperlink untuk menghubungkan obyek database ke sebuah obyek database lain atau ke file eksternal. Dalam bab ini anda akan menggunakan teknologi Web pada Microsoft Office 2002 untuk menghubungkan database Piksi International ke sumber-sumber daya lain baik dalam database itu sendiri maupun yang ada di lokasi lain di World Wide Web. mempublikasikan obyek database sabagai halaman Web dan menggunakan halaman akses data interaktif. Kita menggunakan file database yang sudah pernah kita buat. query dan report terhubung baik secara lokal maupun global. Integrasi feature Web yang terus meningkat kedalam program komputer sekarang memungkinkannya untuk mengirim.2 7.2.Microsoft Access Bekerja dengan Web 7 .Create data Access page in Design View Yang akan dibahas pada bagian selnajutnya hanya menggunakan Create data Access page by Using Wizard 7.1. Pendahuluan Web adalah kumpulan informasi yang tersedia di Internet yang terhubung oleh hyperlink. menyimpan dan menerima informasi dalam berbagai cara baru.Create data Access page by Using Wizard . Banyak organisasi berbagi informasi dengan suplier mereka. yang memungkinkan anda melompat dari satu dokumen ke dokumen lain atau dari tempat ke tempat dalam satu dokumen. Dimana ada 2 cara untuk membuat page yaitu : . customer mereka atau dengan masyarakat umum dengan membuat alamat permanen di Internet. Membuat halaman data Access dengan Wizard Langkah-langkahnya : a.

Lalu mucul dialog pemilihan field apa yang diinginkan sebagai dasar Sorting (pengurutan) record. .3 b. Lalu tekan Next. Lalu klik Next d. c. Pilih field-field dari Tabel atau Query yang sudah kita ciptakan.Microsoft Access Bekerja dengan Web 7 . Klik pilihan Create data Access page by Using Wizard.

Microsoft Access Bekerja dengan Web 7 . Lalu ketik judul dari pages yang ingin anda tampilkan. f. Selanjutnya ada 2 pilihan untuk menampilkan dalam tampilan page view atau dalam tampilan Design. Lalu klik Finish dan hasilnya akan seperti tampilan dibawah ini. .4 e.

Create New Page : Jika anda ingin menghubungkan teks yang kita pilih dengan page baru yang dapat diedit kemudian atau diedit saat itu juga. . Theme lalu pilih Theme Sesuai yang dibutuhkan 7.4.3.Microsoft Access Bekerja dengan Web 7 .Existing File Or Web Page : Jika anda ingin menghubungkan teks yang kita ketik dengan File atau halaman web yang sudah ada. Adalah dengan cara klik menu Format. 7.. Menghapus Hyperlink. Menampilkan Hyperlink pada Design Page.Page in This Database : Jika anda ingin menghubungkan teks yang kita pilih dengan bagian-bagian pada database yang sedang aktif.5 7. . lalu klik Hyperlink.5. Ada 4 pilihan dalam dialog yaitu : . Hyperlink lalu pada kotak Edit Hyperlink klik Remove Link . . Mengubah format Theme pada Design Page. Adalah dengan cara klik menu Insert. Adalah dengan memilih teks yang akan dihapus hyperlinknya lalu pilih Menu Insert.E-mail Address : Jika anda bermaksud menghubungkan teks yang kita pilih dengan salah satu alamat email.

Sistem Informasi Manajemen Fisilitas Command Boxes dan Macro 8 . .1 BAB 8 Fasilitas Command Boxes dan Macro Tujuan : Pada Bab ini mahasiswa akan mempelajari: • Cara menggunakan Command Boxes • Cara menggunakan Macro pada Access.

diantaranya penggunaan fungsi-fungsi berikut : .Command button sebagai penutup Form Sebelumnya kita buat tabel jual dan tabel beli 1. Struktur Tabel Beli adalah 2. Struktur Tabel Jual adalah .2 8. yang dapat langsung kita aplikasikan untuk menjalankan suatu aksi. Pendahuluan Microsoft Access 2002 menyediakan sekitar 30 jenis fungsi Command button.1.Sistem Informasi Manajemen Fisilitas Command Boxes dan Macro 8 .Command button sebagai pengontrol record .

dan kotak Action pilih Go To Previous Record.3 8. selanjutnya Next dan Finish .Sistem Informasi Manajemen Fisilitas Command Boxes dan Macro 8 . Command Button Sebagai pengontrol Record Langkah-langkahnya : .Akan muncul Command Button wizard - Untuk kotak Categories pilih Record Navigation.2.Buat Form Data beli dan Data jual seperti pada bab3 yang hasilnya seperti .Untuk Penambahan Button “Record sebelumnya“ menggunakan Command Button .

Lalu simpan Macro dengan nama Macro1 5.3.4 8. Ada 3 kolom yaitu Macro Name. Action dan Comment. Selanjutanya Buat Tampilan Form seperti ini . klik Macro lalu klik New akan Muncul Kotak dialog macro dimana ada 3 Jendela yaitu .4. tombol pada toolbar. Command Button Sebagai penutup Record Untuk Penutup Form lakukan hal yang sama seperti pada pengontrol record tetapi pada Untuk kotak Categories pilih Form Operation. Setelah itu Close(X) untuk menutup dialog Macro 4. 8. kombinasi kunci atau dari macro lain.Comment : Komentar dari perintah yang digunakan .Action : Isilah dengan nama field perintah yang akan anda gunakan . dan kotak Action pilih close form. On click pada kontrol properti. Macro berisi sejumlah aksi berbentuk perintah yang dapat mengotomatisasikan operasi setiap kali bekerja dengan cara yang sama. macro dapat dijalankan dari form atau report melalui Command button. selanjutnya Next dan Finish sekarang bisa di preview. Pada Jendela database. Macro Adalah sarana untuk membuat rangkaian perintah yang otomatis.Sistem Informasi Manajemen Fisilitas Command Boxes dan Macro 8 . Langkah-langkah pembuatan macro : 1.Action Argument : Properties dari Action yang diberikan 2. Lalu klik toolbar Macro Names muncul dialog macro 3.

Dengan Pilihan Onclicknya adalah Macro1.5 Langkah-langkah pembuatan form . Pilih properties.Sedangkan Untuk Command Button Keluar pilih Macro1.Beli .Lakukan hal yang sama untuk Button Penjualan. Lalu jalankan Form View .Keluar 6.Pada pilihan On Click pilih Macro1.Buatlah Tombol Macro Pembelian diarea Detail dengan Command Button.Jual . klik Event .Ketik Judul pada area Form Header : Pembelian dan Penjualan .Sistem Informasi Manajemen Fisilitas Command Boxes dan Macro 8 .

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->