P. 1
Tutorial Visual Basic

Tutorial Visual Basic

5.0

|Views: 5,911|Likes:
Published by Endo

More info:

Published by: Endo on Sep 13, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

11/30/2013

pdf

text

original

MENGENAL MICROSOFT VISUAL BASIC

A. Sekilas Mengenai Visual Basic

V
seperti :

isual Basic pada dasarnya adalah sebuah bahasa pemrograman komputer. Bahasa pemrograman adalah perintah-perintah atau instruksi-instruksi yang dimengerti oleh komputer untuk melakukan tugas-tugas tertentu. Visual Basic kini seakan-akan

menjadi kiblat bagi para software developer, dan menjadi salah satu bahasa yang wajib dipelajari oleh berbagai kalangan. Visual Basic (yang sering juga disebut dengan VB) selain disebut sebagai sebuah bahasa pemrograman, juga sering disebut sebagai sarana (tool) untuk menghasilkan program-program aplikasi berbasiskan windows. Beberapa kemampuan atau manfaat dari Visual Basic diantaranya  Untuk membuat program aplikasi berbasis Windows.  Untuk membuat objek-objek pembantu program seperti misalnya kontrol ActiveX, file Help, aplikasi Internet, dan sebagainya.

 Menguji program (debugging) dan menghasilkan program akhir berakhiran EXE yang
bersifat executable, atau dapat langsung dijalankan. Bagi programmer pemula yang baru ingin belajar program, limgkungan Visual Basic dapat membantu membuat program berbasis Windows dengan sekejap mata. Sedang bagi programmer tingkat lanjut, kemampuannya yang besar dapat digunakan untuk membuat program-program yang kompleks, misalnya seperti dalam lingkungan networking atau clientserver. Bahasa Visual Basic cukup sederhana dan menggunakan kata-kata bahasa Inggris yang umum digunakan. Andapun tidak perlu lagi menghapalkan sintaks-sintaks maupun formatformat bahasa yang bermacam-macam. Di dalam Visual Basic semuanya sudah disediakan dalam pilihan-pilihan yang tingal diambil sesuai kebutuhan. Selain itu sarana pengembangannya yang bersifat visual memudahkan anda untuk mengembangkan program aplikasi berbasis Windows, bersifat mouse-driven (digerakkan dengan mouse), dan berdaya guna tinggi. Visual Basic adalah sebuah sarana pembuat program yang lengkap namun mudah. Siapapun yang bisa menggunakan Windows, ia pasti bisa membuat program dengan Visual

1

Basic. Anda hanya perlu tahu cara menggunakan mouse, memanipulasi jendela, serta logika pemrograman untuk membuat sebuah aplikasi Visual Basic. Sejak dikembangkan pada tahun 1980-an, Visual Basic kini telah mencapai versinya yang ke-6. Beberapa keistimewaan utama dari Visual Basic 6.0 ini diantaranya seperti :

1. Menggunakan platform pembuatan program yang diberi nama Developer Studio, yang
memiliki tampilan dan sarana yang sama dengan Visual C++ dan Visual J++. Dengan begitu Anda dapat bermigrasi atau belajar bahasa pemrograman lainya dengan mudah dan cepat, tanpa harus belajar dari awal lagi.

2. Memiliki compiler andal yang dapat menghasilkan file executable yang lebih cepat dan
lebih efisien dari sebelumnya. 3. Memiliki beberapa tambahan sarana Wizard yang baru. Wizard adalah sarana yang mempermudah di dalam pembuatan aplikasi dengan mengotomatisasi tugas-tugas tertentu. 4. Tambahan kontrol-kontrol baru yang lebih canggih serta peningkatan kaidah struktur bahasa Visual Basic. 5. Kemampuan membuat ActiveX dan fasilitas Internet yang lebih banyak. 6. Sarana akses data yang lebih cepat dan andal untuk membuat aplikasi database yang berkemampuan tinggi. 7. Visual Basic 6.0 memiliki versi atau edisi yang disesuaikan dengan kebutuhan pemakainya. Seperti aplikasi-aplikasi komersil lainnya, Visual Basic juga dipasarkan dalam berbagai jenis atau versi. Beberapa versi dari Visual Basic 6.0 yang ada di pasaran diantaranya adalah :  Standard Edition/Learning Edition Ini adalah versi standar yang sudah mencakup berbagai sarana dasar dari Visual Basic 6.0 untuk mengembangkan aplikasi.  Professional Edition Versi ini memberikan berbagai sarana ekstra yang dibutuhkan oleh para programmer professional. Misalnya seperti kontrol-kontrol tambahan, dukungan untuk pemrograman internet, compiler untuk membuat file Help, serta sarana pengembangan database yang lebih baik.  Enterprise Edition 2

Versi ini dikhususkan untuk para programmer yang ingin mengembangkan aplikasi remote computing atau client/server. Biasanya versi ini digunakan untuk membuat aplikasi pada jaringan.

B. Menjalankan Visual Basic 6.0
Visual Basic juga merupakan sebuah program aplikasi Windows. Oleh sebab itu, Anda juga harus menjalankannya dari dalam Windows dari menu Start >Program >Microsoft Visual Studio 6.0 >Microsoft Visual Basic 6.0, seperti gambar berikut :

Sebuah kotak dialog seperti pada Gambar 1.1 akan muncul saat Anda memulai Visual Basic. Disini Anda bisa memilih jenis aplikasi yang akan Anda buat dengan Visual Basic. Biasanya untuk membuat program aplikasi standar, pilihlah Standard EXE, lalu klik tombol Open.

Gambar 1.1 Kotak dialog New Project

C. Lingkungan Visual Basic 6.0
3

Setelah Visual Basic dijalankan, akan muncul sebuah layar seperti Gambar 1.2. Layar ini adalah lingkungan pengembangan aplikasi Visual Basic yang nantinya akan Anda gunakan untuk membuat program-program aplikasi pada Visual Basic.
Menu Control Menu Toolbar Project Tool box Properties Window

Form Window

Form Layout Window

Gambar 1.2 Lingkungan Visual Basic 6.0

Layar Visual basic adalah suatu lingkungan besar yang terdiri dari beberapa bagian-bagian kecil yang kesemuanya memiliki sifat :

 Floating : dapat digeser-geser ke posisi mana saja. Untuk menggeser elemen layar Visual
Basic , klik dan tahan tombol mouse pada judul (Title Bar) elemen tersebut, lalu geserlah ke tempat yang diinginkan.

 Sizeable

: dapat diubah-ubah ukurannya, seperti Anda mengubah ukuran jendela

Windows. Untuk mengubah ukuran suatu elemen atau jendela, klik dan tahan tombol mouse pada sisi (border) jendela tersebut, lalu geserlah hingga ke ukuran yang diinginkan.

 Dockable :

dapat menempel dengan bagian lain yang berdekatan. Untuk menempelkan

elemen layar Visual basic ke elemen lainnya, cukup tempelkan sisi-sisi elemen tersebut, dan secara otomatis akan menempel ke tempat yang anda inginkan.

4

D. Control Menu
Control Menu adalah menu yang digunakan terutama untuk memanipulasi jendela Visual Basic. Dari menu ini Anda bisa mengubah ukuran, memindahkan, atau menutup jendela Visual Basic atau jendela Windows lainnya. Untuk mengaktifkan Control Menu ini, klik tombol mouse pada pojok kiri atas jendela seperti pada gambar 1.3.
Restore : mengubah ukuran jendela ke ukuran sebelumnya Move : untukmemindahkan letak jendela. Size : untuk mengubah ukuran jendela. Minimize : untuk meminimalkan ukuran jendela. Maximize : untuk memaksimalkan ukuran jendela. Close : untuk menutup jendela.

Gambar 1.3 Jendela Control Menu

E. Menu
Menu Visual Basic berisi semua perintah Visual Basic yang dapat Anda pilih untuk melakukan tugas tertentu. Untuk memilih menu pada Visual Basic dapat dilakukan dengan :  Klik mouse pada menu dan submenu.

 Tekan ALT dan karakter bergaris bawah untuk memilih menu. Misalnya ALT+F untuk
membuka menu File.

 Beberapa perintah juga memiliki shortcut
untuk membuat proyek baru dan sebagainya.

(tombol cepat), seperti misalnya CTRL+N

Gambar 1.4 Menu pada Visual Basic

F. Toolbar

5

Toolbar adalah tombol-tombol yang mewakili suatu perintah tertentu dari Visual Basic. Setiap tombol tersebut dapat langsung diklik untuk melakukan perintah tertentu. Biasanya tombol-tombol ini merupakan perintah-perintah yang sering digunakan dan tedapat pula pada menu Visual Basic. Untuk menampilkan macam-macam toolbar yang ada, pilih menu View >Toolbars.
Add Project : menambahkan proyek ke dalam proyek yang sudah ada. Add Item : menambahkan komponen atau objekke dalam jendela Form. Menu Editor : menampilkan Menu Editor untuk mengubah tampilan menu. Open Project : membuka proyek Visual Basic yang sudah ada. Save Project Group : menyimpan proyek Visual basic yang sudah ada. Cut : memotong elemen yang dipilih pada layar. Copy : meng-copy elemen yang dipilih pada layar. Paste : menyalin elemen yang sebelumnya sudah dipotong (cut) atau disalin (copy). Find : mencari teks tertentu. Undo : membatalkan perintah atau tindakan yang terakhir. Redo : mengulangi perintah atau tindakan terakhir yang dibatalkan. Start : menjalankan proyek yang dibuat pada Visual Basic. Break : menghentikan running program untuk sementara. End : menhentikan running program. Project Explorer : menampilkan jendela Project Explorer. Properties Window : menampilkan jendela properties. Form Layout Window : menampilkan jendela Form Layout Window. Object Browser : menampilkan jendela Object Browser. Toolbox : menampilkan jendela Toolbox. Data View Window : menampilkan jendela Data View Window. Visual Component Manager : menampilkan jendela Visual Component Manager.

6

G. Form Window
Form Window atau jendela Form adalah daerah kerja utama, dimana Anda akan membuat program-program aplikasi Visual Basic. Pada form ini, Anda akan meletakkan berbagai macam objek interaktif seperti teks, gambar, tombol-tombol perintah, scrollbar, dan sebagainya. Jendela form ini pada awalnya kelihatan kecil, tetappi ukurannya bisa diubah-ubah sesuai dengan kebutuhan aplikasi anda. Apabila program aplikasi Anda dijalankan, semua yang terdapat di dalam Form akan ditampilkan pada layar Window. Jendela Form inilah yang nantinya akan menjadi latar belakang dari aplikasi Anda.

Gambar 1.5 Jendela Form dan Form yang sudah jadi dan dijalankan

H. Toolbox
Toolbox adalah sebuah “kotak peranti” yang mengandung semua objek atau kontrol yang dibutuhkan untuk membentuk suatu program aplikasi. Kontrol adalah suatu objek yang akan menjadi interface (penghubung) antara program aplikasi dan user-nya, dan kesemuanya harus diletakkan di dalam jendela Form. Apabila Anda pertama kali menjalankan Visual Basic, maka Toolbox akan ditampilkan di sebelah kiri layar dan berisi objek-objek standar yang akan selalu muncul setiap kali Visual Basic dijalankan. Untuk menambahi objek pada Toolbox ini dengan memilih menu Project >Components. Jika Anda menggunakan Visual Basic versi Professional Edition atau Enterprise Edition , ada beberapa objek lain yang bisa ditambahkan yang tidak terdapat pada Standard Edition.

7

Pointer Label Frame Check Box Combo Box Horizontal Scrollbar Timer Directory List Box Shape Image OLE

Picture Box Text Box Command Button Option Button List Box Vertical Scrollbar Drive List Box File List Box Line Data ADODC

Gambar 1.6 Toolbox Standard pada Visual Basic

I. Project Exporer
Jendela Project Explorer adalah jendela yang mengandung semua file di dalam aplikasi Visual Basic Anda. Setiap aplikasi dalam Visual Basic disebut dengan istilah project (proyek), dan setiap proyek bisa mengandung lebih dari satu file. Pada Project Explorer ditampilkan semua file yang terdapat pada aplikasi (proyek) Anda, misalnya form, modul, class dan sebagainya.

Gambar 1.7 Jendela Project Explorer

J. Jendela Properties
Jendela Properties adalah jendela yang mengandung semua informasi mengenai objek yang terdapat pada aplikasi Visual Basic Anda. Properti adalah sifat dari sebuah objek, misalnya seperti namanya, warna, ukuran, posisi dan sebagainya. 8

Anda akan mengatur bentuk dan karakteristik dari setiap objek melalui jendela Properties ini. Di bagian paling atas dari jendela properties ini terdapat kotak yang menunjukkan nama objek yang sedang aktif, sedang propertinya ditampilkan di bagian bawah dari jendela Properties tersebut.

Gambar 1.8 Jendela Properties

K. Form Layout Window
Form Layout Window adalah jendela yang menggambarkan posisi dari form yang ditampilkan pada layar monitor. Posisi form pada Form Layout Window inilah yang merupakan petunjuk dimana aplikasi anda akan ditampilkan pada layar monitor saat dijalankan nanti.

Gambar 1.9 Form Layout Window

Anda bisa menampilkan Form Layout Window ini dengan memilih menu View > Form Layout Window.

L. Jendela Code
9

Jendela Code adalah salah satu jendela yang penting di dalam Visual Basic. Jendela ini berisi kode-kode program yang merupakan instruksi-instruksi untuk aplikasi Visual Basic Anda. Setiap objek pada Visual Basic dapat Anda tambahi dengan kode-kode program untuk melakukan tugas-tugas tertentu, misalnya menutup aplikasi, membatalkan perintah dan sebagainya.

Gambar 1.10 Jendela Code

Pada saat Anda menjalankan Visual Basic, jendela ini tidak akan ditampilkan pada layar. Untuk menampilkannya, ada beberapa cara yaitu :

 Pilih menu View >Code
 Klik ganda objek tertentu pada Form Window, atau

 Klik kanan pada komponen yang diinginkan, lalu pilih View Code.

Kontrol dan Properti
Kontrol

10

Adalah salah satu objek atau komponen suatu aplikasi yang diletakkan di dalam form untuk membentuk suatu program aplikasi. Seluruh kontrol pada Visual Basic terdapat pada Toolbox. Setiap kontrol yang dibuat atau diletakkan pada form secara otomatis telah diberi nama yaitu sebagai berikut : Awalan Cbo Chk Cmd Dir Drv Fil Fra Frm Grd Hsb Img Lbl Lin Lst Mnu Ole Opt Pic Shp Tmr Txt Vsb Kontrol Combo box Check box Command button Directory list box Drive list box File list box Frame Form Grid Horizontal scrollbar Image Label Line List box Menu OLE client Option button Picture box Shape Timer Text box Vertical scrollbar

Misalnya jika membuat kontrol Command button maka dinamai dengan cmdTombol, cmdOK, cmdCancel. Untuk merubah nama kontrol yaitu pada jendela Properties pilih Name yang terletak di bagian paling atas kemudian ganti dengan nama yang baru. Array Kontrol Adalah sekelompok kontrol-kontrol yang memiliki nama yang sama. Untuk membedakan digunakan bilangan indeks yang dimulai dari nol. Contoh : Command1(0) Command1(1) Command1(2)

Array kontrol terbentuk apabila suatu kontrol dicopy kedalam form yang sama. 11

Contoh program : 1. Buat suatu proyek Visual Basic baru 2. Klik ganda kontrol CommandButton pada Toolbox 3. Pilih kontrol CommandButton tersebut pada jendela form, tekan CTRL C lalu tekan CTRL V kemudian pilih YES 4. Ulangi langkah di atas untuk membuat kontrol array lagi 5. Klik ganda pada salah satu tombol tersebut dan ketik code program di bawah ini : Private Sub Command1_Click(Index As Integer) Command1(0).Caption = "Hallo, Apa Kabar?" Command1(1).Caption = "Belajar Membuat Array Kontrol" Command1(2).Caption = "Di Kelas 1.02" End Sub 6. Jalankan aplikasi dengan menekan tombol F5 dan klik salah satu tombolnya. 7. Hasil :

Properti Adalah atribut yang melekat pada sebuah objek yang biasanya merupakan karakteristik penampilannya seperti warna, jenis huruf, ukuran dan sebagainya. Untuk memberikan nilai pada properti yang telah dipilih yaitu : 1. Mengetikkan langsung, misal jika ingin mengubah Nama maka klik properti Name lalu ketik nilai yang baru kemudian tekan enter. 2. Memilih dari daftar, yaitu dengan menekan tombol panah bawah disebelah kanan properti tersebut. Misal pada Form mempunyai properti BorderStyle yang memiliki nilai 0-None, 1-Fixed Single, 2-Sizeable dan sebagainya. Klik pada salah satu nilai untuk memilihnya.

12

3. Memilih dari daftar bertumpuk, sama seperti di atas yaitu dengan menekan tombol panah disebelah kanan properti tersebut tetapi biasanya memiliki banyak tab pilihan. 4. Memilih dari kotak dialog, yaitu dengan menekan tombol elipsis gaya huruf. 5. Melalui program Cara ini disebut mengubah nilai properti pada saat runtime (saat program dijalankan). Sintaks : nama objek.nama properti = nilai properti Contoh : cmdTombol.Caption = “Cancel” label1.FontColor = vbRed disebelah kanan properti tersebut. Misalnya pada properti Font untuk merubah jenis huruf, ukuran dan

FORM dan LABEL
 Form Adalah sebuah objek di dalam aplikasi Visual Basic. Form disebut sebagai objek ayah (parent objek) karena menjadi tempat untuk meletakkan objek-objek lain di dalam aplikasi. Event (kejadian) yang paling sering digunakan adalah : 1. Load yaitu event yang akan menjalankan prosdur event (kode program) yang terdapat didalamnya pada saat form pertama kali dijalankan. 2. Unload yaitu event yang akan menjalankan prosedur event pada saat form tersebut ditutup. Sintaks : Load NamaForm Unload NamaForm atau Unload Me Contoh : Load FrmForm1 (membuka form bernama FrmForm1) Unload FrmForm1 (menutup form bernama FrmForm1) Unload Me (menutup form yang sedang aktif) Untuk menampilkan form dilayar komputer digunakan perintah Show Contoh :  Label 13 Form1.Show

Berfungsi untuk menampilkan teks atau tulisan pada aplikasi. Label hampir tidak pernah membutuhkan pemograman apapun. Properti Label yang umum digunakan : Alignment AutoSize BackColor BackStyle BorderStyle Perataan teks (rata kiri, rata tengah atau rata kanan) Secara otomatis mengubah pembatas kontrol menyesuaikan dengan besarnya teks Warna latar belakang 0-Transparent (transparan/tembus pandang) 1-Opaque (tidak tembus pandang) Menentukan pembatas di sekeliling label 0-None (tidak ada pembatas) Caption Enabled Font ForeColor Height MousePointer ToolTipText Visible WordWrap 1-Fixed Single (pembatas garis tunggal) Teks yang akan ditampilkan pada Label Menentukan apakah label tersebut aktif Mengubah jenis dan ukuran huruf untuk label Warna teks dari Label Tinggi Label Menentukan bentuk kursor mouse apabila diletakkan di atas Label Teks yang muncul pada apabila mouse diletakkan di atas Label Menampilkan/menyembunyikan Label Menentukan apakah ukuran kontrol Label akan menyesuaikan dengan teks Caption-nya label agar

TOMBOL
 Command Button Fungsi dari tombol ini biasanya untuk mengeksekusi perintah tertentu seperti : • • • • • Menyetujui atau menjalankan suatu perintah (tombol OK) Kaluar dari aplikasi (tombol Exit) Membatalkan perintah (tombol Cancel) Menerapkan perubahan (tombol Apply) Membuka file (tombol Open) dan sebagainya.

Properti CommandButton yang paling utama adalah Name dan Caption 14

Event yang digunakan biasanya click() yaitu menjalankan atau mengeksekusi suatu perintah dengan satu kali klik. Untuk membuat tombol Exit ketikkan kde programnya sebagai berikut : Private Sub Command1_Click() End End Sub  Option Button Adalah sebuah kontrol dimana user dapat memilih salah satu dari beberapa pilihan-pilihan yang ada. Pilihan ini sifatnya tunggal, artinya user tidak dapat memilih lebih dari satu pilihan . Apabila user mengklik pada pilihan lain, maka pada tombol pilihan pertama yang sudah diklik akan dimatikan pilihannya (deselect) Properti yang penting yaitu : • Alignment, berfungsi untuk menentukan letak tombol Option Button pada teks 0-Left Justify (tombol berada di sebelah kiri teks) 1-Right Justify (tombol berada di sebelah kanan teks) • Value, Ubah menjadi 1-True agar Option Button sudah terpilih pada saat aplikasi dijalankan Contoh : 1. Buat form sebagai berikut :

2. Ubah Properti tiap kontrol 15

Kontrol Form Label1 Option1 Option2 Option3 Command1

Properti Caption Caption Caption Caption Caption Caption

Nilai Merubah Warna Teks STMIK JAKARTA Merah Hijau Biru Keluar

3. Ketikkan program di bawah ini : Private Sub Command1_Click() End End Sub Private Sub Option1_Click() Label1.ForeColor = vbRed End Sub Private Sub Option2_Click() Label1.ForeColor = vbGreen End Sub Private Sub Option3_Click() Label1.ForeColor = vbBlue End Sub  Check Box (Kotak Cek) Adalah sebuah kontrol pemilihan yang fungsinya hampir sama dengan Option Button, hanya saja pada Chek Box, bisa dipilih lebih dari satu buah pilihan. Properti yang penting yaitu : • Value, digunakan untuk menentukan nilai dari item yang secara default dipilih pada saat aplikasi dijalankan 0-Uncheck (item tidak dipilih) 1-Check (item dipilih)

16

2-Grayed (item berwarna abu-abu dan dipakai jika ingin menampilkan pilihan yang tidak dapat dipilih) • Style, digunakan untukmenentukan jenis dari Check Box 0-Standard (kontrol bergaya standar) 1-Graphical (kontrol mirip dengan Command Button) Contoh : 1. Buat Form sebagai berikut :

2. Ubah properti tiap kontrol Kontrol Form1 Label1 Check1 Check2 Check3 Check4 Command1 Properti Caption Caption Caption Caption Caption Style Caption Style Caption Nilai Latihan Check Box Mengubah Teks dengan Check Box Tebal Garis Bawah Teks Merah 1-Graphical Teks Besar 1-Graphical Keluar

3. Ketikkan program di bawah ini : Private Sub Check1_Click() If Check1.Value = vbChecked Then Label1.FontBold = True Else If Check1.Value = vbUnchecked Then Label1.FontBold = False End If 17

End If End Sub Private Sub Check2_Click() If Check2.Value = vbChecked Then Label1.FontUnderline = True Else If Check2.Value = vbUnchecked Then Label1.FontUnderline = False End If End If End Sub Private Sub Check3_Click() If Check3.Value = vbChecked Then Label1.ForeColor = vbRed Else If Check3.Value = vbUnchecked Then Label1.ForeColor = vbBlack End If End If End Sub Private Sub Check4_Click() If Check4.Value = vbChecked Then Label1.FontSize = 14 Else If Check4.Value = vbUnchecked Then Label1.FontSize = 10 End If End If End Sub

18

Private Sub Command1_Click() End End Sub

Kontrol Tambahan
 Frame (Bingkai) Adalah kontrol pada Visual Basic berupa bingkai segi empat yang berfungsi mengakomodasi (menjadi tempat meletakkan) kontrol-kontrol yang lain. Semua kontrol yang diletakkan di dalam Frame akan dianggap sebagai satu kelompok. Frame dibuat terlebih dahulu sebelum kontrol lain diletakkan diatasnya sebab jika dibuat kontrol terlebih dulu maka kontrol tersebut tidak akan menjadi bagian dari Frame. Tanda sebuah kontrol sudah menjadi bagian dari Frame adalah kontrol tersebut akan ikut bergeser jika posisi Frame dipindahkan.

19

Contoh :

 Scrollbar (Penggulung) Adalah sebuah kontrol penggulung yang terdapat disisi suatu jendela. Ada dua macam jenis Scrollbar yaitu Vertical Scrollbar dan Horizantal Scrollbar. Fungsi dari Scrollbar ini pada umumnya adalah untuk menggulung teks pada layar atau mengubah nilai sebuah kontrol. Elemen-elemen pada Scrollbar ; Kotak Penggulung Ruang Penggulung

Panah Penggulung

Properti Scrollbar yang umum digunakan Min Max SmallChange LargeChange Value Contoh: Menentukan nilai terendah dari range Scrollbar Menentukan nilai tertinggi dari range Scrollbar Besarnya perubahan nilai saat user meng-klik panah pada Scrollbar Besarnya perubahan nilai saat user meng-klik ruang penggulung pada Scrollbar Besarnya nilai (dalam integer) yang mewakili posisi dari Scrollbar

20

Scrollbar yang menggulung nilai dari 100 sampai 1000. Jika user meng-klik panah maka nilai menaik dalam kelipatan 1 dan jika user meng-klik ruang kosong maka nilai akan menaik dalam kelipatan 10. Propertinya adalah : Min Max : 100 : 1000

SmallChange : 1 LargeChange : 10 Event ScrollBar Satu-satunya event yang digunakan adalah Change(). Event ini terjadi apabila user meng-klik salah satu elemen pada ScrollBar sehingga nilai didalam ScrollBar berubah. Contoh :

21

1. Buat form sebagai berikut :

2. Ubah properti tiap kontrol sebagai berikut : Kontrol Form Label1 Label2 Label3 Text1 Vscroll1 Hscroll1 Command1 Properti Caption Caption Caption Caption Text Max Min Max Min Caption Nilai Program ScrollBar Nilai Vertikal ScrollBar (Dikosongkan) Besar Huruf (Dikosongkan) 32767 0 72 1 Keluar

3. Ketikkan program di bawah ini : Private Sub VScroll1_Change() Label2.Caption = VScroll1.Value End Sub

Private Sub HScroll1_Change() Label2.FontSize = HScroll1.Value 22

Text1.Text = HScroll1.Value End Sub Private Sub Command1_Click() End End Sub  Timer Adalah kontrol yang berfungsi menghitung waktu pada Visual Basic. Kontrol ini menggunakan jam internal yang terdapat pada komputer. Pada saat program dijalankan, kontrol Timer tidak akan tampak pada layar Form, karena ia hanya berjalan pada latar belakang untuk menghitung waktu. Properti Timer Properti timer yang utama adalah Enabled yang membuat Timer mulai menghitung waktu jika nilainya True dan berhenti menghitung waktu jika nilainya False. Sedangkan properti Interval berfungsi mengaktifkan event Timer() jika nilai di dalamnya dilampaui. Properti Interval memiliki nilai 1 sampai 65,535. Contoh : Timer1.Interval = 500, artinya 500/1000 detik atau 0,5 detik Timer1.Interval = 1000 artinya 1000/1000 detik atau 1 detik

1. Buat form sebagai berikut :

23

2. Ubah properti tiap kontrol sebagai berikut : Kontrol Form Label1 Label2 Label3 Label4 Timer1 Command1 Properti Caption Caption Caption Caption Caption Enabled Interval Caption Nilai Program Jam Waktu Menunjukkan Pukul : (dikosongkan) Sekarang Tanggal : (dikosongkan) True 1 Keluar

3. Ketikkan program di bawah ini : Private Sub Command1_Click() pesan = MsgBox("Apakah anda yakin ? ", vbYesNoCancel, "Peringatan") If (pesan = vbYes) Then End End Sub Private Sub Timer1_Timer() Label2.Caption = Time() Label4.Caption = Format(Now, "DD MMMM YYYY") End Sub

Pengelolaan Data pada Visual Basic

Data 24

Adalah Bentuk jamak dari bahasa Latin datum, yang berarti item informasi. Berdasarkan pemakaian, satu item informasi harus disebut sebuah datum, dan lebih dari satu item informasi disebut data. Dalam praktek kadang-kadang data digunakan untuk menyatakan bentuk tunggal maupun jamak untuk kata benda dari data. Kumpulan dari data akan menjadi Informasi. Field Adalah lokasi pada record untuk menyimpan suatu jenis data. Misalnya NPM dapat mempunyai field untuk menyimpan tahun angkatan, jurusan dan nomor urut mahasiswa. Masing-masing field mempunyai spesifikasi sendiri mengenai panjang maksimum dan jenis data (misalnya karakter atau numerik) yang dapat dimasukkan ke dalamnya. Pada sistem database relational, field disebut column. Record Sebagai kata kerja berarti merekam informasi, biasanya pada file. Sebagai kata benda, Struktur data yang merupakan koleksi field (unsur), masing-masing dengan nama dan jenisnya sendiri-sendiri. Berlainan dengan array (deret), yang unsur-unsurnya diakses menggunakan indeks, unsurunsur record diakses dengan nama. Record dapat diakses sebagai unit kolektif unsur, atau unsur-unsur dapat diakses secara individual. File Adalah suatu koleksi informasi yang lengkap, misalnya program, himpunan data yang digunakan oleh program, atau dokumen yang dibuat oleh operator. File merupakan unit dasar penyimpanan yang memungkinkan komputer membedakan satu himpunan informasi dengan yang lain. File dapat atau tidak dapat disimpan dalam bentuk yang dapat dibaca oleh manusia, tetapi masih merupakan perekat yang mengikat kumpulan instruksi, bilangan, kata-kata, atau gambar menjadi suatu kesatuan yang dapat dipanggil, diubah, dihapus, direkam atau diberikan kepada alat output oleh operator. 25

Database Adalah kumpulan sebuah file yang terdiri atas sejumlah record (atau tabel), masing-masing terbentuk dari field (kolom) dari tipe tertentu dan kumpulan operasi yang memudahkan pencarian, penyimpanan, kombinasi ulang dan aktivitas sejenisnya.

Field

Record

File

Database

Contoh : File Mahasiswa pada Database Mahasiswa STI&K NPM 10494570 10494571 10494572 dst... Field NAMA` Adi Budi Didi dst... UTS 75 65 85 dst... UAS 85 50 55 dst...

Record

Menggunakan Visual Data Manager
Jika kita ingin membuat suatu program manajemen database pada Visual Basic, kita memerlukan file database yang akan diproses. File database ini dibuat satu kali saja dan tidak perlu langsung diisi recordnya (dibuat struktur databasenya saja). Selanjutnya file database tersebut diproses lewat program. Untuk membuat file database, Anda dapat menggunakan program Visual Data Manager (VISDATA) atau program lain, misalnya Microsoft Access. 26

Cara memanggil Visual Data Manager adalah sebagai berikut :

1. Pilih menu Add-ins pada menu utama. 2. Pilih Visual Data Manager. 3. Pilih menu File >New >Microsoft Access > Version 7.0 MDB 4. Setelah itu, Anda akan diminta untuk memberikan nama file dan lokasi data yang akan
disimpan. Perhatikan bahwa satu file database dapat berisi beberapa tabel. Jadi, misalnya Anda akan membuat tiga tabel database untuk data mahasiswa, maka Anda dapat memberi nama databasenya Mahasiswa.MDB, yang nantinya dapat berisi tabel database Siswa, Mtkuliah dan Nilai.

5. Setelah Anda tentukan nama databasenya pilihlah Save. Tunjuk tulisan Properties lalu
klik kanan dan pilih New Table.

6. Ketik tulisan Siswa pada Table Name lalu klik Add Field untuk menambahkan field
seperti pada gambar

27

7. Ketik NPM pada kolom Name sebagai nama field yang pertama. Field ini nantinya akan
diisi data Nomor Pokok Mahasiswa. Pilih Text pada kolom Type untuk menentukan tipe data field NPM. Tentukan lebar data pada kolom Size dengan angka 8. Pilih Option Button pada pilihan FixedField agar lebar field bersifat tetap, sehingga tidak dapat diubah pada saat program dijalankan. Lalu klik OK. 8. Ulangi langkah tadi untuk field-field selanjutnya. Nama Field Nama JK Alamat Kota Kode Pos Telpon Tipe Text Text Text Text Text Text Lebar 20 1 30 10 5 8 Klik Close, lalu klik Built the Table sampai muncul tampilan di bawah ini.

Memodifikasi Database

28

Cara memodifikasi database yang sudah ada dalam disk hampir sama dengan cara membuatnya yaitu :

1. Panggil program Visual
Manager.

Data Manager dengan memilih menu Add-Ins >Visual Data

2. Pilih menu File
memilih Design.

>Open Database >Microsoft Access lalu klik file yang diinginkan lalu

klik Open. Tunjuk pada nama tabel yang diinginkan lalu klik kanan, dilanjutkan dengan

3. Anda dapat langsung mengubah nama field, menghapus field atau menambah field. Jika
Anda ingin keluar dari program Visual Data Manager, dengan memilih File lalu Exit.

Menambah Index Data
Index data adalah urutan data pada suatu tabel database. Index data diperlukan terutama untuk pencarian data dengan cepat dan pengelompokan data. Untuk membuat index data caranya hampir sama dengan memodifikasi data, yaitu sebagai berikut :

1. Panggil program Visual Data Manager, pilih file database yang akan digunakan, tunjuk
nama tabel yang akan digunakan lalu klik kanan, dilanjutkan dengan memilih Design.

2. Klik Add Index lalu ketik nama index NPM pada kolom Name. Klik kunci index pada
kolom Available Fields. Anda dapat menggunakan beberapa field sebagai kunci index.

29

3. Tentukan pilihan index.


• •

Primary : index yang memuat satu atau lebih field dan bersifat unik (tidak ada yang sama dalam satu tabel). Dalam satu tabel hanya boleh ada satu primary key. Unique : index yang bersifat unik. IgnoreNulls : field yang kosong diabaikan.

4. Klik OK lalu ulangi langkah di atas jika masih ada index lain atau Close untuk menutup
jendela Add Index.

Menambahkan Tabel Data Dalam File Database
Untuk menambahkan tabel data dalam file database caranya hampir sama dengan membuat tabel seperti di atas yaitu dengan meng-klik kanan Properties dan pilih New Table. Tambahkan tabel baru dengan data sebagai berikut : Nama tabel : Mtkuliah Nama Field Kodemk Mata kuliah SKS Tipe Text Text Single Lebar 6 20 4 Index Primary, Unique -

30

Nama tabel : Nilai Nama Field NPM Kodemk UTS UAS Tipe Text Text Single Single Lebar 8 6 4 4 Index Tanpa tipe index Tanpa tipe index -

Memasukkan Data Dalam Tabel Database
Selain dengan program melalui Visual Basic, Anda dapat memasukkan data dalam tabel database dengan menggunakan program Visual Data Manager. Caranya yaitu dengan meng-klik kanan nama tabel dan pilih Open lalu klik Add.

31

File dan Database
Kontrol File
Adalah kontrol yang memiliki fungsi memanipulasi file-file pada komputer. Biasanya kontrol file ini digunakan untuk menampilkan daftar file agar user bisa memilih salah satu file yang terdapat pada komputer.  Drive List Box (Daftar Drive) Kontrol ini akan menampilkan daftar drive yang terdapat pada komputer seperti drive floppy (A atau B), drive hard disk (C, D dan seterusnya), drive CD-ROM serta drive-drive penyimpanan lainnya.  Directory List Box (Daftar Direktori) Kontrol ini akan menampilkan seluruh daftar direktori atau folder pada drive yang dipilih.  File List Box (Daftar File) Kontrol ini akan menampilkan seluruh file yang terdapat pada direktori yang dipilih. File-file yang ditampilkan dapat ditentukan jenisnya melalui properti Pattern. Contoh : 1. Buat Form sebagai berikut :

32

2. Ubah properti tiap kontrol sebagai berikut : Kontrol Form Label1 Text1 Drive1 Dir1 File1 Command1 Properti Caption Caption Text Nilai Program Daftar File Daftar File (dikosongkan)

Caption

Keluar

3. Ketikkan program di bawah ini : Private Sub Command1_Click() End End Sub Private Sub Drive1_Change() Dir1.Path = Drive1.Drive End Sub Private Sub Dir1_Change() File1.Path = Dir1.Path End Sub Private Sub File1_Click() Text1.Text = Dir1.Path + "\" + File1.FileName End Sub

33

Kontrol Data
Berguna untuk menampilkan record-record database pada suatu aplikasi. Kontrol ini menyediakan tombol penggulung yang dapat membantu melewati record demi record di dalam sebuah file database. Kontrol Data dapat menampilkan field-field di dalam database dengan beberapa format database misalnya Access (mdb), dBase dan Foxpro (dbf), Excel (xls), Lotus (wk*), Paradox (db) bahkan teks (txt). Properti Kontrol Data Properti Caption Connect DatabaseName RecordSource Keterangan Teks judul yang akan ditampilkan di tengah-tengah kontrol Data Memilih salah satu jenis database yang ada Menghubungkan kontrol data dengan file database. Disini Anda harus memilih file database yang akan dijadikan sumber dari kontrol Data Memilih salah satu tabel dari database yang dipilih. Biasanya sebuah database memiliki lebih dari satu tabel. Pilihlah tabel yang ingin dimanipulasi dengan kontrol Data pada properti ini. Contoh : 1. Buat Form sebagai berikut :

2. Ubah properti tiap kontrol sebagai berikut : Kontrol Form Properti Name Nilai frmSiswa 34

Data1

Caption Caption Connect DatabaseName EOFAction RecordSource Caption Caption Caption Caption Caption Caption Caption Caption DataField DataSource Text DataField DataSource Text DataField DataSource Text DataField DataSource Text DataField DataSource Text DataField DataSource Text DataField DataSource Text Caption

Program Daftar File Tabel Siswa Access (lokasi dan nama file database) 2-AddNew Siswa Data Mahasiswa STMIK Jakarta STI&&K NPM Nama Jenis Kelamin Alamat Kota Kode Pos Telepon NPM Data1 (dikosongkan) Nama Data1 (dikosongkan) JK Data1 (dikosongkan) Alamat Data1 (dikosongkan) Kota Data1 (dikosongkan) Kode_Pos Data1 (dikosongkan) Telpon Data1 (dikosongkan) Keluar

Label1 Label2 Label3 Label4 Label5 Label6 Label7 Label8 Text1

Text2

Text3

Text4

Text5

Text6

Text7

Command1

3. Ketikkan program di bawah ini :

35

Private Sub Command1_Click() End End Sub Private Sub Form_Load() frmSiswa.WindowState = 2 End Sub Hasil :

Mengaitkan Tabel dengan Menggunakan DataGrid
1. Tambahkan kontrol baru dengan memilih menu Project >Components (Ctrl+T) lalu pilih Microsoft ADO Data Control (OLEDB) dan Microsoft Data Grid Control (OLEDB) lalu klik OK 2. Buat form sebagai berikut :

36

Kontrol Form

Properti Name Caption

Nilai frmBrowseSiswa Data Siswa Setting True True True True Browse Data Siswa True Adodc1 2-dbgGridNavigation Setting Tabel Siswa 2-adDoAdNew

Properti AllowAddNew AllowArrows AllowDelete AllowUpdate Caption ColumnHeaders DataSource TabAction Properti Caption EOFAcction • • • • •

3. Lakukan langkahlangkah berikut untuk kontrol Adodc1 : • Ubah propertinya sebagai berikut :

Tekan tombol elipsis pada properti ConnectionString. Pada Use Connection String klik tombol Build lalu pilih Microsoft Jet 4.0 OLEDB Provider lalu klik Next. Pada kolom Select or enter a database name, masukkan nama database yang dipakai atau klik tombol elipsis lalu cari nama database. Klik Test Connection untuk mengetes hubungan dengan database lalu klik OK sampai kembali ke jendela Form. Tentukan properti RecordSource dengan menekan tombol elipsis lalu pada kolom Command Type pilih 2-adCmdTable. Lalu pilih table yang akan digunakan pada kolom Table or Stored Procedure Name lalu klik OK.

4. Ubah properti kontrol DataGrid sebagai berikut :

37

5. Ketikkan program di bawah ini : Private Sub Command1_Click() End End Sub Private Sub Form_Load() frmBrowseSiswa.WindowState = 2 End Sub Hasil :

MENU DAN INSTALASI PROGRAM APLIKASI
A. Membuat Menu untuk Integrasi Program
Jika program yang Anda buat sudah cukup besar dan kompleks, maka Anda perlu membuat menu program untuk mengintegrasikanprogram-program Anda, sehingga pemakai program tidak kesulitan menggunakan program yang Anda buat.

38

MS-Visual Basic 6.0 menyediakan fasilitas untuk membuat menu program, yaitu Menu Editor. Dengan fasilitas ini, Anda dapat membuat menu program dengan cepat dan mudah. Untuk itu lakukan langkah-langkah berikut ini : 1. Buat form baru dengan menekan tombol Add Form lalu ubah properti Name-nya menjadi frmMenu dan properti Caption-nya menjadi Menu Latihan Visual Basic

2. Klik tombol Image pada Toolbox lalu buat areanya pada form. Klik tombol

di properti

Picture sehingga muncul jendela Load Picture. Pilih gambar yang akan kita sisipkan

3. Ubah properti Stretch menjadi True lalu atur besarnya gambar yang disisipkan 4. Klik icon Menu Editor seperti gambar yang terletak pada toolbar, sehingga akan muncul tampilan

5. Isilah isian Caption dengan tampilan menu, misalnya &Input. Nantinya pada saat dijalankan , yang akan muncul adalah tulisan Input. Jadi Anda dapat menambahkan tanda “&” pada isi Caption, yang akan menyebabkan karakter disebelah kanannya akan diberi 39

garis bawah pada saat program dijalankan. Tanda garis bawah pada karakter tersebut menandakan bahwa Anda dapat mengunakan tombol Alt diikuti karakter yang digarisbawahi untuk memilih pilihan yang dimaksud. 6. Isilah isian Name dengan nama pengenal menu, misalnya Minput. Nama menu ini antara lain dipakai sebagai nama procedure atau objek jika Anda nanti membuat kode programnya. 7. Beri tanda pilih pada pilihan Enable agar menu ini bisa dipilih. Beri tanda pilih pada pilihan Visible agar menu ini ditampilkan dilayar.

8. Gunakan icon tanda panah

jika Anda ingin mengubah letak atau level menu.

Perlu diketahui bahwa urutan yang lebih atas akan ditampilkan lebih ke kiri, sedangkan menu dengan indentasi (menjorok) ke kanan akan diletakkan sebagai submenu dari menu di atasnya yang indentasinya lebih ke kiri. 9. Pilih Next untuk membuat pilihan (menu) berikutnya. Pilih Insert untuk menyisipkan pilihan baru pada posisi yang sekarang ditunjuk dan pilih Delete untuk menghapus menu yang ditunjuk. 10. Lengkapi struktur menu menjadi seperti tabel berikut ini :

Caption
Level1 &Input Level2 Data Mahasiswa Data Mata Kuliah Data Nilai &Latihan Latihan 1 Latihan 2 Latihan 3 &Selesai Keluar Menu

Name
Minput Mmahasiswa Mmtkuliah Mnilai Mlatihan Mlat1 Mlat2 Mlat3 Mselesai Mkeluar

11. Setelah selesai klik OK dan simpan form dan jalankan program dengan mengklik icon Start. 40

B. Mengaitkan Aplikasi Lain dalam Menu
Program di atas hanyalah program menu saja, jadi belum dapat memanggil program atau form lain. Sekarang kita akan mempelajari cara mengaitkan program aplikasi atau form lain ke dalam menu, agar dapat dipanggil lewat menu tersebut. Untuk itu lakukan langkah-langkah berikut ini : 1. Tampilkan form menu, pilih Input, lalu klik dua kali sub menu Data Mahasiswa sehingga akan muncul tampilan kode program dengan procedure Mmahasiswa_Click( ). Ketikkan kode programnya seperti berikut ini : Private Sub Mmahasiswa_Click() <namaform Input Data Mahasiswa>.Show End Sub Procedure di atas menunjukkan bahwa jika Anda mengklik pilihan Data Mahasiswa pada menu Input, maka program akan menampilkan form Input Data Mahasiswa. 2. Tampilkan form program input dan latihan yang telah dibuat, setelah itu tampilkan kode programnya dan ubahlah nama procedure Form_Load (jika ada) menjadi Form Activate. Hal ini perlu karena jika digunakan procedure Form_Load, maka procedure hanya dijalankan satu kali selama program utama (menu) belum selesai. Sedangkan jika memakai Form_Activate, maka procedurenya akan dilaksanakan setiap kali pilihan pada menu tersebut dipilih. 3. Ubah pula isi procedure selesai_Click menjadi seperti contoh berikut ini : 41

Private Sub selesai_Click() <nama form Input Data Mahasiswa>.Hide frmMenu.Show End Sub Perintah di atas menunjukkan bahwa jika tombol Selesai di klik, maka program akan menutup database mahasiswa, kemudian menyembunyikan tampilan form Input Data Mahasiswa dan kembali menampilkan (mengaktifkan) form Menu. 4. Simpan form Menu dengan nama yang sama, lalu coba jalankan program.

C. Membuat File Setup Program
Setelah Anda selesai membuat program secara lengkap, maka mungkin Anda ingin menggunakan program Anda pada komputer lain, misalnya Anda membuat dan menyelesaikan program di rumah, kemudian ingin menggunakan program tersebut di kantor Anda. Untuk keperluan tersebut, Ms-Visual Basic 6.0 menyediakan fasilitas pembuatan file setup program. Untuk mempelajari fasilitas tersebut, lakukan langkah-langkah berikut ini : 1. Bukalah proyek yang akan dibuat file setup-nya. 2. Agar file setup-nya efisien, sebaiknya komponen yang tidak dipakai dibuang dulu. Komponen yang dimaksud adalah objek yang terdapat dalam toolbox. Untuk melakukannya pilihlah menu Project lalu Components. Setelah itu buanglah tanda silang pada pilihan yang tersedia di lembar Controls. Jika ada pilihan yang tidak bisa dibuang tanda pilihnya, berarti komponen tersebut memang terpakai. Hal yang sama Anda lakukan pada lembar Designer dan lembar Insertable Objects. Setelah itu klik Apply lalu Close.

42

3. Simpan proyek lalu tutuplah program MS-Visual Basic 6.0 dan kembali ke sistem operasi Ms-Windows. Klik Icon Start >Programs >Microsoft Visual Studio 6.0 >Microsoft Visual Studio 6.0 Tools >Package & Deployment Wizard sehingga akan muncul tampilan seperti gambar di bawah

4. Tentukan nama program aplikasi (proyek) yang akan dibuat file setup-nya. Anda dapat mengunakan tombol Browse untuk memilih proyek yang diinginkan dari lokasi tertentu. Setelah itu klik icon Package sampai muncul tampilan seperti gambar

43

5. Pilihan ini akan muncul jika Anda belum pernah membuat file EXE dari program aplikasi yang bersangkutan. Jika file EXE sudah pernah dibuat, maka pilihan , maka pilihan yang dimunculkan sedikit berbeda dan disarankan Anda memilih Recompile untuk melakukan kompilasi ulang. 6. Setelah proses kompilasi selesai, akan muncul pilihan Package Type. Pilihlah Standard Setup Package lalu klik Next, sampai muncul tampilan seperti gambar

7. Tentukan folder tempat menyimpan hasil proses. Klik Next sampai muncul pilihan Drivers yang tersedia, lalu klik Next sekali lagi. Tampilan selanjutnya adalah daftar file yang diperlukan oleh program aplikasi pada saatnya nanti dijalankan di komputer baru. Jadi jika komputer baru yang akan dipakai tidak mempunyai Ms-Visual Basic 6.0, maka program aplikasi tetap dapat dijalankan, karena file-file yang diperlukan sudah dimasukkan dalam kelompok file setup. Tetapi jika dalam komputer yang baru juga terdapat program Ms-Visual Basic 6.0, maka Anda dapat tidak menyertakan daftar file yang tersedia dengan cara menghilangkan tanda pilihnya. Setelah itu klik tombol Next.

44

8. Tampilan selanjutnya adalah pilihan Cab. Pilihan ini untuk menentukan, apakah Anda ingin menggunakan file setup tunggal atau file setup majemuk. File setup tunggal dipilih jika Anda ingin menyimpan file tersebut dalam media dengan kapasitas cukup besar (misalnya CD-ROM), sehingga cukup dibuat satu file saja, sedangkan file setup majemuk dipilih jika Anda ingin menggunakan media dengan kapasitas kecil (misalnya disket), sehingga file setup harus dipecah-pecah. Untuk contoh sekarang, pilihlah Multiple Cabs dan tentukan ukurannya sesuai dengan kapasitas media dilanjutkan dengan mengklik Next.

9. Tampilan selanjutnya adalah isian Installation Title. Disini Anda dapat menentukan judul instalasi, misalnya Database Mahasiswa STMIK Jakarta (STI&K). Setelah itu klik Next.

45

10. Tampilan selanjutnya adalah lokasi program hasil setup nantinya ditampilkan pada komputer baru. Klik lagi Next. Lalu tamplan selanjutnya adalah lokasi program disimpan di media penyimpanan pada komputer baru. Klik lagi Next.

11. Selanjutnya muncul Shared files. Berilah tanda silang jika diinginkan program hasil setup dapat dipakai secara bersama-sama oleh beberapa user lalu klik Next. 12. Tampilan selanjutnya adalah isian Script name. Pilihan ini untuk menentukan nama skrip, yaitu langkah-langkah proses pembuatan file setup, sehingga jika nanti Anda ingin membuat file setup lagi, Anda dapat mengunakan skrip tersebut sehinga langkahlangkahnya otomatis dan sama dengan yang ada dalam skrip. Setelah itu klik lagi Finish.

13. Program akan mulai memproses membuat file setup. Tunggulah sampai proses selesai dan muncul laporan proses. Klik tombol Close sampai muncul tampilan seperti gambar 6.6 kemudian klik lagi tombol Close.

46

14. Sampai disini, proses pembuatan file setup sudah selesai. Selanjutnya Anda dapat melihat dan atau menyalin file hasil setup ke media lain (misalnya disket) dengan menggunakan program Windows Explorer. Contoh hasil setup dapat Anda lihat seperti pada gambar

Jika Anda melakukan instalasi atau setup program aplikasi ke dalam harddisk, maka akan ter-copy juga komponen program yang diperlukan program aplikasi. Yang perlu diperhatikan adalah bahwa ada beberapa komponen program yang mungkin sudah ada dan diperlukan atau dipakai program aplikasi lain. Pada saat Anda melakukan instalasi, hal tersebut tidak menjadi masalah, karena komponen tetap ada. Tetapi yang menjadi masalah adalah jika Anda melakukan proses Uninstall, misalnya lewat Add/Remove Programs pada jendela Control Panel. Jika Anda melakukan proses Uninstall tersebut, maka semua komponen juga akan dihapus, sehingga program aplikasi lain yang menggunakan komponen ang terhapus akan terganggu. 47

Oleh karena itu, jika Anda menginstal program aplikasi yang dibuat dengan MsVisual Basic 6.0, sebaiknya disimpan dalam folder tersendiri yang terpisah dari folder lain, sehingga jika sudah tidak diperlukan, Anda dapat menghapusnya dengan Windows Explorer.

48

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->