P. 1
PENGENALAN BORLAND DELPHI7

PENGENALAN BORLAND DELPHI7

|Views: 1,369|Likes:
Published by BETAN

More info:

Published by: BETAN on Jan 15, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

07/27/2013

pdf

text

original

[Type the company name

]

[Type the document title]
[Type the document subtitle]

Gilang Abdul Aziz [Pick the date]

......2.................................................................................... Menu Database .................................................2................................................................1............... Menu Tool dan Help .....................8......... 16 3....2..................... 6 2.. Menu View .......................................................................................................................................Halaman |1 DAFTAR ISI DAFTAR ISI .......................... Menu Edit .......... 3 2................................................................... 2 2........................................................................................................................................8...... 10 2............................................Ver.......................5.................... Toolbar ........................................2........................................3..............3................................................................ Form Designer ............................ 6 2................................... Membuat Program Calculator Sederhana Menggunakan Borland Delphi7 ........................................... Main Windows .......... Menu File ............................................................................... Code Explorer .................. Code Editor ....3................................... Object Inspector ..............................3........................................ Component Pallete ..............3...................................6.........3................................0 ...............................1........ Menu Search ............. 4 2....................................................................... Menjalankan Borland Delphi7 .......................... 4 2...........................................................................................................................2......... Membuat Program Sederhana (Single-Form) Menggunakan Borland Delphi7 ............................ 3 2............................... Menu Component ..................2..5.......................................1...........................................................................1.......................................3..........3.2....................................................1.............................. Menu-menu pada Borland Delphi7 ........... 5 2............... 9 2..2................ 5 2.................... PENDAHULUAN ....................... Menu Project .........................................................7........... 17 4................................ 12 2....... 18 MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc..... POGRAM PERTAMA MENGGUNAKAN BORLAND DELPHI7 .................................................. 14 2............................................................................. PENGENALAN BORLAND DELPHI7 .............................6... 8 2...................1......... 11 2............... Menu Run ............................................ 5 2.................. 15 3............................................................................................................. 6 2..3....9................................ 4 2................................ Mengenal IDE (Integrated Development Environment) pada Borland Delphi7 ........ 3 2........ 6 2....................3.............................3...................................... Object Tree View ......2.. 13 2...........4............................4......... PROBLEM TO SOLVE .............................. 17 REFERENSI ................... 1 1...............2.............3...................................................7.2................................. 16 4............

Ver.0 .1.. kita mulai deh belajarnya. Dalam pemrograman visual kita lebih dimudahkan dalam hal desain interface. sehingga kita tidak akan terlalu tersesat saat bermain dengan Dekstop Programming. Ok.Halaman |2 1.. PENDAHULUAN Pemrograman Visual atau lebih sering kita dengar dengan istilah Pemrograman Dekstop merupakan revolusi dari pemrograman tradisional yang masih berbasis console. Namun kita tetap harus memiliki konsep-konsep dasar programming yang kuat. penempatan object. Modul ini akan memandu anda saat praktikum berlangsung. Sehingga anda dapat memahami dan mampu mempraktekan langsung materi-materi mengenai pemrograman visual dengan menggunakan tools Dekstop Programming yang cukup powerfull yaitu Borland® Delphi7™. dan lain-lain. MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.

berikut langkah-langkahnya: Start  All programs  Borland Delphi 7  Delphi 7 Gambar 2. 2.Ver.0 . Berikut IDE (Integrated Development Environment) pada Borland Delphi7: Gambar 2..2. Menjalankan Borland Delphi7 Ok. Mengenal IDE (Integrated Development Environment) pada Borland Delphi7 Salah satu ciri dari programmer handal selain logikanya yang tajam adalah mampu menguasai IDE (Integrated Development Environment) pada berbagai tools programming.1 Memulai Borland Delphi7 Mudahkan?. Untuk menjalankan program Borland Delphi7.1.1.. PENGENALAN BORLAND DELPHI7 2.2 Workspace pada Borland Delphi7 MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. kita asumsikan bahwa program Borland Delphi7 telah terinstal pada komputer anda lengkap dengan fitur-fitur bawaannya.Halaman |3 2.

antara lain: Standart. View. Pada kondisi default Borland Delphi7 memiliki 6 bagian toolbar.2.0 .Ver. 2. Main Menu dan Component Pallete.Halaman |4 2.3 Component Pallete MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Toolbar terletak pada bagian bawah baris menu.3. Toolbar Borland Delphi7 memiliki beberapa Toolbar yang masing-masing memiliki fungsi dan kegunaan yang berbeda-beda. Custom dan Component Pallete. Component Pallete Component Pallete berisi kumpulan tombol-tombol yang merepresentasikan komponen-komponen yang terdapat pada VCL (Visual Component Library).2. Additional. Gambar 2.1.2. seperti Standart.1. Dekstops. mencakup Toolbar. Pada Component Pallete anda akan melihat Page Control. Klik kanan pada toolbar pilih Customize Sehingga muncul kotak dialog Customize Gambar 2.2.2 Kotak Dialog Customize Kita bisa mengatur tampilan toolbar sesuai kebutuhan dan keinginan kita. Debug. System. Kita dapat mengatur tombol-tombol pada toolbar sesuai kebutuhan. Data Access dan lain-lain seperti pada gambar 2.2. Win32. 2. Main Windows Berfungsi sebagai navigasi utama.2.2.3.

1.4. Satu diantara keuntungan bagi pengguna Delphi adalah bahwa Anda tidak perlu menuliskan kode-kode sumber.2.Ver. teks. Gambar 2.5. Object Inspector terdiri dari dua tab. Form dapat diisi berbagai komponen seperti tombol.2.2.4 Lembar Kerja Form Sebuah Form pada dasarnya adalah sebuah unit yang nantinya akan terintegrasi dengan main project. karena Delphi telah menyediakan kerangka penulisan sebuah program seperti pada gambar 1.5 Lembar Kerja Code Editor 2. Gambar 2. MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.6. Object Inspector Digunakan untuk mengubah properti atau karakteristik dari sebuah komponen.2.2. yaitu Properties dan Events seperti gambar 2.2.6 di bawah ini. Form Designer Form Designer merupakan sebuah sub-workspace yang digunakan untuk merancang sebuah aplikasi. Code Editor Code Editor merupakan tempat di mana Anda dapat menuliskan kode program. Pada bagian ini Anda dapat menuliskan pernyataan-pernyataan dalam Object Pascal. dan komponen-komponen lain yang terdapat pada Component Pallete. 2.5 di bawah ini.0 .Halaman |5 2.

Object Tree View Object TreeView menampilkan diagram pohon dari komponen-komponen yang bersifat visual maupun nonvisual yang telah terdapat dalam form. Code Explorer digunakan untuk memudahkan pemakai berpindah antar file unit yang terdapat di dalam jendela Code Editor.7. Menu File Menu File berisi perintah-perintah dasar menu yang sering digunakan yang berhubungan dengan pengoperasian file. 2.2.2. 2. Anda dapat melihat konteks menu komponen versi sebelumnya. dan untuk membukanya kembali pilih menu View Code Explorer dari main menu atau klik kanan dalam jendela Code Editor kemudian pilih View Explorer. Code Explorer Code Explorer merupakan lembar kerja baru yang terdapat di dalam Delphi7 yang tidak ditemukan pada versi-versi sebelumnya. data module.1.3. Menu-menu pada Borland Delphi7 Tidak terlalu berbeda dengan aplikasi-aplikasi yang berjalan di Windows lainnya.2. Supaya lebih jelas. klik kanan pada komponen yang sama dalam form. Untuk menutup Code Explorer. Apabila Anda mengklik kanan salah satu item yang terdapat di dalam diagram phon. 2. atau frame.3. atau frame. peratikan tabel berikut! MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Borland Delphi7 juga menyediakan menu-menu yang lengkap.Halaman |6 Gambar 2.6 Lembar Kerja Object Inspector 2. Object TreeView juga menampilkan hubungan logika antar komponen.Ver.0 . klik tanda silang yang terdapat di sudut kanan atas. Untuk mengakses menu secara penuh. data module.1.8.

1 Menu File Submenu New New  Application Fungsi Membuat objek baru yang berupa project dan form Membuat Projek baru. membuka code editor baru dengan nama Unit1.0 . Menyimpan form yang aktif dengan nama baru. Menyimpan project yang aktif dengan nama baru. Menyimpan form yang sedang aktif. File form tersebut akan dihubungkan dengan apliksi CLX yang memiliki ekstensi xfm. Membuat form baru yang masih kosong. Membuka sebuah objek. Menyimpan semua objek yang aktif. Membuat kelompok projek baru dengan aplikasi single cross plaform di dalamnya. New  CLX Application New  Data Module New  Form New  Frame New  Unit Open Open Project Reopen Save Save As Save Project As Save All MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Perintah ini akan menutup projek sebelumnya.1.Halaman |7 Gambar 2.Pas. dan form baru dengan nama Form1. Membuka objek terakhir yang pernah anda buka sebelumnya. Membuat Data Module baru. dan selanjutnya akan ditampilkan kontainer data modul pada dekstop. Membuat unit baru di jendela Code Editor. Anda dapat menggunakan objek CLX untuk membuat aplikasi platform untuk Windows atau Linux. Objek tersebut dapat berupa sebuah program atau project. Membuat frame (bingkai) baru yang masih kosong yang akan ditambahkan di dalam projek baru yang masih aktif.Ver.3. Module ditambahkan di dalam projek yang berlaku. Membuka project.

maka Borland Delphi7 akan menampilkan kotak komfirmasi tentang penyimpanan file. Menutup program Borland Delphi7. Menghapus teks atau objek yang sedang dipilih Memilih atau menyeleksi seluruh teks atau Delete Select All MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.1 Menu File Menutup form. Mengulang perinteh terakhir yang pernah anda lakukan. Gambar 2.Halaman |8 Close Close All Use Unit Print Exit Tabel 2.3. Memotong teks atau objek yang sedang terpilih. Menu Edit Menu Edit berisi perintah – perintah yang digunakan untuk menyunting teks program dala jendela code editor.0 . Menutup semua objek yang aktif. menyunting komponen – komponen yang terletak pada bagian form designer dan beberapa item lainnya.2 Menu Edit Submenu Undo Redo Cut Paste fungsi Membatalkan perintah terakhir yang pernah anda lakukan.3.2. Menempelkan teks atau objek yang sebelumnya telah anda cut atau copy pada posisi yang anda kehendaki.Ver. Mencetak item Borland Delphi7 yang sedang terpilih. jika form belum anda simpan.1.3. Membuka sebua unit untuk project yang aktif. 2.

baik secara vertikal ataupun horizontal. Gambar 2. Meletakan objek terpilih pada posisi terbawh di antara objek lain pada form.3. Mengubah urutan komponen-komponen nonVisual yang akan diaktifkan apabila anda menggunakan tombol Tab untuk memindahkan posisi komponen non-visual yang aktif pada saat form yang telah anda buat dijalankan.0 .1.Ver. Meletakan objek terpilih pada posisi teratas di antara objek lain pada form. mencari kesalahan-kesalahan program pada jendela kode editor dan beberapa item lainnya.3. Mengatur ukuran lebar atau tinggi objek yang terpilih. Mengunci seluruh komponen yang terdapat dalam form sehingga anda tidak diperkenankan untuk mengubah ukuran atau memindahkan posisi komponen-komponen tersebut. Menu Search Menu Search berisi perintah-perintah untuk mencari teks-teks tertentu dalam Code Editor.3. Mengubah seluruh ukuran objek yang akan diaktifkan apabila anda menggunakan tombol Tab untuk memindahkan posisi objek yang aktif pada saat Form yang telah anda buat dijalankan. Merapikan atau mengatur peralatan objek yang dipilih terhadap posisi titik-titik grid pada form. Mengatur tata letak objek dalam form. Memutar komponen-komponen yang terdapat pada form secara horizontal.3.2 Menu Edit 2. Tabel 2.3 Menu Search Submenu Find Fungsi Mencari teks tertentu dalam Code Editor MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.Halaman |9 Align to Grid Bring to Front Send to Back Align Size Scale Creation Order Flip Children Lock Control objek.

Pindah menuju baris program tertentu pada jendela Code Editor.3 Menu Search Mencari teks tertentu dalam Code Editor yang terletak pada file lain. Menu View Menu View berisi perintah-perintah yang digunakan untuk menampilkan atau menyembunyikan jendela-jendela tertentu dalam program Borland Delphi7. Menampilkan lembar kerja Object TreeView yang digunakan untuk menampilkan diagram pohon objek dalam suatu form.0 . Object Inspector Object TreeView Alignment Pallete MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.1.Ver. Gambar 2. 2. Menampilkan toolbar align yang berisi tombol perintah untuk mengatur tata letak komponen-komponen dalam suatu form. Jalankan perintah ini sehingga akan tampak teks Searching For: pada bagian Code Editor kemudian ketik yang akan anda cari. Mencari teks tertentu yang akan anda ketik. Menampilkan lembar kerja Object Inspector yang digunakan untuk mengubah property dan event komponen-komponen dalam suatu form. Mengulangi perintah pencarian teks yang sebelumnya pernah anda lakukan.3. Mencari kesalahan-kesalahan program yang ada dalam jendela Code Editor.4 Menu View Submenu Project Manager Fungsi Menampilkan lembar kerja Project Manager yang digunakan untuk mengelola struktur hierarki dari suatu project. Mencari teks tertentu dan menggantinya dengan teks lain dalam Code Editor.3.4.H a l a m a n | 10 Find in Files Replace Search Again Incremental Search Go to Line Number Fatal Error Tabel 2.3.

atau berdasarkan prioritas. Membuka jendela Code Editor baru.Ver. Pindah menuju lembar kerja form designer dan code editor secara bergantian. Menampilkan daftar nama toolbar yang baru saja diaktifkan atau disembunyikan.0 .H a l a m a n | 11 To Do List Browser Code Explorer Component List Windows List Additional Message info Debug Windows Dekstop Toogle Form/Unit Units Forms New Edit Window Toolbar Tabel 2.3. Menampilkan dan atau mengaktifkan daftar nama unit yang anda miliki. Menampilkan lembar kerja Code Explorer. Menampilkan sub-menu Dekstop yang berfungsi untuk mengolah dekstop.3.1. Gambar 2.3. 2. status.5. Menampilkan dan atau mengaktifkan daftar nama form yang anda miliki. Anda dapat mengurutkan item-item tersebut sesuai dengan abjad.5 Menu Project MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Menu Project Menu project berisi perintah-perintah yang berhubungan dengan pengolahan suatu project.4 Menu View Menampilkan item-item tugas yang dibutuhkan untuk melengkapi pekerjaan dalam project yang berlaku. Menampilkan lembar kerja Message Hints. Menampilkan daftar nama jendela yang sedang dalam kondisi aktif yang dapat anda pilih. Menampilkan lembar kerja Component yang berisi daftar komponen-komponen yang tersedia dalam Borland Delphi7. Menampilkan lembar kerja project browser. Menampilkan lembar kerja Debug.

6. Anda juga dapat memantau jalannya program dengan memperhatikan procedure yang sedang dijalankan.0 . Menambahkan project lain yang pernah anda buat sebelumnya ke dalam project yang sedang aktif. Menu Run Menu ini digunakan untuk menjalankan program dan melihat jalannya program. dll) pada project anda. Perintah ini digunakan untuk memeriksa kode dari kesalahan-kesalahan yang mungkin terjadi pada saat proses kompilasi. Membagun kembali semua komponen yang terdapat dalam project yang aktif yang mengalami perubahan.EXE (Executeable) yang dapat dieksekusi setiap saat untuk file-file dalam project yang aktif. Menampilkan kotak dialog Options. MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Memasukan type Library lain ke dalam system program Borland Delpi7. Mengubah tatanan penterjemah (resource. Memasukan program aplikasi yang telah anda buat ke dalam daftar repository. Membentuk file kompilasi yang ber-ekstensi . Membagun kembali semua komponen yang terdapat dalam seluruh project yang aktif yang mengalami perubahan. Program aplikasi yang telah dimasukan ke dalam daftar repository dapat dipanggil kembali.Ver. 2. Menghapus unit yang terdapat di dalam project yang sedang aktif. Menampilkan source code dari project yang sedang aktif.1.5 Menu Project Fungsi Menambahkan unit yang pernah anda buat sebelumnya ke dalam Project yang sedang aktif. Membentuk file kompilasi yang ber-ekstensi .3.EXE (Executeable) untuk seluruh file project yang sedang aktif.H a l a m a n | 12 Submenu Add to Project Remove From Project Import Type Library Add to Repository View Source Language Add Existing Project Compile Project Build Project Syntax Check Project Compile All Project Build All Project Options Tabel 2.3. Mengompilasi modul-modul project yang tidak terikat dengan project tersebut.

6 Menu Run Submenu Run Attach to Process Fungsi Mengompilasikan dan menjalankan program aplikasi yang telah anda buat. Memeriksa proses beberapa aplikasi yang sedang dijalankan. Menampilkan kota dialog Evaluate/Modify. Parameters Step Over Trace Info Trace to Nexs Source Line Run to Cursor Run until Return Show Execution Point Program Pause Program Reset Evaluate/Modify MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.Ver. Menghentikan program secara permanen. Menjalankan program dalam suatu procedure dan akan berhenti bila menemukan baris perintah dalam suatu procedure berikutnya. Menjalankan baris program satu persatu dalam suatu prosedur. Menentukan parameter awal untuk program aplikasi anda.3. sehingga anda dapat merubah atau mengevaluasi nilai pernyataan yang ada. dan menampilkan daftar proses program aplikasi yang sedang dijalankan oleh komputer lokal. Menjalankan baris program satu persatu dalam suatu prosedur yang saling berhubungan.1.0 . Menghentikan program secara sementara. Menjalankan program sampai program tersebut mengeksekusi perintah return. Pilih sebuah proses dari daftar dan klik 2x pada Attach untuk memulai pemeriksaan. Menjalankan program hanya sampai lokasi kursor dalam Code Editor. Menampilkan posisi cursor dalam jendela Code Editor.H a l a m a n | 13 Gambar 2.

sehingga anda dapat memodifikasi Brakpoint.3.0 .3. 2. 2.7 Menu Component Submenu New Component Install Component Import ActiveX Component Install Packages Configure Pallete Tabel 2.7 Menu Component Fungsi Membuat komponen baru. sehingga anda dapat mengubah atau memodifikasi menu Watch.. Menginstall komponen baru. Menu Component Menu ini digunakan menambah atau menginstall komponen-komponen pada Borland Delphi7. Borland Delphi7 menyediakan fasilitas objek yang kuat dan lengkap yang memudahkan programmer dalam membuat program.3.8.7. ODBC.H a l a m a n | 14 Add Watch Add Breakpoint Tabel 2. MySql.3. Microsoft Access.3.Ver. Menu Database Untuk pemrograman database. Menambahkan type library kontrol ActiveX ke dalam project Borland Delphi7.1.3. Menginstall paket-paket komponen yang telah disediakan Borland Delphi7. Gambar 2. Membuka dan mengatur pallete dalam kotak dialog Pallete Properties. Membuka kotak dialog Breakpoint.. Gambar 2.6 Menu Run Membuka kotak dialog Watch Properties. dBase. dll.8 Menu Database MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. Oracle. mengubah atau melihat database. Menu ini digunakan untuk membuat. Format database yang dimiliki oleh Borland Delphi7 adalah format Paradox.

Diganukan untuk membangun aplikasi ClientServer dengan menggunakan file IDL-Based.1. Membuat form melalui database Form Wizard yang berfungsi untuk menampilkan data dari suatu database. Gunakan kotak dialog ini untuk menambah perintah. Menampilkan database dekstop. Gambar 2.3. dan mengolah tabel Query dalam program paradox.9 Menu Tool dan Help Submenu Environment Options Fungsi Menentukan konfigurasi Preferences.3.3. atau mengubah perintah pada menu Tool. Library. Menampilkan kotak dialog Tool Options. menampilkan. Menu Tool dan Help Menu ini digunakan untuk mengubah options atau memanggil Database Dekstop dari menu Delphi. Menampilkan kotak dialog Debugger Options.8 Menu Database 2. Membuka SQL Monitor. sehingga anda dapat membuat. Editor Options Debugger Options Repository Translation Tool Options Regenerate CORBA IDL Files Configure Tool Database Dekstop MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc. mengurutkan.H a l a m a n | 15 Submenu Explorer SQL Monitor Form Wizard Fungsi Membuka Database Explorer atau SQL Explorer.9. nama Path dan mengubah tampilan Component Pallete Menentukan konfigurasi editor. dBase. Menampilkan kotak dialog Object Repository Menampilkan kotak dialog Translation Tool Options yang digunakan untuk mengkonfigurasi translations tool. menghapus perintah. Tabel 2.0 .Ver. memodifikasi.

3.a Saat Program dijalankan (belum diberi aksi) Gambar 1.9 Menu Tool dan Help dan format SQL.H a l a m a n | 16 Package Collection Editor XML maping Rave Designer Image Editor Tabel 2. Membuat Program Sederhana (Single-Form) Menggunakan Borland Delphi7 Deskrpsi: Program ini berisi hanya satu Form. Gambar 1.1.Ver.3. Ukuran: Default (32)) Gambar 1. Dalam program ini ada sebuah teks dan kita diminta supaya bisa mengubah warna dan ukuran dari teks tersebut. Membuka lembar kerja Rave Reports Membuka lembar kerja Image Editor. Ukuran: 18) MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.c Program diberi aksi lain (Warna: Hijau. Membuat dan menyunting package collections (kumpulan paket). Membuka lembar kerja XML Maping Tool.0 .1.b Program diberi aksi (Warna: Merah. PROGRAM PERTAMA MENGGUNAKAN BORLAND DELPHI7 3.

Ok. Membuat Program Calculator Sederhana Menggunakan Borland Delphi7 Sekarang kita sudah memasuki ruang lingkup yang bermain dengan hitungan dalam Borland Delphi7. PROBLEM TO SOLVE 4. MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.Ver.H a l a m a n | 17 Gambar 1.1.1. Hijau. Kuning ItemIndex: 0 Source Code: // Kita pelajari langsung agar dapat mengerti proses pengolahan dan logikanya 4. Merah. 18.d Program diberi aksi lain (Tombol Hide: clicked) Komponen-komponen: Komponen Form1 Button1 Button2 ComboBox1 Label1 Label2 RadioGroup1 Properties Caption: Program pertama saya Caption: Modifikasi Caption: Hide Visible: False Items: Default (32). Namun masih dalam perhitungan yang sederhana. 12 ItemIndex: 0 Caption: Ini adalah program pertama saya! Font-Name: Calibri Font-Size: 32 Caption: Ini adalah program pertama saya! Font-Name: Calibri Font-Size: 32 Visible: False Caption: Warna Items: Default.0 . 24.

ilmukomputer.0 .1.H a l a m a n | 18 REFERENSI http://www. Haryanto Toni Haryanto Ruli Angriawan MODUL PRAKTIKUM PEMROGRAMAN VISUAL | Doc.Ver.com Tim Assisten Dosen Pemrograman Visual         Gilang Abdul Aziz Muhammad Yusuf Jaka Indra Pratama Rinaldi Guarsa Rendy Rini M.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->