P. 1
panduan SPSS

panduan SPSS

|Views: 907|Likes:
Published by Herry Kurnia

More info:

Published by: Herry Kurnia on Jan 27, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

06/03/2013

pdf

text

original

Bab III.

Pengenalan Program SPSS
3.1 Proses Membuka File Apabila ingin melakukan pengolahan/penghitungan data statistik dengan menggunakan software SPSS, maka pertama kali yang harus dilakakan adalah membuka file data. SPSS memiliki fasilitas membuka data yang berasal dari beberapa jenis data diantaranya SPSS, SAS, Systat, Excel, Dbase, TXT, dan lotus dengan cara sebagai berikut:  Aktifkan program SPSS  Pilih menu SPSS File Open Data (gambar 3.1)  Setelah itu pilih file/data yang sesuai dengan jenis datanya (lihat tanda panah pada gambar 3.1).

Gambar 3.1. Proses membuka file data  Kemudian dilanjutkan dengan memilih lokasi tempat penyimpanan data dan file datanya, seperti terlihat pada gambar 3.2 berikut:

Gambar 3.2. Memilih file lokasi data
Pedoman Pengolahan Menggunakan Software SPSS

33

 Kemudian lakukan pemilihan file of type data atau jenis data yang ingin dibuka seperti pada gambar 3.3 berikut.

Gambar 3.3. Memilih jenis file data Maka proses membuka data sudah selesai dan tampilan data sudah dalam format data SPSS. Untuk memudahkan proses membuka file data tersebut kembali, disarankan untuk disimpan dalam format data SPSS.

3.2

Identifikasi Value Label dan Variabel Label Apabila membuka data dari file data selain SPSS, maka data tersebut biasanya tidak dilengkapi dengan informasi struktur datanya mengenai nama variabel dan nama nilai variabel, struktur data lainnya sudah ada seperti variable, type, width, decimal, value, missing, colums, Align, Measure, yang belum tersedia adalah nama variabel dan nama dari nilai variabel. Untuk memudahkan proses pengolahan data dan tabel maka terlebih dahulu melakukan proses memberikan nama variabel dan nama nilai variabel tersebut untuk melengkapi informasi struktur datanya. Proses pemberian nama variabel dan nama nilai variabel dapat digunakan dengan dua cara, yang pertama pemberian nama dapat langsung diberikan pada layar ”variabel view” dan cara kedua dengan menggunakan syntax program SPSS. Cara langsung dapat digunakan dengan membuka variabel view, kemudian arahkan kursor ke baris label yang masih kosong, lalu ketik nama variabel, dalam contoh “Jenis Kelamin” pada gambar 3.4.

34

Pedoman Pengolahan Menggunakan Software SPSS

5.5.4. Gambar 3.Gambar 3. Pada umumnya variabel yang digunakan menggunakan type jenis Numeric dengan angka desimal atau Numeric tanpa angka desimal. Mengindentifikasi type variabel JK 35 Pedoman Pengolahan Menggunakan Software SPSS . nama provinsi dan lain sebagainya. dapat di lihat pada gambar 3. Pengisian nama variabel Untuk menetapkan type jenis variabel dapat dipilih sesuai dengan jenis datanya. kemudian jenis type String yaitu type variabel yang memuat data karakter seperti nama anggota rumah tangga.

Gambar 3. dan dilanjutkan pemberian nama nilai variabel dengan memasukkan terlebih dahulu nilai variabel kemudian dituliskan nama nilai variabel tersebut. langkah pertama buka terlebih dahulu tempat kerja penulisan program dengan menjalankan perintah File Open Syntax Enter.Setelah menetapkan jenis type variabel. Gambar 3.4). Lihat pada gambar 3. Lakukan hal yang sama untuk nilai variabel berikutnya sampai semua nilai variabel terisi nama nilai varibelnya.6. selanjutnya memberikan penamaan variabel (lihat gambar 3. seperti pada gambar 3.6 Memberikan nama nilai variabel JK Cara kedua untuk pemberian nama variabel dan nama nilai variabel dapat dilakukan dengan menuliskan pada syntax program.7 Mengaktifkan fasilitas pembuatan syntax program SPSS 36 Pedoman Pengolahan Menggunakan Software SPSS .7. lalu lanjutkan menekan tombol Add.

Mulailah mengetik VARIABLE LABELS kemudian mulai dengan memberikan nama variabel. B1R2. diharuskan memberikan garis miring / dan dilanjutkan menulis variabel berikutnya. karena apabila tidak diberikan titik. Untuk membedakan nama variabel pertama dan kedua dan seterusnya. Pada baris atas dimulai dengan tanda * kemudian ditulis kalimat INDIVIDU KOR2007 dan diakhiri dengan titik. * INDIVIDU KOR2007. maka perintah tersebut belum berakhir dan program dinyatakan salah. seperti contoh ”Propinsi” dan dilanjutkan ke variabel berikutnya B1R2 dengan hal yang sama. dicontohkan untuk B1R1. VARIABLE LABELS B1R1 /B1R2 /B1R3 /B1R4 /B1R5 /B1R7 /B1R8 /B4AK1 /B4AK2 /B4AK3 /B4AK4 /B4AK5 /KWN /MNART /JAHAT /FREK /SKL /JENIS /ART /NAMA /NO_IBU /INFO /B5R1A /B5R1B /B5R1C /B5R1D /B5R1E /B5R1F /B5R1G /B5R1H /B5R2 ”Propinsi” ”Kab/kota” ”Kecamatan” ”Kelurahan” ”Desa” ”Nomor kode sampel” ”Nomor urut rt” ”Nomor” ”Nama art” ”Hubungan kepala rumah tangga” ”Jenis kelamin” ”Umur” ”Status perkawinan” ”Nomor urut anggota rt” “Apakah menjadi korban kejahatan” “Frekuensi” “Apakah pernah mengikuti pendidkan pra sekolah” ”Jenis pendidikan” ”Banyak art” ”Nama KRT” ”Nomor urut ibu kandung” “Art pemberi informasi?“ “Panas“ “Batuk“ “Pilek“ “Asma/napas sesak/cepat“ “Diare/buang air“ “Sakit kepala berulang“ “Sakit gigi“ “Lainnya“ “Apakah menyebabkan terganggu pekerjaan. maka kalimat diantara kedua tanda tersebut oleh SPSS tidak dinyatakan sebagai perintah program akan tetapi diterjemahkan sebagai kalimat catatan. Berikanlah tanda titik sebagai akhir dari perintah pemberian nama variabel.sekolah“. Baris selanjutnya dimulai dengan Variable labels tanpa tanda titik langsung dilanjutkan kode variabel B1R1 dan diberikan nama variabelnya didalam tanda apostrop ” . Pedoman Pengolahan Menggunakan Software SPSS 37 . dan seterusnya sampai dengan variabel terakhir dituliskan lengkap.

maka akan menjalankan proses perintah tersebut seperti seluruhnya. Gambar 3.8. dimulai dengan menuliskan kalimat VALUE LABELS yang dilanjutkan dengan menuliskan kode variabel B1R5 dan di ikuti dengan nilai variabel 1 “Perkotaan” dan 2 “Pedesaan”. adapun cara penulisannya menggunakan prinsip yang sama dan dapat disatukan perintah penulisan bersama dengan pemberian nama variabel. Proses selanjutnya menjalankan perintah program tersebut dengan menjalankan proses dengan memilih menu RUN dan ALL.8. VALUE LABELS B1R5 1 “Perkotaan” 2 “Pedesaan” /B4AK3 1 “Kepala rumah tangga” 2 “Istri/suami” 3 “Anak” 4 “Menantu” 5 “Cucu” 6 “Orang tua/mertua” 7 “Famili lain” 8 “Pembantu rt” 9 “Lainnya” /B4AK4 1 ”Laki-laki” 2 ”Perempuan” /B4AK6 1 ”Belum kawin” 2 “Kawin” 3 “Cerai hidup” 4 “Cerai mati”. Untuk memberikan nama nilai variabel berikutnya diberikan garis miring / sebagai perintah lanjutan. Berikanlah tanda titik sebagai akhir dari perintah pemberian nama nilai variabel pada bagian terakhirnya. seperti pada gambar 3. Menjalankan program syntax pemberian nama variabel 38 Pedoman Pengolahan Menggunakan Software SPSS .Pemberian nama nilai variabel ditujukan pada variabel yang memiliki nilai variabel.

lalu tekan tombol Continue. Adapun tahapan pekerjaannya sebagai berikut:  Pertama kali membuka file yang terdapat kedua variabel tersebut  Dari menu utama SPSS pilih ”Transform” kemudian ”Compute” maka akan muncul seperti Gambar 3.9. maka isikan pada label kode wilayah. pada type & label di klik akan muncul tampilan compute variable: Type and label.9.3. Perlu diketahui bahwa variabel-variabel yang ada pada struktur data yang dimiliki yaitu variabel provinsi (B1R1) dan kab/kota (B1R2) masing-masing sebanyak dua digit. (Gambar berikut ini) Pedoman Pengolahan Menggunakan Software SPSS 39 . Gambar 3. Maka untuk membuat kombinasi dari kedua variabel tersebut menjadi variabel baru dengan cara memanipulasi variabel yaitu dengan melakukan proses compute. Apabila ingin menghasilkan tabel yang berasal dari combinasi dari beberapa variabel maka perlu dibangun/dibuat terlebih dahulu variabel tersebut dengan memanfaatkan fasilitas compute. misal kodwil yang merupakan singkatan dari kode wilayah. Contoh: akan dilakukan pembuatan kode wilayah yang unik hanya sampai kabupaten sehingga menghasilkan empat digit. Proses Numeric Expression  Setelah itu pada ”target variabel” isikan variabel yang diinginkan. dan type tetap Numeric.3 Memahami Proses Compute Proses compute digunakan untuk proses pengolahan lebih lanjut dengan cara melakukan manipulasi nilai variabel.

Untuk menghasilkan Syntax program Compute tekan Paste 40 Pedoman Pengolahan Menggunakan Software SPSS . COMPUTE kodwil = (B1R1 * 100) + B1R2 . EXECUTE . Gambar 3.11.10. Agar supaya proses tersebut tidak terhapus maka sebelum dipilih “ok” terlebih dahulu pilih “paste” dan hasilnya seperti dibawah ini. (B1R1*100)+B1R2. maka disarankan untuk menyimpan proses tersebut dalam file syntax. Jika ingin menyimpan proses pendifinisian variabel baru tersebut dan apabila diperlukan untuk mengecek proses pembuatan variabel baru tersebut sudah benar atau tidak. VARIABEL LABELS kodwil ’Kode wilayah’ . atau dengan cara memilih tanda () kemudian pilih variabel B1R1 dari jendela sebelah kiri. kemudian pindahkan ke jendela sebelah kanan dengan menekan lambang dan seterusnya sehingga menjadi (B1R1*100)+B1R2 setelah itu pilih ok. cara pertama bisa langsung dituliskan seperti berikut ini.Gambar 3. Memberikan nama variabel dan type Kemudian pada kotak ”numeric expression” isikan rumusan yang diingikan.

Gambar 3. pada variabel yang baru (kodwil) tidak ada angka desimal atau desimalnya nol sehingga hasilnya seperti pada gambar 3.13. akan ada tampilan seperti pada gambar 3. berikan nama file untuk syntax program tersebut. dan proses ini menjadi bagian dari pengawasan untuk mengecek kebenaran program. Hasil Proses Compute Pedoman Pengolahan Menggunakan Software SPSS 41 . selain itu juga dapat dilihat pada sheet ”Variabel View” baris terakhir. Pada variabel view lakukan pendefinisian variabel. Gambar 3. Menjalankan perintah compute dengan program syntax  Disarankan untuk semua prosedure compute atau perintah lainnya disimpan dalam file syntax. Kemudian jalankan perintah tersebut dengan membuka file syntax pada menu window SPSS.13.12. Simpanlah file syntax ini dengan memilih menu File kemudian save as.  Untuk melihat hasilnya dapat dilihat pada sheet ”Data view” variabel yang paling belakang atau paling ujung.12. Lakukan perintah RUN dan pilih ALL.

kemudian kondisi tersebut disesuaikan dengan persyaratan. Sebagai contoh akan dilakukan penghitungan dengan proses compute dengan membangun variabel bernama Usia belum menikah untuk jenis kelamin laki-laki. Tahapannya adalah sebagai berikut:  Tahapan yang dilakukan adalah sama dengan melakukan proses compute tetapi ditambah dengan memilih kodisi yaitu “IF”.14 dan isikan pada Numeric Expression dengan variable yang diinginkan missal umur (B4K5).Compute dengan fasilitas IF Proses compute dengan menggunakan fasilitas IF apabila terdapat beberapa persyaratan-persyaratan kondisi-kondisi yang harus dilakukan sesuai dengan kebutuhan. misal Jenis kelamin (B4K4) = 1 dan (&) Statust perkawinan (B4K6) = 1 setelah diisi selanjutnya pilih Continue maka muncu gambar 3. tahapannya sebagai berikut: o Pertama buka file o Dari menu SPSS pilih Transform Compute if maka muncul seperti gambar 3.14.14 kemudian pilih include if case satisfies condition (lihat tanda panah) dan isikan kondisi tersebut dengan cara memindahkan variable-variable dengan kondisi yang diingikan. Proses penggunaan if 42 Pedoman Pengolahan Menggunakan Software SPSS . o Untuk melihat hasilnya maka pilih Ok (Gambar 3.15) Gambar 3.

maka sebelum memilih Ok terlebih dahulu pilih Paste dan hasilnya seperti dibawah ini IF (B4K4=1 & B4K6 = 1) USIA_BLM_KWN_LK = B4K5 .Gambar 3. Proses Numeric Expression Gambar 3. EXECUTE .. Hasil akhir o Apabila ingin melihat syntax dari tahapan proses tersebut diatas.16. 43 Pedoman Pengolahan Menggunakan Software SPSS .15.

18.3. Gambar 3. Misal: Name: ”Kel_umur” dan Label: ”Kelompok Umur” (Gambar 3.4 Memahami Proses Recode Apabila ingin membuat nilai baru dari variabel yang ada baik menambah variabel ataupun pada variabel yang sama.18).17. dalam hal ini pilih Into Different Variables atau Into Same Variables (Gambar 3. tahapannya adalah sebagai berikut:  Pertama kali buka file yang memiliki variabel untuk di manipulasi  Dari menu utama SPSS pilih Transform Recode  Dari pilihan Recode ada dua pilihan. setelah variabel pindah kemudian isikan Name dan Label pada output variable sesuai yang diingikan. misal variabel umur (B4K5)  Pindahkan variabel B4K5 ke Input variable output variable dengan cara mengklik tanda . Proses recode variabel baru 44 Pedoman Pengolahan Menggunakan Software SPSS .17) Gambar 3. Memilih Into Different Variables  Pilih variabel.

kelompok 6: umur 25–29 tahun. yaitu 0 through 4 karena range umur antara 0 – 4 tahun sedangkan untuk kelompoknya yaitu kelompok 1. Setelah output variable terisi. maka pilih Change (Gambar 3.20.19 Perubahan Nama Variabel  Kemudian pilih Old and New Values Range dan isikan range tersebut. kelompok 9: umur 40–44 tahun. 13–15. kelompok 7: umur 30–34 tahun. dan 50 +. misal umur (B4K5) dikelompokkan. kelompok 5: umur 20–24 tahun. dan seterusnya. kelompok 3: umur 10–14 tahun. Biasanya umur tunggal ini dilakukan pembuatan variabel kelompok umur lebih dari satu kelompok. dan 16–18. kelompok 2: umur 5–9 tahun.20) Gambar 3. kelopok 8: umur 35–39 tahun.sesuai yang diinginkan. serta kelompok umur balita (0-5 tahun) dan batita (0-3 tahun). kelompok 4: umur 15– 19 tahun.  Pada contoh pengisian Old Value pilih Range kemudian isikan intervalnya. masing-masing: kelompok 1: umur 0–4 tahun. karena dapat dibuat misalnya menjadi kelompok umur pendidikan 5–12.19) Gambar 3. Proses pembuatan kelompok 45 Pedoman Pengolahan Menggunakan Software SPSS . Kelompok umur lainnya kerap kali dibutuhkan misalnya untuk wanita usia subur 15-49. Untuk kelompok umur yang lainnya dapat dilakukan dengan cara yang sama seperti kelompok 1 (Gambar 3. maka isikan angka 1 ke Value yang ada di New Value setelah itu pilih/klik Add.

Proses Hasil Akhir  Jika ingin melihat syntax dari proses recode. pilih/klik Continue maka akan mucul gambar sebagai berikut: Gambar 3. seperti gambar 3.22. VARIABLE LABELS Kel_umur ’Kelompok Umur’. EXECUTE .22 Gambar 3.21 Proses lanjutan pengelompokan  Terakhir pilih/klik OK atau Paste. untuk melihat hasilnya dapat dilihat pada variabel yang terakhir.Setelah selesai membuat pengelompokan umur. 46 Pedoman Pengolahan Menggunakan Software SPSS . sebelum memilih OK terlebih dahulu pilih/klik Paste dan hasilnya seperti dibawah ini Syntax Proses Recode: RECODE B4K5 (0 thru 4=1) (5 thru 9=2) (10 thru 14=3) (15 thru 19=4) (20 thru 24=5) (25 thru 29=6) (30 thru 34=7) (35 thru 39=8) (40 thru 44=9) INTO Kel_umur .

Untuk contoh ini sudah tersedia variabel penimbang yaitu KOR08_IND untuk data kor 2008 data individu.23)  Pilih variabel yang digunakan sebagai pembobot kemudian pindahkan ke Frequency Variable dengan cara memilih/ mengklik (lihat panah pada Gambar 3. maka proses selesai Gambar 3.24). pilih Data Weight Cases (Gambar 3. dalam hal ini file ”KOR08_IND”  Dari menu utama SPSS. Proses pembobotan Gambar 3.23.3. proses mengaktifkan caranya adalah sebagai berikut:  Buka file.24.5 Proses Mengaktifkan Penimbang (weigthing) Salah satu usaha untuk menghasilkan hitungan yang tidak terlalu jauh melenceng dari populasinya adalah dengan melakukan pembobotan atau penimbang.  Pilih/klik OK. Pemilihan variabel Pedoman Pengolahan Menggunakan Software SPSS 47 .

Karena identitas masing-masing kasus individu dan rumah tangga sama maka dapat digabungkan kedua file tersebut sehingga menghasilkan gabungan variabel data dari kedua file tersebut.25. Kegiatan menggabungkan kedua data tersebut ditujukan untuk mendapatkan tabulasi silang antara variabel yang ada dalam file rumah tangga dengan file individu. file rt terdiri dari 4 kasus (rumah tangga). namun variabelnya berbeda. Gabung variabel 11 12 21 22 23 31 32 33 34 41 42 Pengabungan ini adalah type menambah variabel dengan catatan jumlah kasus antara ke dua file jumlahnya berbeda akan tetapi identitasnya untuk kedua file tersebut sama. Add cases. Contoh: Akan dilakukan penggabungan file Susenas KOR08 Individu Provinsi Sulawesi Barat (KOR08_IND76. atau dengan lapangan pekerjaan. atau dengan kesehatan anggota rumah tangga. Apabila diperhatikan dari contoh penggabungan dua buah file tersebut. dan yang diharapkan dari hasil penggabungan kedua file tersebut menjadi 11 kasus Adapun proses penggabungannya adalah sebagai berikut:  Buka file. yaitu menggabung file yang mempunyai kasus yang sama atau identitas yang sama.3. yaitu menggabung file yang mempunyai susunan variabel yang sama namun kasus atau lokasinya berbeda. misal yang pertama KOR08_ID76 48 Pedoman Pengolahan Menggunakan Software SPSS .sav) dengan Susenas KOR08 Rumah Tangga Provinsi Sulawesi Barat (KOR08_RT76. sedangkan file individu terdapat 11 kasus (anggota rumah tangga).sav).6 Proses Penggabungan File (Merger) Proses ini digunakan untuk menggabung (merger) file yang satu dengan file yang lain atau file yang sekarang ada dengan file baru. miasalnya golongan pengeluaran rumah tangga di tabelkan dengan tingkat pendidikan yang ditamatkan. Add variables. 2. RT 1● 2● 3● 4● ● ● ● ● ● ● ● ● ● ● ● Gambar 3. Penggabungan file dapat dilakukan dengan dua cara: 1. Kalau digambarkan dalam bentuk diagram maka pola kedua file tersebut dapat digambarkan sebagai berikut: Individu .

 Setelah file sudah disort. yaitu file KOR_RT76. Usahakan variabel-variabel yang disort sama dengan variabel-variabel yang disort pada file KOR_IND76_sort. dalam hal ini kunci yang unik adalah dari variabel B1R1 (Provinsi) sampai dengan B1R8 (Nomor urut rumah tangga sampel) dengan cara memindahkan variabel-variabel sebut ke tempat Sort by kemudian pilih Sort Ordernya.sav  Lakukan sort file tersebut.  Setelah file dibuka. maka buka file yang terlebih dahulu disort yaitu KOR_ IND76_sort. Gambar 3.27 Proses merge Pedoman Pengolahan Menggunakan Software SPSS 49 .sav.27) Gambar 3.26. file disimpan dengan nama KOR_IND76_sort.26 Proses memilih variabel  Buka file yang akan digabung. Usahakan kunci untuk sort adalah yang unik. pilih/klik Data Merge File Add Variable (Gambar 3. Dari menu utama pilih Data Sort Cases kemudian pilih variabel-variabel sebagai kunci untuk sort. yaitu Ascending kemudian pilih/klik OK seperti Gambar 3. caranya sama dengan diatas. simpan file tersebut dengan nama file yang sama atau berbeda. sav.sav. Setelah itu.

file tersebut adalah KOR_IND76_sort. multiple response tables.28) Gambar 3. multiple response sets. yaitu basic tables dan general tables. tables offrequencies. yaitu B1R1.29 setelah semua variabel dipindahkan. yang terkait dengan rencana tabel dan kebutuhan tabel untuk indikator. B1R2. B1R5. B1R7 sebelum memindahkan variabel-variabel tersebut terlebih dahulu pilih/klik Match Cases on Key Variables in Sorted Files kemudian pindahkan variabel-variabel tersebut ke Key Variables (Gambar 3. Dalam hal ini yang akan dibahas hanya beberapa proses pembuatan tabel. diantaranya adalah custome tables.sav setelah dipilih maka akan muncul gambar seperti dibawah ini (Gambar 3. basic tables. Pilih file yang akan digabung. B1R4.7 Proses Pembuatan Tabel Ada beberapa macam fasilitas pembuatan tabel di dalam program SPSS. B1R3.29 Memiindahkan variabel kunci 3.28 File yang akan digabung  Pilih variabel-variabel sebagai kunci penggabungan file. general tables. 50 Pedoman Pengolahan Menggunakan Software SPSS . Gambar 3. maka pilih Ok maka file akan tergabung.

seperti rata-rata. standart deviasi.30 Proses Basic Tables  Pilih variabel-variabel yang akan digunakan untuk penghitungan nila rata-rata atau jumlah. pilih Analyze Tables Basic Tables maka akan muncul gambar 3.a. dan variabel status perkawinan dipindahkan ke across.31) Gambar 3. cara memindahkan variabel adalah dengan cara mengklik arah panah (Gambar 3.31 Proses pemindahan variabel 51 Pedoman Pengolahan Menggunakan Software SPSS . maka fasilitas basic tables dapat digunakan. misal pilih variabel umur lalu dipindahkan ke summaries. Adapun tahapan-tahapan dalam pembuatan basic tables adalah:  Buka file yang akan dilakukan proses pembuatan tabel  Dari menu utama SPSS. variabel jenis kelamin dipindahkan ke down. Untuk menghasilkan tabel dengan output berupa jumlah nilai variabel (sum) atau nilai rata-rata (means). varians dan lain sebagainya.30 Gambar 3. Basic Tables Tujuan dari pembuatan basic tables adalah memberikan gambaran dari data yang diperoleh baik dalam bentuk kuantitatif maupun kualitatif.

caranya sama seperti diatas hanya dengan memilih variabel yang digunakan untuk memisahkan yaitu memindahkan variabel pemisah ke separate. Gambar 3. Untuk penggunaan formula statistik yang dipakai misalnya untuk tabel rata-rata. hanya disini ditambahkan memilih variabel yang digunakan untuk membuat perbedaannya.32 dibawah ini. Summaries dipilih variabel umur. tahapannya adalah sebagai berikut:  Caranya sama dengan cara basic tables diatas. Hasil dari proses tabulasi seperti dibawah ini Status Perkawinan Belum Kawin Mean Jenis Kelamin Laki-laki Perempuan Umur Umur 11 11 Kawin Mean 41 36 Cerai Hidup Mean 44 44 Cerai Mati Mean 66 60 Untuk memisahkan hasil hitungan antara laki-laki dengan perempuan dapat dilakukan dengan menambah pilihan pada separate tablesnya. Separate Tables dipilih variabel jenis kelamin. Across dipilih variabel status perkawinan. untuk melihat hasilnya pilih OK.’) /OBSERVATION B4K5 /TABLES B4K4 > B4K5 BY B4K6 > (STATISTICS) /STATISTICS mean( ). TABLES /FORMAT BLANK MISSING(‘. dapat dilihat pada gambar 3.32 Proses separate tables  Untuk melihat hasilnya pilih/klik OK 52 Pedoman Pengolahan Menggunakan Software SPSS . Down dipilih variabel bekerja.32. maka caranya dengan memiilih/klik Statistic lalu kemudian Mean Add Continue akan kembali pada gambar 3. apabila ingin melihat syntaxnya maka sebelum pilih OK terlebih dahulu pilih Paste dan hasilnya seperti dibawah ini. * Basic Tables.

General Tables Penggunaan general tables pada umumnya sama dengan basic tables. Sebagai contoh ingin melihat kepemilikan akte kelahiran dengan hubungan kepala rumahtangga 53 Pedoman Pengolahan Menggunakan Software SPSS . namun pada general tables ditambah fungsi untuk pengolahan multiple response set. kemudian isikan variabel-variabel yang akan digunakan untuk penghitungan. maka muncul gambar 3. TABLES /FORMAT BLANK MISSING(‘. Tahapan penghitungan dengan menggunakan general tables sebagai berikut:  Pertama buka file yang akan diolah  Pada menu utama SPSS pilih Analyze Tables General Tables Gambar 3.Untuk melihat hasil hitungan pada jenis kelamin perempuan dapat dilakukan dengan mengklik dua kali pada tabel tersebut sehingga akan terlihat jenis kelamin perempuan. Syntax dari tahapan tersebut dapat dilihat dengan memilih Paste sebelum memilih OK Hasilnya sebagai berikut: * Basic Tables.33.’) /OBSERVATION UMUR /TABLES B5R21A1 > UMUR BY B4K6 > (STATISTICS) BY JK /STATISTICS mean( ). A b. perbedaannya adalah general tables tidak mempunyai besaran statistik yang lengkap.33 Proses general tables  Setelah memilih General Tables.

misalnya berupa bilangan angka pembilang dan angka penyebut yang dikalikan dengan nilai 100. bahwa proses pembuatan indikator sangat dipengaruhi sekali oleh konsep dan difinisi yang diterjemahkan dalam formulasi matematis. dan jenis kelamin dipindahkan ke layer. dan untuk melihat hasil hitungan maka dipilih/klik OK. Untuk mengurangi tingkat kesalahan. TABLES /FORMAT ZERO MISSING(‘. maka sebelum memilih OK terlebih dahulu pilih/klik Paste. Maka yang harus diisikan ke Row adalah variabel mempunyai akte kelahiran.8 Memahami Proses Select Cases Proses select cases digunakan untuk memilih kelompok data yang sesuai dengan kebutuhan. tentunya dengan mengikuti manajemen data yang telah diuraikan pada bab sebelumnya maka perlu dipersiapkan terlebih dahulu file datanya. Semua variabel dipindahkan. Namun untuk melihat syntax dari hitungan. 3. 54 Pedoman Pengolahan Menggunakan Software SPSS . tidak dapat ditunjukkan Tidak punya Tidak tahu 30 11 206 1 Cucu 4 1 24 1 Famili Lain 0 0 5 0 * General Tables. Perlu diketahui bahwa fungsi dari layer adalah sama dengan separate tables (lihat Gambar 3.’) /GBASE=CASES /TABLE=LAHIR BY B4K3 > (STATISTICS) BY B4K4 . variabel hubungan kepala rumahtangga dipindahkan ke column.34 Proses pemindahan variabel  Hasil hitungan dengan general Hubungan kepala rumah tangga Anak Mempunyai akte kelahiran Ya.31). menjadi indikator dengan nilai persentase.menurut jenis kelamin. Perlu dipahami. Gambar 3. dapat ditunjukkan Ya.

dan kasus berdasarkan kondisi tertentu (if condition is satisfied).35 Proses Select Cases dari menu Data Proses select mempunyai beberapa pilihan opsi.Dicontohkan membentuk file data kelompok balita dengan menggunakan proses select cases. Gambar 3. Lakukan pengisian pada jendela select cases if nama variabel dan kondisinya. lihat gambar 3.dat).38.36 memilih menu IF Maka tampilan berikutnya seperti pada gambar 3.36. untuk seluruh kasus (All cases). lalu lanjutkan dengan menekan tombol continiu. seperti pada tampilan gambar 3. Pilihlah opsi untuk file data tersebut hasilnya hanya ditandai saja (filtered) atau yang tidak terpilih di buang (deleted) sehingga hanya data yang diinginkan saja yang terdapat pada layar monitor. Gambar 3. Pedoman Pengolahan Menggunakan Software SPSS 55 . Maka selanjutnya tampilan kembali seperti gambar 3. kemudian jalankan menu utama Data Select Cases.35. Pilihlah menu IF untuk (if condition is satisfied) seperti pada gambar 3.37. Pada contoh ini dituliskan variabel umur < 5 tahun.36. Mulai dengan membuka data yang terdapat kelompok umur balita tergabung didalamnya (Gab_ind. Pada umumnya penggunaan select cases hanya 2 opsi pertama saja yaitu.

USE ALL. Memasukkan variabel umur < 5 sebagai penentu Gambar 3. 56 Pedoman Pengolahan Menggunakan Software SPSS .Gambar 3. Apabila penggunaan perintah deleted dan disimpan dengan nama yang sama akan berakibat data yang lama (aslinya) akan hilang tertimpa dengan data yang baru sesuai dengan persyaratannya. Memilih hapus data yang tidak dibutuhkan (deleted) Proses selanjutnya OK atau Paste untk mendapatkan syntax program SPSS yang otomatis terdapat dalam file syntax. Adapun format syntax program tersebut adalah sebagai berikut: FILTER OFF. EXECUTE . Disarankan untuk menyimpan data setelah proses select cases dengan menggunakan perintah deleted dengan menggunakan nama file yang berbeda.37.38. SELECT IF(UMUR < 5).

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->