Singkat-Padat-Jelas

Diktat

Disusun oleh:

Pengantar
Salam pendidikan.... Puji syukur ke hadirat Tuhan Yang Maha Esa, karena Dia senantiasa memberikan nikmatNya, sehingga penyusunan diktat Microsoft Access 2007 untuk mata pelajaran KKPI SMK kelas XI semua jurusan ini telah selesai. Diktat ini disusun guna memberikan bahan acuan pendamping belajar dan praktikum Ketrampilan Komputer dan Pengelolaan Informasi di Laboratorium Komputer SMK Yos Sudarso Kawunganten. Dalam hal ini diktat ini disusun berdasarkan kurikulum SMK khususnya pada mata pelajaran KKPI. Adapun perinciannya sebagai berikut : Standar Kompetensi : Mengoperasikan Sistem Operasi Software. Kompetensi Dasar : 1. Mengoperasikan Software Aplikasi Basis Data. 2. Melakukan Entry Data Aplikasi dengan Keyboard. 3. Melakukan Update dan Delete Data dengan Utilitas Aplikasi. Akhirnya kami mengucapkan terima kasih kepada semua pembaca yang telah meluangkan waktu membaca diktat ini. Semoga bermanfaat. Cilacap, Februari 2011 Penulis

KD-1
A.

: MENGOPERASIKAN SOFTWARE APLIKSI BASIS DATA
PENGENALAN SOFTWARE BASIS DATA (DATABASE) 1. Pengertian Database Dalam kehidupan sehari-hari, kita tidak akan bisa lepas dari data. Misalnya data tentang peserta didik, nilai, harga, makanan, dan lain-lain. Agar data menjadi suatu informasi yang bermanfaat bagi orang yang membacanya, maka data harus diorganisasikan dan diolah dalam suatu file database. Untuk pengorganisasian dan pengolahan data dengan komputer dibutuhkan suatu sistem manajemen database (DBMS). Dengan DBMS, kita dapat menambah, mengubah, menghapus, dan mengurutkan data sesuai dengan urutan yang sesuai dengan yang diinginkan serta membuat laporan bagi data tersebut. Database atau biasa dikenal dengan basis data adalah kumpulan data yang terhubung dengan suatu objek, topik, atau tujuan khusus tertentu. Contoh database antara lain : buku telepon, buku kamus, katalog buku diperpustakaaan, dan lain-lain. 2. Mengenal Microsoft Access 2007 Microsoft Access 2007 atau lebih dikenal dengan sebutan Access 2007 merupakan salah satu perangkat lunak yang diperuntukkan untuk mengolah database di bawah system Windows. Dengan menggunakan Microsoft Acces 2007 Anda dapat merancang, membuat, dan mengolah database dengan mudah dan cepat. Banyak kemudahan yang akan diperoleh jika bekerja dengan microsoft Access 2007 diantaranya dapat melakukan proses penyortiran pengaturan data, pembuatan label data serta laporan pembuatan data kegiatan sehari-hari misalnya untuk menampung daftar pelanggan, pendataan data karyawan, dan lain sebagainya. 3. Database Dalam Access 2007 Di dalam mengolah database, Access 2007 memiliki sarana atau objek yang dapat mempermudah dalam membangun sebuah database. Adapun objekobjek tersebut antara lain :
Tabel 1.1 Objek dalam Access 2007

Objek Table Query Form

Report

Kegunaan Merupakan tempat atau sarana untuk penyimpanan data Digunakan untuk menyaring data dengan berbagai kriteria dan urutan yang diinginkan Digunakan untuk memasukkan dan mengubah data atau informasi yang ada didalam suatu database dengan menggunakan tampilan formulir Digunakan untuk menampilkan atau mencetak data atau informasi dalam bentuk laporan

Ada beberapa istilah yang harus diketahui pada saat bekerja dalam lingkungan Access 2007 yaitu : Diktat Microsoft Access 2007 | 1

Field umumnya tersimpan dalam bentuk kolom secara vertikal pada tabel. Record merupakan data lengkap dalam jumlah tunggal yang biasanya tersimpan dalam bentuk baris secara horizontal pada tabel.a. Memulai Microsoft Access 2007 Untuk menjalankan Microsoft Access 2007. c.2 Tampilan awal Access 2007 Diktat Microsoft Access 2007 | 2 . Record Field Gambar 1. Field adalah tempat atau dimana data atau informasi dalam kelompok yang sama atau sejenis dimasukkan. b. ikuti langkah sebagai berikut : klik Start pilih All Programs  pilih Microsoft Office  pilih dan klik Microsoft Office Access 2007. Gambar 1.3 Contoh tampilah field dan record 4. Tabel mengatur data di dalamnya dalam bentuk kolom (field) dan baris (record). Table adalah sekumpulan data yang memiliki topik tertentu.1 Memulai Microsoft Access 2007 Sehingga dilayar tampak kotak dialog Microsoft Access seperti berikut : Gambar 1.

Klik Office Button . Setelah muncul dialog untuk memasukkan nama file database. klik salah satu pilihan berikut : 1) Blank Database  jika ingin membuat sebuah database baru yang masih kosong. b. 5. b. Ketik nama filenya pada kotak dialog yang muncul disebelah kanan Access 2007. Membuat Database Baru Untuk membuat sebuah database baru. Double klik file database untuk membukanya. langkah-langkahnya sebagai berikut : a. 2) Feature Online Template  jika ingin membuat sebuah database dengan menggunakan template yang disediakan oleh Windows Sharepoints Service Site. Diktat Microsoft Access 2007 | 3 .Pada tampilan awal tersebut. Pilih file database yang diinginkan lalu klik tombol Open untuk membukanya. Gambar 1.4 Tampilan dialog blank database 6. 2. Klik tombol Close Database (Ctrl+W). Klik Create untuk pilihan Blank Database atau klik Download untuk pilihan yang ada di Feature Online Templates. Pada tampilan awal pilih Blank Database atau bisa juga memilih New  Blank database pada bagian Microsoft Office Button. langkah-langkahnya sebagai berikut : a. cari folder atau alamat tempat tersimpannya file database. pilih salah satu langkah berikut : 1. Membuka File Database Untuk membuka file database dapat dilakukan dengan cara : a. c. Klik tombol Create untuk membuat sebuah database atau tombol Cancel untuk membatalkan proses pembuatan file database. Bila sudah menemukan file database yang diinginkan. Menutup File Database yang Aktif Untuk menutup database yang sedang aktif. 7. isikan alamat beserta nama file database secara manual atau bisa mengklik tombol folder untuk menyimpan secara otomatis. b. Di dalam daftar folder. Klik Office Button lalu klik Open. c.

Dengan menggunakan tabel terpisah masing-masing topik berarti kita sudah melakukan suatu tindakan yang amat berguna bagi database. Berikut ini adalah jenis data yang disediakan oleh Access 2007 dan sering digunakan untuk membentuk sebuah tabel : Tabel 2. Untuk mengisi field dengan nomor urut otomatis untuk masing-masing record dan nilainya tidak dapat diubah. Pengertian Tabel Selain objek utama sebuah database.1 Jenis data pada Access 2007 Jenis Data Text Memo Number Date/Time Currency AutoNumber Yes/No Ole Object Hyperlink Lookup Wizard Keterangan Untuk pemasukan huruf. data guru. Jumlah karakter maksimum 255 karakter. Ukuran yang disediakan bisa mencapai satu GB. simbol. Untuk menampung dua macam keadaan.8. Bisa menampung hingga 255 karakter. Untuk pemasukan data yang berjenis numerik maupun angka biasa. dan spasi. jam. Jumlah karakter maksimum 64. menit. B. seperti data peserta didik. Untuk menampung data yang berjenis angka dengan format mata uang. tanggal. angka. Mengakhiri Access 2007 Untuk mengakhiri atau menutup Access 2007. Diktat Microsoft Access 2007 | 4 . Struktur tabel pada Access 2007 yang terdiri dari field-field yang mengelompokkan data ke dalam kelompok-kelompok yang berjenis sama. Memungkinkan Anda untuk membuat sebuah daftar pilihan yang berguna untuk pemilihan nilai dari tabel atau daftar. sebuah tabel bisa dipandang sebagai kumpulan data tentang topik yang khusus. Di dalam tabel perlu menentukan jenis dan ukuran yang dibutuhkan sesuai dengan besarnya data yang akan dimasukkan. BEKERJA DENGAN APLIKASI MICROSOFT ACCESS 2007 Membuat dan Memodifikasi Tabel pada Access 2007 1. dan lain sebagainya. Untuk pemasukan teks panjang dan berguna untuk memberikan keterangan dan lain-lain. Tabel terdiri dari dua bagian utama yaitu kolom (field) dan baris (record).000 karakter. Merupakan kombinasi teks dan angka. Yes (ya) atau No (tidak) Untuk menampung objek yang berasal dari aplikasi lain dari proses OLE (Object Linking dan Embeddeing). Sebab dengan demikian akan mengurangi kesalahan terutama di dalam memasukkan data. Dapat diisi dengan alamat hyperlink agar bisa terkait dengan data yang tersimpan di lokasi tertentu. Untuk menampung data waktu yaitu hari. Anda tinggal mengklik tombol Close (X) dari jendela Access yang sedang aktif atau tekan secara bersamaan tombol Alt dan F4 pada keyboard.

Ketikkan nama Peserta Didik.1  Maka secara otomatis Anda akan diminta memasukkan nama Ribbon view tabel. Gambar 2. Anda dapat merancang dan membuat dengan langkah-langkah berikut ini :  Buka file database yang Anda inginkan atau buat sebuah database baru. Gambar 2.3 Tampilan awal design view  Pada jendela design view isikan struktur tabel seperti di gambar berikut ini : Gambar 2. Hapus nama field tersebut. pilih tab Datasheet  klik View  pilih Design View.  Ketika pertama kali database dibuat atau dimunculkan. Lalu tekan OK. Oleh karena itu.2 Tampilan simpan tabel  Setelah itu akan muncul tampilan Design View dengan nama field yang secara otomatis terisi dengan ID. Merancang Tabel Untuk membuat sebuah tabel baru. Gambar 2. maka secara otomatis akan muncul tampilan table1 dalam format Datasheet View.4 Struktur tabel peserta didik Diktat Microsoft Access 2007 | 5 .2. Walaupun begitu tidak disarankan merancang tabel dalam format datasheet view karena struktur dan jenis data tabel tidak terlalu terlihat.

Isikan sesuai dengan perubahan yang Anda buat pada field di sebelahnya. terdapat beberapa pilihan yaitu : Tabel 2. Gambar 2. Pada Field Name. form.). simpan struktur tabel tersebut. Diktat Microsoft Access 2007 | 6 . Pilih field yang akan dijadikan primary key contoh : NIS.  Pada Description isikan keterangan dari nama field beserta properties yang diubah (sebagai contoh field size dari nama field yang ada).2 Pilihan field properties Perintah Field Size Format Input Mask Decimal Place Caption Default Value Validation Rule Validation Text Required Allow Zero Length Indexed Kegunaan Untuk menentukan jumlah maksimum karakter yang diisikan pada field tersebut Untuk menentukan format tampilan data Untuk menentukan standarisasi tampilan pada saat memasukkan data di layar Untuk menentukan jumlah angka desimal yang diinginkan Untuk menempatkan keterangan sebagai judul kolom.  Pada saat mengisi nama field.  Pada Data Type pilih jenis data sesuai struktur di atas. Anda perlu menentukan nama field mana yang akan dijadikan Primary Key.5 Ribbon primary key  Pada kotak Field Properties. 2. atau laporan Untuk menempatkan data yang sering digunakan atau data yang sama pada field tertentu agar selalu ditampilkan kembali Untuk mengontrol atau membatasi sampai sejauh mana data yang Anda masukkan dalam sebuah database Untuk menampilkan keterangan atau pesan apabila data yang dimasukkan tidak sesuai dengan batasan yang ada di validation rule Untuk mengatur apakah field ini boleh dikosongkan atau tidak pada saat pengisian record Untuk mendefinisikan nilai blank (““) yang membedakan dengan nilai null Untuk membuat index pada field yang disorot  Setelah selesai membuat struktur tabel di atas. Pilih tab Design  klik Primary Key. ketikkan nama field sesuai dengan struktur tabel di atas. maka langkahnya sebagai berikut : 1. Misalnya nama field NIS (posisikan kursor dalam keadaan aktif di field name NIS) dijadikan sebagai primary key (biasanya field yang dijadikan primary key harus mengandung nilai yang UNIQUE dan bisa dijadikan acuan untuk nilai yang lain). Maksimum nama field 64 karakter dan tidak boleh mengandung titik (.

klik kanan kolom yang akan diganti. Modifikasi Tabel Setelah merancang tabel terkadang ada suatu perubahan yang mengharuskan modifikasi pada tabel yang dibuat. Merancang Tabel dengan Entering Data Untuk membuat sebuah tabel baru.8 Jendela kerja tabel kosong setelah nama fieldnya diubah 4.7 Tampilan jendela kerja tabel kosong  Untuk menggantikan nama field tersebut di atas. pengguna juga bisa menggunakan fasilitas Entering Data dengan langkah-langkah berikut ini :  Buka file database yang diinginkan. Diktat Microsoft Access 2007 | 7 . Untuk selanjutnya lakukan untuk menambah kolom dengan cara menekan tombol tab sehingga tampilannya seperti berikut : Gambar 2. kemudian pada tab Create kilk Table. Gambar 2.6 Tampilan tab create  Secara otomatis akan timbul tampilan seperti berikut : Gambar 2. Kemudian pilih Rename Column.3.

Menyisipkan/menambah field e. Aktifkan atau tempatkan kursor pada field JK. Adapun bentuk modifikasi tabelnya adalah sebagai berikut : a.Misalkan mengganti field. Misalkan akan mengganti data type Text dengan Number untuk field JK.9 Tampilan field tgl lahir b) Memperbaiki Jenis Data (Data Type) Untuk memperbaiki jenis data. Memindahkan letak field d. Gambar 2. ataupun menghapus field tersebut. Menghapus field a) Memperbaiki Nama Field (Field Name) Untuk memperbaiki nama field caranya sebagai berikut : a.10 Tampilan jenis data JK 5. Buka field tabel yang ingin diperbaiki. Memperbaiki jenis data (Data Type) c. b. Simpan kembali struktur tabel tersebut. Diktat Microsoft Access 2007 | 8 . Memperbaiki nama field (Field Name) b. b. Memindahkan Letak Field Cara memindahkan letak field adalah sebagai berikut :  Misalkan pindahkan letak field KELAS dan letakkan setelah field JK. d. Pilih nama field yang akan diganti kemudian ketikkan nama field baru. lalu klik di bagian Data Type c. misalkan tabel peserta didik. caranya sebagai berikut : a. menambah atau menyisipkan field. Contoh ganti nama field TANGGAL LAHIR dengan TGL LAHIR. Gambar 2. Pilih tipe data Number.

 Klik Insert Rows di tab Design atau klik kanan lalu pilih Insert Rows.  Klik Delete Rows di tab Design atau klik kanan lalu pilih Delete Rows. Gambar 2. sedangkan lebarnya 20 dan letakknya setelah field KELAS.12 Struktur tabel setelah insert d) Menghapus Field Cara menghapus field adalah sebagai berikut :  Misal hapus field JK.  Tekan dan geser (drag dan drop) field KELAS lalu arahkan ke field JK lalu lepas mousenya.  Simpan kembali struktur tabel tersebut. dengan data typenya text.  Pindahkan kembali field KELAS ke tempatnya semula.11 Tampilan field kelas setelah dipindahkan c) Menyisipkan/Menambah Field Cara menambah atau menyisipkan field adalah sebagai berikut :  Misal sisipkan field JURUSAN.  Aktifkan/tempatkan kursor pada field setelah KELAS lalu klik. Gambar 2. Gambar 2.  Simpan kembali struktur tabel tersebut. Aktifkan kursor pada field KELAS lalu klik.13 Struktur tabel setelah JK dihapus Diktat Microsoft Access 2007 | 9 .  Aktifkan/tempatkan kursor pada field JK lalu klik.  Lalu ketik nama field JURUSAN.

Mengubah tinggi baris  Aktifkan baris yang akan diubah tinggi barisnya.14 Tampilan column width Gambar 2. isikan angkanya. Standard Width : Mengubah lebar kolom ke lebar kolom semula (standar). Diktat Microsoft Access 2007 | 10 . isikan angkanya.15 Isian row width  Pada kotak isian Row Height.  Klik tombol More yang ada dibagian Records lalu pilih Row Height atau klik kanan pilih Row Height sehingga muncul : Gambar 2. a.  Masuk ke tab Home. Mengubah lebar kolom  Aktifkan kolom yang akan diubah lebar kolomnya.  Klik OK.  Klik OK. Best Fit : Mengubah lebar kolom sesuai dengan banyaknya karakter pada kolom data.  Masuk ke tab Home. data/record pun dapat diubah ukurannya.  Klik tombol More yang ada di bagian record lalu pilih Column Width atau klik kanan pilih Column Width sengga muncul : Gambar 2.6.15 Isian column width  Pada kotak isian Column Width. 7. Mengubah Ukuran Data Seperti halnya field. Keterangan . baik lebar kolom maupun tinggi baris data.

 Klik tombol New yang ada pada bagian record atau klik kanan lalu pilih New Record.  Tabel hasil cetakan akan terlihat seperti berikut. Data baru akan selalu ditampilkan setelah data terakhir.8. Untuk menyisipkan data/record langkahnya sebagai berikut :  Pilih dan klik baris data/record yang akan disisipkan. Selanjutnya muncul jendela Print.  Masuk ke tab Home.16 Hasil mencetak tabel Diktat Microsoft Access 2007 | 11 . Selanjutnya OK. Menyisipkan/Menambah Data Penyisipan data/record berarti penambahan jumlah data yang telah ada. 9. langkah-langkahnya sebagai berikut :  Buka basis data tempat tabel yang akan dicetak berada.atif cepat dan singkat. 11. baik diurutkan berdasarkan Ascending (menaik) maupun Descending (menurun). 10.  Masuk ke tab Home.  Kemudian pilih tabel yang akan dicetak dengan cara mengkliknya. langkahnya sebagai berikut :  Pilih dan klik baris data/record yang akan dihapus.  Klik tombol Ascending pada bagian Sort & Filter. langkahnya sebagai berikut :  Pilih dan klik kolom NAMA sehingga isi kolom NAMA akan terseleksi. hanya tombolnya yang berbeda. Mengurutkan Data (Data Sort) Anda dapat mengurutkan data dengan cara re. kemudia klik Office Button  Print. Mencetak Tabel Untuk mencetak tabel yang telah dibuat. Gambar 2. Anda bisa melakukan pengaturan pada jendela Print.  Klik tombol Delete yang ada pada bagian Records atau klik kanan lalu pilih Delete Record. Menghapus Data Untuk menghapus data yang tidak diperlukan lagi.  Masuk ke tab Home. Untuk mengurutkan data secara Descending langkahnya hampir sama dengan Ascending. Misal urutkan data berdasarkan NAMA secara Ascending.

Berfungsi untuk mengeksekusi perintah. kewyboard juga digunakan untuk memasukkan data. Berfungsi untuk mengarahkan kursor.1 Kelompok tombol pada keyboard Tombol Modifikasi Tombol Pengunci Tombol Navigasi Tombol Edit Tombol Ketik Alt + F4 Ctrl + Alt + Del F1 Esc (Escape) Arah (tanda panah) Enter Delete Home End Ctrl. Berfungsi untuk menampilkan menu bantuan. Tidak itu saja. Diktat Microsoft Access 2007 | 12 . yaitu :  Keyboard Serial  Keyboard PS/2  Keyboard USB  Keyboard Wireless 2. Membuat atau Merancang Form Form merupakan salah satu objek database yang digunakan untuk mempermudah Anda memasukkan data pada tabel. Berfungsi untuk menghapus huruf yang ada di sebelah kanan kursor Berfungsi untuk memindahkan kursor ke awal baris. dengan form kita bisa menampilkan recordrecord yang memenuhi kriteria tertentu. dan Space Bar Semua tombol yang belum disebutkan di atas Berfungsi sebagai jalan pintas (shortcut) untuk menutup program aplikasi yang sedang aktif. dan Scroll Lock Up. 1. Selain itu. Left. Tab. atau bahkan menyertakan foto Anda maupun data siswa suatu sekolah yang datanya kita simpan. Delete. Down. Backspace. Right. Tabel 2. PENGENALAN KEYBOARD Keyboard merupakan salah satu perangkat masukan yang berfungsi untuk memasukkan perintah-perintah ke dalam komputer. Tabel 2. MEMBUAT FORM 1. Berfungsi untuk menampilkan task manager.KD-2 : MELAKUKAN ENTRY DATA APLIKASI DENGAN MENGGUNAKAN KEYBOARD A. mencari data. kita bisa membuat atau bahkan merancang form yang hanya memperlihatkan sebagian fielf dari sebuah tabel. Num Lock. Shift. Struktur dan Fungsi Tombol Keyboard Struktur dan fungsi tombol keyboard telah dibahas di kelas X. Berfungsi untuk memindahkan kursor ke akhir baris. baik berupa huruf maupun simbol. Insert. Dengan form. Berikut diingatkan lagi beberapaa tombolfungsi pada keyboard. Jenis-jenis Keyboard Secara fisik keyboard dibedakan menjadi 4. Berfungsi untuk membatalkan pelaksanaan perintah.2 Beberapa fungsi dari tombol pada keyboard B. menampilkan data. memperbaiki data dan mencetaknya. Page Up/Page Down. dan Alt Caps Lock. Home/End Enter.

Kita cukup memilih bentuk yang sudah disediakan oleh Access 2007. Membuat Form dengan Fasilitas Form Wizard Access 2007 menyediakan fasilitas Form Wizard dimana dalam pembuatan formnya tidak perlu merancang lagi layout form maupun gaya (style) form.  Pada form pertama pilih field-field yang akan ditampilkan pada formnya.  Pada menu Forms klik tombol More Forms lalu pilih Form Wizard. Dalam kasus ini pilih semua field lalu klik Next. Sedangkan nama file tabelnya yaitu Peserta Didik dengan struktur tabel sebagai berikut : Gambar 2. Untuk memilih semua field klik tombol >>.2.1 Struktur tabel Peserta Didik Untuk membuat form dengan fasilitas Form Wizard ikuti langkah berikut ini :  Buka tabel Peserta Didik  Klik tab Create. Dalam hal ini ada empat pilihan yaitu :  Columnar  Tabular  Datasheet  Justified Pilih Columnar lalu klik Next. Apabila ingin memilih salah satu field.2 Form pemilihan field  Pada form kedua pilih tampilan atau layout form yang diinginkan. Gambar 2. anda bisa mengklik dua kali field yang diinginkan atau tinggal mengklik tombol >. Sebelum membuat form. terlebih dahulu buatlah file database dengan nama Database Pendidikan. Diktat Microsoft Access 2007 | 13 .

3 Form pemilihan tampilan  Pada form ketiga. kita juga bisa memilih untuk membuka form atau memodifikasi tampilan form yang sudah dibuat.Gambar 2. Klik Finish untuk melihat hasil formnya.5 Form isian nama  Maka tampilan formnya adalah sebagai berikut : Diktat Microsoft Access 2007 | 14 . Gambar 2.4 Form pemilihan style  Pada form keempat kita harus memasukkan nama dari form yang kita buat. Pilih Access 2007 lalu klik Next. Gambar 2. Pada form tersebut. anda bisa memilih style yang anda suka. Masukkan form Peserta Didik pada isian nama form lalu pilih Open the form to view or enter information.

7 Tampilan mengubah form Diktat Microsoft Access 2007 | 15 . anda harus melakukan perubahan. 3. Gambar 2. Mengubah Desain Form Jika form yang dibuat ingin dimodifikasi sehingga menghasilkan form yang menarik.Gambar 2. klik kanan form Peserta Didik dan pilih Design View.6 Tampilan form peserta didik  Di bawah ini tampilan form. untuk melakukan perubahan tersebut.  Setelah itu anda dapat mengisikan data baru dengan mengklik tombol . Langkahlangkahnya adalah sebagai berikut :  Buka kembali Database Pendidikan. anda bisa mulai melakukan pengaturan ulang pada form tersebut. Pada jendela Navigation Pane. ada sebuah bar yang dapat digunakan untuk berpindah ke record selanjutnya maupun mencari record yang diinginkan.

Diktat Microsoft Access 2007 | 16 . Maka terlihat hasilnya seperti pada gambar. Gambar 2. Misal judulnya diubah menjadi “Peserta Didik SMK Yos Sudarso Kawunganten”. Selanjutnya muncul tampilan berikut.8 Desain form siap diubah  Sekarang coba anda merubah judul pada Form Header. Hal ini dapat dilakukan dengan meletakkan kursor di Form Header dan kemudian ketiklah perubahan judul yang diinginkan. Gambar 29 Mengubah judul form  Setelah selesai melakukan perubahan klik tab Design  pada ribbon yang tampil pilih View  Form View. hasilnya seperti terlihat pada gambar berikut.

Buat form dengan menggunakan Form Wizard.10 Penambahan Jumlah nilai dan rata-rata pada Penilaian  Untuk membuat rumus di kolom jumlah nilai dan rata-rata caranya adalah: anda masuk ke Design View dari Penilaian.9 Hasil perubahan desain form peserta didik 4.Gambar 2. Jika anda mengklik dengan benar. Klik ganda textbox jumlah nilai. Musuk ke Design View tabel tersebut dan tampilkan field Jumlah Nilai dan Rata-rata. maka akan muncul properties box Diktat Microsoft Access 2007 | 17 . Hasilnya dapat anda lihat seperti berikut : Gambar 2.  Selanjutnya simpan perubahan tabel dengan menekan Ctrl + S. Menambahkan Fungsi Matematika pada Form Dalam bahasan menambahkan Fungsi Matematika ini kita akan menggunakan form Daftar Nilai yaitu menghitung Jumlah Nilai secara otomatis. Buatlah kembali sebuah form baru dengan nama Penilaian yang menampilkan semua field yang telah ada. Keduanya memiliki tipe data Number. langkahnya sebagai berikut :  Buka kembali tabel Daftar Nilai pada basis data Database Pendidikan.

Gambar 2. Hasilnya dapat anda lihat seperti pada gambar. klik OK. anda akan memasuki Expression Builder. lalu klik lagi nilai berikutnya yang akan dijumlah.11 Properties box dari textbox  Jika tombol diklik. di Gambar 2. kemudian klik ganda pada nilai yang akan dijumlah.13 Expresion Builder telah diisi dengan persamaan jumlah nilai Diktat Microsoft Access 2007 | 18 . Gambar 2. akan muncul tombol sebelah kanan kotak Jumlah Nilai.12 Expresion Builder   Ganti kotak dengan persamaan jumlah nilai yang sebelumnya telah diberikan.seperti pada gambar. Setelah selesai memasukkan persamaan. dan seterusnya sampai semua nilai yang akan dihitung dimasukkan. caranya :  Ketik tanda “=” (tanpa tanda “ “).  Klik sekali tanda tambah (+). Jika Control Source diklik.

B) Maksud dari fungsi tersebut. jika sebaliknya maka siswa tidak lulus. Sebagai contoh. sebaliknya siswa hanya mendapatkan nilai cukup. jika pernyataan benar. kita buat syaratsyarat. Gambar 2. Selanjutnya keluar dari Design View dan buka kembali form Penilaian. untuk contoh kasus Database Pendidikan ini. Kemudian akan diperoleh tampilan seperti berikut. maka yang diambil adalah nilai A. namun jika pernyataan salah. maka yang diambil adalah nilai B. Hal ini menunjukkan bahwa Control Source (sumber control) dari Text Box: jumlah nilai telah berubah. Microsoft Access telah menyediakan fungsi seleksi yaitu fungsi IIf. Untuk menyelesaikan kasus tersebut. simpan hasil kerja anda. jika seorang siswa mendapatkan nilai rata-rata di atas 65. dapat juga diberi batasan. Gambar 2. A. keterangan = Istimewa b) Nilai rata-rata < 85. keterangan = Cukup Diktat Microsoft Access 2007 | 19 . Sekarang. Format dari fungsi ini adalah : IIf(Pernyataan. maka siswa dinyatakan lulus. Maka akan diperoleh hasil seperti gambar berikut. Menambah Fungsi Seleksi pada Form Keterangan yang ditambahkan pada form Penilaian masih bersifat subjektif. jika siswa mendapatkan nilai diatas atau sama dengan 85 maka siswa mendapatkan keterangan istimewa.14 Control source dari text box  Jika telah berhasil mencapai langkah ini. sebagai berikut : a) Nilai rata-rata ≥ 85.15 Text box jumlah nilai telah menunjukkan data nilai total 5. sehingga perlu dibuat ukuran-ukuran yang jelas agar keterangan yang disampaikan memiliki makna.

karena kesalahan kecil saja akan memyebabkan Microsoft Access tidak mengeksekusi perintah yang diberikan.Kita berikan cukup dua syarat agar mudah bagi anda mempelajari fungsi seleksi ini. Langkah-langkahnya adalah sebagai berikut. Walaupun demikian Microsoft Access tetap mengenali fungsi ini sekalipun ditulis dengan huruf kecil. Dalam hal ini kita gunakan kata “Istimewa” dan “Cukup”. Kedua kata ditulis lengkap dengan tanda kutip dua. Gambar 2.  Perhatikan tanda kurung buka. Gambar 2. gunakan tanda kutip dua(“ “).  Penulisan yang tepat adalah IIf. Kemudian klik ganda textbox Keterangan dan ubah Control Source melalui Expression Builder.  Jika yang ditampilkan pada textbox adalah kata (bukan angka). =IIf([RATA-RATA]>=85. Anda akan melihat bahwa keterangan siswa telah berubah.18 Textbox keterangan telah menunjukkan perubahan Diktat Microsoft Access 2007 | 20 . simpan hasil perubahan yang anda lakukan dengan menekan Ctrl+S. buka kembali form Penilaian.  Buka kembali Design View dari form Penilaian.  Penulisan harus diawali dengan tanda sama dengan (“=”).  Jangan lupa meletakkan tanda kurung tutup! Klik OK.17 Mengubah control source dari text box: keterangan di expression builder Perhatikan dengan baik penulisan fungsi seleksi.16 Properties box dari text box: Keterangan  Ketikkan fungsi berikut di dalam Expression Builder."Istimewa".  Selanjutnya."Cukup") Gambar 2.

 Setelah form terbuka. perhatikan langkah berikut :  Buka form yang telah dibuat. 60 – 70 adalah kurang. sedangkan kurang dari 60 dapat diberi keterangan tidak lulus. Tabel Penilaian mengalami beberapa penambahan data. Jika lembar form telah terisi anda harus mencari lembar form yang kosong dengan menekan   Page Down atau dengan menekan pada form. 70 – 84 adalah baik. Selain mudah dan praktis. 7.Setelah anda mampu membuat suatu program seleksi di Expression Builder. asumsikan bahwa anda sudah mempunyai sebuah basis data yang didalamnya sudah terdapat tabel dan form. Setelah selesai melakukan input data jangan lupa untuk menyimpannya. Dapatkan anda melakukannya? 6.  Jika anda telah mengisikan data pada semua field dan akan pindah ke lembar form yang baru dapat menekan tombol Page Down atau tekan Enter pada field terakhir. dapat dilakukan dengan berbagai cara. Selanjutnya isikan data sesuai yang diinginkan sampai sesasai. Sebelum anda mulai memasukkan data. Aturan yang ada di dalam sistem manajemen basis data menyebutkan bahwa untuk memasukkan (entry) data ke dalam suatu basis data sebaiknya dilakukan melalui suatu form. misalnya form Penilaian. Selanjutnya anda dapat mulai memasukkan data pada form. penggunaan keyboard biasanya lebih dominan perannya. anda dapat menekan tombol Page Up. Memeriksa Hasil Entry Data Untuk memeriksa apakah data yang kamu masukkan sudah benar dan sudah tersimpan pada basis data. nilai 85 – 100 adalah istimewa. anda harus mengenal beberapa fungsi tombol pada keyboard yang digunakan saat memasukkan data pada form. Salah satunya dengan melihat tabel yang menyimpan data tersebut. Tetapi dari kedua alat tersebut. Gambar 2. Tab. sekarang akan dilihat data yang baru saja dimasukkan pada bagian sebelumnya. Caranya adalah sebagai berikut :  Buka tabel Penilaian. Sebagai contoh. Untuk entry data tersebut dapat dilakukan dengan menggunakan mouse atau keyboard. dan Arrow (panah).  Jika kamu ingin kembali ke lembar form sebelumnya.  Untuk berpindah dari field satu ke field yang lain anda dapat menekan tombol Enter. anda bisa mulai mengisikan data. mungkin anda akan lebih tertantang membuat syarat-syarat yang lebih ketat. pengguna form dimaksudkan untuk menghindari adanya duplikasi data. Misalnya. Entry Data pada Form dengan Menggunakan Keyboard Dalam hal ini.19 Tabel Penilaian telah mengalami penambahan data Diktat Microsoft Access 2007 | 21 .

digunakan untuk menuju ke rocord terakhir.  Tombol  Tombol digunakan untuk menuju ke record berikutnya. 8.21 Mencetak hasil entry data  Tekan Enter atau klik OK jika sudah selesai. artinya data yang dimasukkan tersimpan.  Kotak digunakan untuk menuliskan nomor record yang akan dipilih untuk ditampilkan. Diktat Microsoft Access 2007 | 22 . Gambar 2. Caranya adalah dengan membuka form Penilaian. pewarnaan dan sebagainya.  Klik All untuk mencetak semua data. Langkah untuk mencetak sebagai berikut :  Tekan tombol office  Print atau Ctrl+P. kemudian kamu periksa record pada setiap lembar form dengan menggunakan tombol navigasi yang terdapat pada bagian bawah jendela form Penilaian. anda dapat menggunakan tombol Properties. Anda juga bisa memeriksa hasil entry data dengan menggunakan form.20 Memeriksa hasil entry data menggunakan form Keterangan :  Tombol  Tombol digunakan untuk menuju ke record pertama. Anda bisa mengecek apakah datanya sudah benar atau belum.  Untuk melakukan pengaturan jenis kertas. Gambar 2. Data yang baru dimasukkan ada pada baris ketiga. Mencetak Hasil Entry Data Ada baiknya yang sudah anda masukkan ke dalam basis data juga dicetak ke atas kertas agar anda mempunyai arsip data tersebut secara fisik. digunakan untuk menuju ke record sebelumnya.

informasi yang semula dianggap tidak berguna sama sekali bisa berubah menjadi informasi berharga. Untuk memilih data atau record pada sebuah jendela datasheet dapat dilakukan dengan beberapa cara. Drag drop Pointer pada posisi selektor Kolom sesuai kebutuhan. PERSIAPAN MENG-UPDATE DAN MEN-DELETE DATA Salah satu peristiwa yang selalu terjadi adalah perubahan. Klik pada pisisi selektor Kolom. Sebuah informasi yang dahulu sangat penting bisa berubah menjadi tidak penting. Page Down atau menggunakan Vertikal scroll Bar. Drag drop Pointer pada posisi selektor baris sesuai dengan kebutuhan. untuk lebih jelasnya lihat pada daftar dibawah ini : Pilihan Sebuah sel Beberapa sel Sebuah Kolom Beberapa Kolom Sebuah record Beberapa record Semua Record Perintah Klik pada posisi sel tersebut.  Tekan kombinasi tombol Ctrl + A pada keyboard. Oleh karena itu untuk mengantisipasi terjadinya perubahanperubahan pada data yang dimiliki. Kebutuhan dan minatmu dapat berubah seiring anda tumbuh dan berkembang.  Pilih perintah Select All Record dari menu Edit. Drag drop pointer pada sisi kiri sel tersebut sampai melintasi beberapa sel yang ingin dipilih. Klik pada pisisi selektor baris. panah bawah. anda mungkin perlu menata atau mendistribusi ulang informasi tersebut. Memilih Field dan Record Anda harus memiliki data sebelum melakukan editing pada sebuah jendela datasheet. Sementara. Perhatikan tabel berikut : Diktat Microsoft Access 2007 | 23 .KD-3 : MELAKUKAN UPDATE DAN DELETE DATA DENGAN UTILITAS APLIKASI A. Panah atas. Seiring meningkatnya jumlah informasi dalam bidang bisnis dan kehidupan sehari-hari. 1. Page Up. 2. Selain itu Anda dapat juga memindahkan posisi Record Aktif dengan memilih tombol navigasi yang ada pada bagian bawah dari jendela datasheet sebuah tabel.  Klik tombol Select All pada selector baris. Memindahkan Insertion Point Untuk memindahkan Insertion Point atau data Record dalam sebuah datasheet dapat menggunakan fasilitas yang ada diperintah Go To dari menu Edit. ada baiknya mempelajari bagaimana cara meng-update (mengubah) atau men-delete (menghapus) data pada basis data.

Langkahnya sebagai berikut :  Buka basis data Database Pendidikan yang telah dubuat sebelumnya. Caranya. MENG-UPDATE (MENGUBAH) DATA Ada beberapa cara untuk melakukan update data pada suatu aplikasi basis data. Diktat Microsoft Access 2007 | 24 . 1.2 Update tabel  Selanjutnya masukkan data dari Dian Sastro dan Nicolas Saputra dengan benar. Pada Microsoft Access. B. Misalkan anda ingin meng-uodate data pada tabel “Peserta Didik” yang kita buat sebelumnya.dan form. bukalah tabel yang ingin diubah terlebih dahulu. query. Update Data Melalui Tabel Untuk meng-update data melalui tabel. Selanjutnya buka tabel Peserta Didik. Gambar 3. klik kanan pada selektor kolom. seperti pada gambar.1 Tabel Daftar Misalkan data di-update dengan menambahkan dua record baru dengan siswa bernama Dian Sastro dan Nicolas Saputra. update data dapat dilakukan melalui tabel. Pada buku ini.  Anda bisa mulai meng-update data setelah muncul jendela berikut ini. update data akan dilakukan melalui tabel dan query. lalu pilih New Record. Klik New Record Gambar 3.Pindah Ke Awal record Akhir record Record Sebelumnya Record berikutnya Record Baru Record tertentu First Record Last record Perintah Klik Previus Record Next Record New Record Atau tekan tombol F5 atau ketik nomor Record yang Anda inginkan dan lanjutkan dengan menekan tombol enter.

4 Tab menu Database Tools   Klik Relationship yang ada di bagian Show/Hide.Gambar 3. klik Tombol Office  Save atau klik ikon pada toolbar untuk menyimpan hasil update data. Sebelum membuat query. Klik Show Table yang ada dibagian Relationship. Langkah terakhir tutup tabel dengan mengklik Tombol Office  Close Database atau dengan mengklik ikon . Timbul sebuah tampilan relationship. Cara membuat relationship pada tabel-tabel tersebut adalah sebagai berikut :  Klik tab Database Tools. Membuat Query Query adalah sarana untuk mengatur data yang disimpan dalam tabel. Gambar 3. sehingga hanya data-data tertentu saja yang akan dimunculkan dalam tabel. 2. Gambar 3. Jadi query adalah tabel yang dibuat dari beberapa tabel lainnya dengan tujuan untuk mengelompokkan data baru berupa tabel dengan sumber tabel-tabel yang sudah ada. Update Data Melalui Query a.5 Form show table Diktat Microsoft Access 2007 | 25 . Query dapat menyortir data atau menampilkan data-data yang memenuhi kriteria tertentu atau juga dapat berupa ekspresi. tabeltabel yang akan digunakan harus dihubungkan terlebih dahulu satu sama lain karena ketika memuat query kita akan menggunakan kombinasi dari tabel-tabel tersebut.3 Memasukkan dua record baru   Setelah data selesai di update. Secara fisik query adalah tabel juga. Pada Form Show Table pilih tabel yang ingin kita hubungkan dengan cara sorot nama tabelnya kemudian klik Add.

Sebagai contoh anda klik field NIS yang ada di tabel Peserta Didik kemudian drag dan drop field tersebut dengan field NIS yang ada di tabel Penilaian.  Klik Query Wizard yang ada di bagian Other. Terdapat dua cara membuat query yaitu :  Membuat Query dengan Fasilitas Query Wizard. Gambar 3.  Klik tab Create. Gambar 3. Kemudian pada form Edit Relationship klik Create. Setelah memilih kemudian klik Close. Gambar 3.8 Tampilan relasi tabel Peserta Didik dan Daftar Nilai Setelah anda selesai membuat relasi antar tabel.6 Tampilan relationship  Untuk membuat sebuah relasi antar tabel anda bisa langsung menyorot field yang ingin direlasikan kemudian drag dan drop di field relasinya pada tabel yang berbeda. Cara untuk membuat query dengan query wizard adalah sebagai berikut :  Buka Database Pendidikan yang telah dibuah sebelumnya.9 Tampilan query wizard Diktat Microsoft Access 2007 | 26 . Sebuah query dapat dibuat dengan fasilitas yang telah disediakan oleh Access 2007 yaitu dengan fasilitas query wizard.  Membuat Query dengan Query Design 1) Membuat Query dengan Fasilitas Query Wizard.7 Form edit relationships Gambar 3. maka sekarang bisa dimulai membuat query.

PRODUKTIF. Kemudian anda bisa memilih Open the query to view information (melihat hasil query dalam bentuk tabel) atau Modify the query design (melihat hasil query dalam bentuk design view). NAMA SISWA. Masukkan nama query yang diinginkan pada isian yang telah disediakan.11 Form Simple query wizard   Klik tombol Next untuk menuju tahap berikutnya. MTK. dan RATA-RATA. pilih Simple Query Wizard lalu klik OK. Gambar 3. dan JURUSAN.10 Form new query  Pada form Simple Query Wizard lakukan pemilihan sebagai berikut :  Pada kotak daftar pilihan Table/Query. Selanjutnya klik Next. Kalau memilih Summary kita bisa menambahkan kesimpulan dari query yang akan dibuat. Klik Finish. Pada isian New Query. BINGG. KELAS. Jika ingin semua field tekan tombol >> sehingga field yang terseleksi akan tampak pada gambar di bawah ini. pilih dan klik nama tabel/query yang diinginkan. Sebagai contoh kita bisa menambahkan SUM untuk query yang telah dibuat. JUMLAH NILAI.  Pada kotak daftar pilihan Selected Field. misal:  Tabel Peserta Didik nama field yang diinginkan NIS. Pada form Simple QueryWizard pilih Detail (Shows every field of every record). Gambar 3. pilih field-fieldnya dengan menekan tombol >.  Tabel Penilaian nama field yang diinginkan yaitu BIND. Diktat Microsoft Access 2007 | 27 .

pilih dan klik nama field yang diinginkan.12 Tampilan masukan nama query  Maka hasil querynya adalah sebagai berikut.14 Form show table  Pada jendela yang tampil.  Klik Query Design di bagian Other. pilih field-field yang diinginkan sesuai urutan pada kolom-kolom yang disediakan. Lalu klik pada tombol daftar pilihan pada baris Field. antara lain :  Pada kolom pertama. query juga dapat dibuat dengan cara manual. Ulangi langkah tersebut untuk mengisi kolom-kolom berikutnya. Gambar 3. Pilih tabel yang diinginkan. Diktat Microsoft Access 2007 | 28 .  Pada form Show Table pilih tabel yang ingin di jadikan query dengan cara mengklik Add. Langkahlangkah pembuatan query manual adalah sebagai berikut:  Bukalah Database Pendidikan yang telah dibuah sebelumnya. Lalu klik Close. Untuk itu ada tiga cara yang dapat digunakan.13 Tampilan Peserta Didik Query 2) Membuat Query dengan Query Design Selain cara di atas.Gambar 3. Gambar 3. klik tombol daftar pilihan pada baris Table.  Klik tab Create.

Gambar 3. Bagaimana menampilkan jumlah nilai dan rata-rata pada query? Perhatikan langkah berikut : Diktat Microsoft Access 2007 | 29 . Pada kotak daftar pilihan field yang ada di bagian atas jendela kerja. klik dua kali nama field yang ingin ditampilkan.17 Hasil Query1  Kemudian simpan query tersebut dengan nama Peserta Didik Query1. yang ada di bagian Gambar 3. Ulangi langkah tersebut untuk mengisi kolom berikutnya. sehingga hasilnya adalah sebagai berikut. klik Run Results.15 Jendela kerja query1 Gambar 3. pilih dan klik nama field yang diinginkan lalu geser (drag) ke posisi kolom yang diinginkan. Dengan langkah ini secara otomatis field-field tersebut akan mengisi kolom berikutnya yang masih kosong.16 Isian query yang telah terisi  Untuk melihat hasil query yang dibuat.  Pada kotak daftar pilihan field yang ada di bagian atas jendela kerja.

Hasilnya sebagai berikut. Gambar 3. Gambar 3. Buka query Peserta Didik Query1. Masuk ke dalam Design View. Simpan hasil perubahan yang dilakukan di Design View. kemudian klik Properties. kamu dapat melihat query Peserta Didik Query1 telah menunjukkan jumlah nilai siswa. Gambar 3. Diktat Microsoft Access 2007 | 30 .19 Memasukkan rumus rata-rata  Simpan perubahan yang anda lakukan dan keluarlah dari Design View. beri tanda checklist pada kolom rata-rata di Design View.22 Mengubah format dari field rata-rata menjadi tipe Standard  Simpan hasil perubahan query dengan menekan Ctrl+S dan buka Peserta Didik Query1 dengan cara klik View  Datasheet View. Selanjutnya.18 Memasukkan rumus   Selanjutnya. kemudian ketikkan persamaan berikut : RATA-RATA:[JML NILAI]/4 Gambar 3.20 Jumlah nilai dan rata-rata telah ditampilkan pada query  Anda dapat mengubah jumlah desimal dengan mengklik kanan kolom ratarata pada jendela Design View. ketikkan rumus berikut : JML NILAI:[BIND]+[BINGG]+[MTK]+[PRODUKTIF] Perhatikan penggunaan tanda “:” dan bukan tanda “=”. pada kolom jumlah nilai. buka kembali Peserta Didik Query. Gambar 3. Jika ingin rata-rata ikut diperlihatkan dalam query.21 Melihat dan mengubah properties field rata-rata  Ubah Format pada field properties menjadi Standard.

b. MEN-DELETE (MENGHAPUS) DATA Data yang terdapat di dalam suatu basis data boleh jadi ada yang sudah tidak digunakan lagi. Gambar 3. 1. Gambar 3. Pilih Yes jika memang pasti data tersebut yang harus dihapus. Berikut langkah-langkahnya :  Buka basis data Database Pendidikan. Penghapusan data dalam basis data bisa dilakukan dengan berbagai bentuk. Produktif: 90. masukkan data yang ingin anda tambahkan dengan tepat. jika kita menginginkan record dari siswa bernama Dewi Persik untuk dihapus. Nama Siswa: Firman. maka klik kanan pada selektor record tersebut dan pilih Delete Record. Mtk: 70. Bingg: 82.26 Menghapus record siswa  Setelah memilih Delete Record. yaitu dengan men-delete (menghapus) record.23 Perubahan data melalui query  Simpan hasil perubahan yang dilakukan. kemudian pilih record yang hendak dihapus. dan menghapus tabel. kemudian masuklah ke Peserta Didik Query1. Bind: 75. Kelas: XI Oto 2. Diktat Microsoft Access 2007 | 31 . Oleh karena itu. Atau anda juga dapat menghapusnya dengan cara menekan tombol Delete pada keyboard atau melalui tab menu Home  . Agar tidak terjadi kesalahan menghapus data.  Pada record terakhir. Menghapus Record Sebelum menghapus data dalam bentuk record. Pada bagian ini kita akan menghapus record pada tabel Peserta Didik. menghapus field. data tersebut perlu kita hapus agar tidak memenuhi ruang penyimpanan dalam basis data. Berikut langkah-langkahnya :  Buka tabel Peserta Didik. Misalkan menambahkan data peserta didik berikut NIS: 3015. Update data melalui query Untuk melakukan update data melalui query caranya tidak jauh berbeda dengan update data melalui tabel. Misalnya. anda harus membuka tabel yang datanya akan dihapus. terlebih dahulu harus dipastikan bahwa memang data tersebut adalah data yang dihapus. C. atau pilih No untuk membatalkan penghapusan data. anda akan dihadapkan pada dialog box.

3. Menghapus Tabel Kita sudah mengetahui bahwa di dalam suatu basis data itu terdapat banyak tabel yang saling berhubungan antara tabel satu dengan tabel yang lain.  Selesai mengklik perintah Delete Rows. maka tabel tersebut sebaiknya dihapus. Menghapus Field Field pada suatu tabel yang sudah tidak diperlukan lagi dapat dihapus agar mengurangi kepadatan penyimpanan data dalam database. akan keluar jendela validasi.27 Tabel setelah penghapusan record 2.  Kemudian pilih tabel yang akan dihapus (Misalkan. Langkah-langkahnya sebagai berikut :  Buka kembali basis data Database Pendidikan. Setelah record dihapus. Hal ini dimadsudkan untuk mengurangi kepadatan penyimpanan data di dalam basis data. maka klik kanan selektor field-nya dan pilih Delete Rows. Jika field yang ingin dihapus adalah field JK.  Klik kanan selektor field yang ingin dihapus dan pilih Delete Rows. Adapun langkah-langkah untuk menghapus tabel adalah sebagai berikut :  Buka jendela Navigation Pane. tabel Peserta Didik).  Selanjutnya. Gambar 3. Gambar 3.28 Menghapus field JK pilihan Yes jika anda hendak menghilangkan dari tabel peserta didik field secara permanen dan pilihan No jika anda ingin membatalkan penghapusan. Penghapusannya dapat dilakukan melalui tabel dalam format Design View.29 Memilih tabel Peserta didik Diktat Microsoft Access 2007 | 32 . buka Design View dari tabel Peserta Didik. maka tabel akan tampak seperti pada gambar. Jika terdapat satu atau sejumlah tabel yang sudah tidak digunakan lagi. Jendela tersebut berisi Gambar 3.

 Klik kanan tabel Peserta Didik. Gambar 3.  Pilih tabel/query yang akan dibuat report-nya. Gambar 3. Klik Next. Salah satu cara untuk memeriksa data yang telah di-update adalah dengan menggunakan report. Pilih Yes untuk melanjutkan menghapus tabel atau pilih No untuk membatalkan penghapusan tabel. Diktat Microsoft Access 2007 | 33 . sebaiknya diperiksa apakah data yang di-update sudah benar atau belum. Langkah-langkah membuat report sebagai berikut :  Buka kembali file basis data Database Pendidikan.30 Perintah menghapus  Setelah memilih Delete. lalu klik/pilih . kecuali anda memasukkan ulang data tersebut. atau klik >> untuk memindahkan seluruh field kedalam Selected Fields. D. kemudian pilih Delete. akan muncul kotak konfirmasi.  Klik tab menu Create. Tujuannya adalah untuk menghindari kesalahan dalam meng-update data. Maka berhati-hatilah dalam menghapus data.31 Jendela Report Wizard  Selanjutnya pindahkan nama field-field yang akan dibuatkan report-nya dari Available Fields ke dalam Selected Fields. Tekan > untuk memidahkan nama field satu per satu. akan muncul gambar berikut. MEMERIKSA HASIL UPDATE DATA Setelah data di-update. Semua data yang telah dihapus tidak akan bisa dikembalikan lagi.

Misalnya layout yang dipilih Tabular dan Orientation yang digunakan Landscape seperti pada gambar. Pilih layout untuk report yang anda buat. Gambar 3.  Klik Next lagi.32 Jendela pengaturan style pada Report Wizard   Setelah anda memilih salah satu style yang tersedia.32 Jendela pengaturan layout pada Report Wizard   Klik Next untuk menuju ke tahap berikutnya. Kemudian anda bisa memilih Preview the report (melihat hasil report) atau Modify the report’s design (melihat hasil report dalam bentuk design view). Selanjutnya tentukan style (gaya) dari report yang akan ditampilkan.33 Tampilan masukan nama report Diktat Microsoft Access 2007 | 34 . Klik Finish. kemudian klik Next. klik Next. Gambar 3. Masukkan nama report yang diinginkan pada isian yang telah disediakan. Gambar 3. lalu atur penyortiran data jika diperlukan Ascending (menaik) atau Descending (menuru).

35 Mencetak hasil entry data      Pilih nama printer pada kotak Name: Isikan nomor halaman yang hendak dicetak. Setelah report dibuat. Gambar 3. **** ooOOoo **** Diktat Microsoft Access 2007 | 35 . yaitu :  Tekan Tombol Office  Print atau Ctrl+P. E. anda dapat menggunakan cara seperti pada bagian sebelumnya. Tekan Enter atau klik OK jika sudah selesai.34 Tampilan report Peserta Didik SMK Yos Sudarso   Jangan lupa untuk menyimpan report tersebut. anda bisa memeriksa data-data melalui report. maka akan tampil gambar berikut. Gambar 3. pewarnaan dan sebagainya. anda dapat menggunakan tombol Properties. pada kotak isian Page From: Klik All untuk mencetak semua data. Maka hasil querynya adalah sebagai berikut. Untuk melakukan pengaturan jenis kertas. MENCETAK HASIL UPDATE DAN DELETE DATA Untuk mencetak hasil update dan hasil delete data. maka tabel akan tercetak beserta datanya.

Memahami KKPI SMK.co. Harry. Penerbit PT Elexmedia Komputindo. Alexander Mangkulo. Jakarta. 2008.id Diktat Microsoft Access 2007 | 36 . Jakarta . Penerbit Erlangga. Buku Diktat Mata Kuliah Software Terapan II.google. Hengky. 2006. Unikom.DAFTAR PUSTAKA Modul KKPI VEDC Malang Mintana. www. Ketrampilan Komputer dan Pengelolaan Informasi untuk SMK dan MAK Kelas XI. 2005. D Fauzi. Bank Soal Access. Penerbit Armico. Bandung. Anjrah.

Sign up to vote on this title
UsefulNot useful