P. 1
BS-Menganalisis Data Spasial Dg ArcView GIS 3.3 Untuk Pemula

BS-Menganalisis Data Spasial Dg ArcView GIS 3.3 Untuk Pemula

|Views: 18|Likes:
Published by Sawal Core Xp

More info:

Published by: Sawal Core Xp on Feb 09, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

07/27/2013

pdf

text

original

117

GEOPROSESSING













GeoProsessing merupakan fasilitas yang paling sering digunakan
dalam mengolah data spasial. Melalui GeoProsessing kita dapat
membuat data baru melalui manipulasi theme pada view. Dalam
banyak kasus, manipulasi data grafis pada view dan analisis data
atributnya pada tabel mampu menghasilkan informasi baru yang
bermanfaat.
Modul GeoProsessing tidak dapat diakses langsung dari menu
ArcView, karena GeoProsessing merupakan Extention. Oleh sebab
itu, agar kita dapat memanfaatkan fasilitas ini kita harus meng-
aktifkannya terlebih dahulu. Dari menu File pilih Extentions.
Kotak di bawah ini akan muncul.
Pada pilihan Available Extentions, aktifkan modul Goprocessing
dengan mengklik kotak cek yang ada di depannya. Agar modul ini
tetap disertakan ketika kita memulai ArcView, aktifkan kotak cek
Make Default. Apabila modul geoprocessing telah aktif, maka
menu View akan bertambah pada baris paling bawah, yaitu
GeoProcessing Wizard. Menu ini selanjutkan akan digunakan
dalam proses GeoProsessing.
BAB
5
118

Gambar 5.1. Kotak dialog Extentions.
5.1 Memotong Theme Berdasarkan Theme
yang Lain
Fasilitas ini biasanya digunakan untuk memotong theme menjadi
bagian/daerah yang lebih kecil sesuai dengan keperluan. Misalnya
kita mempunyai peta kemiringan lereng daerah Kecamatan Kuta
Selatan, sedangkan kita hanya memerlukan peta kemiringan
lereng hanya untuk daerah penelitian yang hanya sebagian dari
Kecamatan Kuta Selatan. Maka dalam hal ini kita dapat memotong
(clip) peta kemiringan Kuta Selatan tersebut hanya sebatas daerah
penelitian. Perhatikan gambar di bawah ini.

a b
Gambar 5.2. Peta lereng yang akan dipotong (a), sebesar daerah
penelitian (b).
119
Untuk memotong peta lereng seluas daerah penelilian, ikutilah
langkah-langkah berikut.
1. Aktifkan peta yang akan dipotong (Ler_ks.shp) dan peta
pemotong (Batas_ks.shp) pada view yang sama seperti pada
gambar di atas.
2. Pilih GeoProcessing Wizard dari menu View. Kotak dialog
berikut akan tampil.

Gambar 5.3. Kotak dialog Geoprocessing Clip one theme
based on another langkah 1.
3. Plilh Clip one theme based on another kemudian klik Next. Ko-
tak dialog selanjutnya akan tampil.

Gambar 5.4. Kotak dialog Geoprocessing Clip one theme
based on another langkah 2.
120
4. Pada daftar pilihan Select input theme to clip, pilih theme yang
akan dipotong dalam hal ini Ler_ks.shp. Sedangkan pada daf-
tar pilihan Select a polygon overlay theme, pilih poligon pemo-
tong (Batas_ks.shp). Standarnya ArcView akan menyimpan
hasilnya pada folder Temp. Apabila Anda ingin menyimpan
pada tempat yang berbeda klik tombol dan tentukan lo-
kasinya. Klik Finish jika pengaturan telah selesai. Tampilan
theme seteleh dilakukan clipping adalah sebagai berikut.

Gambar 5.5. Tampilan theme hasil clipping.
Catatan
• Data atribut hasil proses clipping mempunyai struktur yang
sama dengan theme yang dipotong.
• Anda dapat menggunakan sebagian theme yang dipotong atau
theme pemotong dalam proses GeoProsessing, dengan
memilih objek tertentu saja pada theme tersebut. Kemudian,
pada kotak dialog GeoProsessing langkah 2 isikan kotak
cek Use Selected Features Only.
• Jika proses clipping Anda menemukan Error, disarankan untuk
menyimpan hasil clipping tidak pada folder Temp.
5.2 Interseksi Dua Theme
Pada proses clipping di atas, ArcView hanya mengambil batas
terluar theme pemotong yang selanjutnya dipakai sebagai batas
121
terluar theme yang dipotong, tanpa menyertakan informasi tabular
yang terdapat pada theme pemotong pada hasil clipping.
Sementara interseksi dua theme mempunyai prosedur yang
hampir sama. Akan tetapi pada theme hasil interseksi, kedua
informasi atribut disertakan pada tabel.
Kebanyakan pengguna ArcView menggunakan fasilitas interseksi
dua theme ini untuk overlay dua peta atau lebih dengan batas
daerah yang sama. Apabila Anda akan melakukan overlay tiga
peta atau lebih, Anda harus melakukan proses ini lebih dari satu
kali, karena dalam waktu yang bersamaan atau dalam satu proses,
ArcView hanya dapat melakukan overlay dua peta.
Pada contoh di bawah ini, kita akan melakukan overlay dua peta,
yaitu peta kemiringan lereng (Ler_ks.shp) dan peta curah hujan
(Hujan_ks.shp) untuk menentukan daerah yang rawan terhadap
erosi, dengan asumsi bahwa semakin tinggi tingkat kemiringan
lereng dan curah hujan suatu daerah maka bahaya erosi akan
semakin tinggi. Kemiringan lereng pada daerah contoh dibagi
menjadi enam kelas dengan nilai skor 1 sampai 6. Sementara
Curah hujan dibedakan menjadi 3 kelas dengan nilai skor 1 sampai
3. Tampilan peta kemiringan lereng dan peta curah hujan pada
view adalah seperti gambar berikut.

a b
Gambar 5.6. Peta kemiringan lereng (a), dan Peta curah hujan (b).
Sementara tampilan data atribut kedua theme tersebut sebelum
dilakukan overlay tampak seperti gambar di bawah ini.
Kelas lereng berkisar dari 1 sampai 6, sedangkan kelas hujan dari
1 sampai 3. Kriteria yang digunakan untuk menilai bahaya erosi
122
adalah dengan formula berikut:
Total Skor = (2 * Skor lereng )+ (Skor Hujan)
Hasil perhitungan total skor kemudian dicocokan dengan Tabel 5.1
untuk menentukan kriteria tingkat bahaya erosi.

a b
Gambar 5.7. Data Atribut peta kemiringan lereng (a), dan peta curah
hujan (b).
Tabel 5.1. Kriteria tingkat bahaya erosi.
No Total Skor Kriteria
1 < 5 Rendah
2 5 – 8 Sedang
3 > 8 Tinggi

Ikutilah langkah-langkah berikut untuk melakukan overlay dengan
kriteria di atas.
1. Buka kedua peta atau theme yang akan digunakan untuk over-
lay pada view yang sama seperti pada Gambar 5.6.
2. Dari menu View pilih GeoProcessing Wizard. Pada kotak
GeoProcessing, pilih Intersect two theme seperti gambar beri-
kut ini.
123

Gambar 5.8. Kotak dialog GeoProcessing Intersect two theme
langkah 1.
3. Klik Next untuk melanjutkan ke langkah berikutnya. Pada ko-
tak dialog langkah ke-2, pilihlah theme yang akan digunakan
sebagai input pada daftar pilihan Select input theme to intersect
dan theme yang dipakai untuk overlay pada Select an overlay
theme. Apabila batas luar theme yang dioverlay berbeda,
maka hasil dari proses ini akan mengikuti batas luar theme
yang dipilih pada Select an overlay theme. Akan tetapi pada
contoh ini, kedua theme yang digunakan dalam overlay mem-
punyai batas luar yang sama sehingga Anda bebas menentu-
kan salah satau theme yang akan digunakan sebagai theme
input dan theme overlay. Tentukan lokasi di mana hasilnya
akan disimpan. Kalau tidak, ArcView akan menyimpan pada
folder Temp.

Gambar 5.9. Kotak dialog GeoProcessing Intersect two theme
langkah 2.
124
4. Klik Finish, hasilnya seperti gambar di bawah ini.

a

b
Gambar 5.10. Peta (a) dan data Atribut (b) hasil proses interseksi.
Selanjutnya, dilakukan pengolahan data atribut pada tabel hasil
interseksi untuk menjumlahkan skor kedua theme tersebut dan
membuat kriteria bahaya erosi. Prosedurnya sebagai berikut.
1. Aktifkan tabel hasil proses interseksi, dalam contoh di atas
Attribute of ltsct1.shp.
2. Tambahkan 2 field, masing-masing dengan nama tot_skor,
tipe numerik, lebar 3, desimal 0 dan Kt_erosi, tipe string, lebar
10. Pembahasan detail tentang menambah field lihat Bab
‘Mengelola Tabel’.
3. Tandai field tot_skor, kemudian dari menu Field pilih
Calculate. Lengkapi kotak dialog Field Calculator berikut.
125

Gambar 5.11. Kotak dialog Field Calculator.
4. Lengkapi field Kt_erosi dengan kriteria seperti pada Tabel 5.1.
Pertama gunakan perintah Table Ö Query untuk memilih
record yang mempunyai nilai < 5.

Gambar 5.12. Memilih record yang mempunyai total skor kurang
dari 5.
5. Setelah diklik New Set, maka semua record yang mempunyai
total skor kurang dari 5 akan terpilih. Gunakan menu Field Ö
Calculate untuk mengisi kriteria "Rendah" hanya pada field
yang telah terpilih.
126

Gambar 5.13. Mengisi kriteria rendah dengan Field Calculator.
6. Ulangi prosedur nomor 4 dan 5 masing-masing untuk mengisi
kriteria "Sedang" dan "Tinggi". Gunakan ekspresi ( [Tot_skor]
>= 5 ) and ( [Tot_skor] <= 8 ) untuk memilih record yang
mempunyai kriteria "Sedang", dan ( [Tot_skor] > 8 ) untuk
menandai record yang memiliki kriteria "Tinggi".
7. Jika semua kriteria telah dilengkapi, tampilan data Attribute of
ltsct1.shp dan petanya berturut-turut akan tampak seperti pada
gambar di bawah ini.

Gambar 5.14. Tampilan data Attribute of ltsct1.shp
setelah semua field dilengkapi.
127

Gambar 5.15. Tampilan peta bahaya erosi.
Catatan
Dalam teori, sebenarnya perhitungan tingkat bahaya erosi tidak
sesederhana seperti contoh di atas. Akan tetapi, di sini hanya
digunakan sebagai contoh untuk memudahkan pemahaman
interseksi 2 theme, karena perhitungan erosi yang sebenarnya
menggunakan prosedur yang panjang.
T i p
Untuk melakukan prosedur nomor 4 dan 5 secara berulang-ulang,
Anda tidak perlu menutup kotak dialog Query saat mengambil
menu Calculate sehingga pekerjaan menjadi lebih efisien.
5.3 Union Dua Theme
Union dua theme mempunyai prosedur yang sama dengan
interseksi dua theme. Hanya saja, hasil dari interseksi dua theme
menampilkan theme yang berinterseksi. Sementara hasil union
dua theme menghasilkan gabungan dari kedua theme tersebut
walaupun theme tidak berinterseksi. Perhatikan Gambar 5.16.
Jika Anda melakukan overlay dua theme pada daerah yang sama,
penggunaan union dua theme pada theme yang mempunyai batas
luar yang tidak persis sama, sering menyebabkan adanya poligon
sliver, yaitu poligon bukan hasil overlay melainkan adanya batas
128
luar theme yang berbeda pada daerah yang sama. Hal ini akan
mengganggu hasil overlay. Lihatlah contoh pada Gambar 5.17.

Gambar 5.16. Kotak dialog GeoProcessing Union two themes.

Gambar 5.17. Contoh poligon sliver.
Untuk itu penggunaan interseksi dua theme merupakan salah satu
cara yang dapat digunakan untuk menghilangkan poligon sliver.
Penggunaan interseksi dua theme akan memberikan hasil yang
sama dengan union dua theme apabila batas luar kedua theme
persis sama.
Dengan menyuraikan perbedaan dan persamaan interseksi dua
theme dan union dua theme, di sini kita tidak akan membahas
union dua theme lebih jauh karena menggunakan prosedur yang
sama dengan interseksi dua theme.
Poligon
sliver
Poligon
sliver
129
5.4 Menggabungkan Objek Berdasarkan Data
Atribut
Jika kita perhatikan kembali Gambar 5.15 hasil interseksi peta
lereng dan peta hujan untuk memperoleh peta bahaya erosi terlihat
ada sedikit kejanggalan, yaitu kelas bahaya erosi yang sama yang
terletak bersebelahan dibatasi oleh garis pemisah. Hal ini
menyebabkan tampilan peta menjadi kurang baik. Oleh sebab itu,
kita perlu menghilangkan garis pemisah kelas yang sama dengan
menggabungkan objek atau kelas yang sama (Dissolve)
berdasarkan kesamaan nilai atributnya dalam hal ini nama kelas
bahaya erosi, yaitu rendah, sedang, dan tinggi.
Proses dissolve ini juga akan membuat ringkasan terhadap kelas
tingkat bahaya erosi. Sebelum proses tersebut dilakukan,
sebaiknya tabel Attribute of ltsct1.shp kita tambahkan 1 field
dengan nama Luas_ha untuk menyimpan informasi luas pada
masing-masing kelas. Untuk melakukan hal tersebut, gunakan
prosedur berikut.
1. Aktifkan tabel Attribute of ltsct1.shp, tambahkan 1 field dengan
nama Luas_ha, tipe numerik, lebar 10, desimal 2.
2. Gunakan menu Field Ö Calculate untuk menghitung luas
masing-masing record seperti pada gambar di bawah ini.

Gambar 5.18. Kotak dialog Field Calculator untuk menghitung luas.
130
3. Aktifkan view dan theme hasil interseksi seperti Gambar 5.15,
dari menu View pilih GeoProcessing Wizard. Di kotak dialog
GeoProcessing pilih Dissolve feactures based on an attribute.

Gambar 5.19. Kotak dialog GeoProcessing Dissolve feactures
based on an attribute langkah 1.
4. Klik Next. Pada daftar Select theme to dissolve pilih ltsct1.shp,
sedangkan pada daftar Select an attribute to dissolve pilihlah
Kt_erosi. Tentukan pula di mana hasilnya akan disimpan pada
Specify the output file.

Gambar 5.20. Kotak dialog GeoProcessing Dissolve feactures
based on an attribute langkah 2.
5. Klik Next ke langkah berikutnya. Kemudian pilih field tam- ba-
han yang akan disertakan dalam hasil dissolve ini. Untuk men-
dapatkan informasi luas masing-masing kelas bahaya erosi,
pilihlah Luas_ha by Sum.
131

Gambar 5.21. Kotak dialog GeoProcessing Dissolve feactures
based on an attribute langkah 3.
6. Klik Finish. Perbandingan tampilan theme sebelum dan sete-
lah dilakukan proses Dissolve dapat dilihat pada gambar beri-
kut.

a

b
Gambar 5.22. Tampilan peta sebelum (a), dan sesudah (b) proses
Dissolve.
132
Sementara data atributnya menampilkan jumlah poligon theme
dan luas masing-masing kelas seperti gambar di bawah ini.

Gambar 5.23. Tampilan data atribut setelah proses Dissolve.
5.5 Menggabungkan Beberapa Theme
Jika kita mempunyai beberapa theme yang dibuat atau diproses
secara sendiri-sendiri, kita dapat menggabungkan theme-theme
tersebut menjadi satu kesatuan theme. Pada proses interseksi dan
union dua theme, field-field data atribut dari kedua theme akan
digabungkan pada tabel hasil. Sedangkan pada proses peng-
gabungan beberapa theme, terjadi penggabungan record pada
data atribut hasil.
Di bawah ini, kita akan menggabungkan tiga theme, yaitu
Kecamatan Kuta Utara (Kec_ku.shp), Kecamatan Kuta
(Kec_kuta.shp), dan Kecamatan Kuta Selatan (Kec_ks.shp).
Secara terpisah, ketiga theme tersebut tampak seperti pada
Gambar 5.24.
Prosedur penggabungan beberapa theme adalah:
1. Buka ketiga theme yang akan digabungkan pada view.
2. Ambil menu View Ö GeoProcessing Wizard. Pilih Merge
themes together.

133
a
b
c
Gambar 5.24. Tampilan 3 theme yang akan digabung, (a) Kec_ku.shp,
(b) Kec_kuta.shp, dan (c) Kec_ks.shp.
134

Gambar 5.25. Kotak dialog GeoProcessing Merge themes together lang-
kah 1.
3. Klik Next, kemudian pada langkah 2 pilih ketiga theme yang
akan digabung pada kotak Select at least two theme to merge.
ArcView akan menggunakan salah satu struktur tabel untuk
tabel hasil. Tentukan theme yang struktur tabelnya akan
digunakan pada pilihan Use fields from. Tentukan pula nama
dan lokasi folder tempat penyimpanan hasil penggabungan
theme tersebut pada Specify the output file.

Gambar 5.26. Kotak dialog GeoProcessing Merge themes together lang-
kah 2.
4. Klik Finish. Hasilnya akan terlihat seperti pada gambar beri-
kut.
135

Gambar 5.27. Theme hasil penggabungan dari 3 theme yang terpisah.
Jumlah record atributnya pada tabel hasil penggabungan
merupakan penjumlahan ketiga record atribut theme yang
digabung.
Catatan
Field-field pada hasil penggabungan diambil dari theme yang
ditentukan pada Use fields from. Field yang berbeda pada theme
selain yang ditentukan pada pilihan Use fields from akan tidak
digunakan.
5.6 Menggabungkan Data Attribute MeIaIui
Lokasi Objek
Prosedur ini sama dengan join spasial. Untuk memberikan
gambaran tentang proses penggabungan data atribut berdasarkan
lokasi objek, perhatikan Gambar 5.28.
Penjelasan lebih detail tentang Join Spasial, lihat kembali Bab
‘Mengelola Tabel’.


136

Gambar 5.28. Kotak dialog GeoProcessing Assign data by location.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->