P. 1
Mikrotik

Mikrotik

|Views: 51|Likes:
Published by Rizqi Ramadhan

More info:

Published by: Rizqi Ramadhan on Apr 11, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

04/11/2012

pdf

text

original

Pada OS versi 3 keatas mikrotik menambahkan fitur Layer7 Protocol yang dapat dipergunakan sebagai alternatif untuk pengisian

content. Layer7 -protokol adalah metode untuk mencari pola dalam ICMP / TCP / UDP stream. Atau istilah lainnya regex pattern. Cara kerja L7 adalah mencocokan (mathcer) 10 paket koneksi pertama atau 2KB koneksi pertama dan mencari pola/pattern data yang sesuai dengan yang tersedia. Jika pola ini tidak ditemukan dalam data yang tersedia, matcher tidak memeriksa lebih lanjut. Dan akan dianggap unknown connections. Anda harus mempertimbangkan bahwa banyak koneksi secara signifikan akan meningkatkan penggunaan memori pada RB maupun PC Router anda. Untuk menghindari itu tambahkan regular firewall matchers (pattern) untuk mengurangi jumlah data yang dikirimkan ke layer-7 filter. Layer7 matcher harus melihat kedua arah lalu lintas (masuk dan keluar). Untuk memenuhi persyaratan ini rule l7 harus diatur dalam chain Forward. Jika rule pada chain input / prerouting maka aturan yang sama harus diatur juga dalam chain output / postrouting , jika tidak maka data mungkin dianggap tidak lengkap sehingga pola/pattern dianggap tidak benar /cocok. Contoh penggunaan: Dalam hal ini kita mencari pattern untuk bittorent
/ip firewall layer7-protocol add comment="" name=bittorrent regexp="^(\\x13bittorrent protocol| azver\\x01\$\ |get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet\ /|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"

Tambahkan pada firewall filter protocol yang biasa dipergunakan, ini untuk mengurangi penggunaan memori
/ip firewall filter add action=accept chain=forward comment="" disabled=no port=80 protocol=tcp add action=accept chain=forward comment="" disabled=no port=443 protocol=tcp

Tambahkan matchernya :
add action=accept chain=forward comment="" disabled=no layer7-protocol=\ bittorrent protocol=tcp

Seperti yang dapat anda lihat sebelum rule l7 ditambahkan beberapa rule reguler sehingga mengurangi penggunaan memori. Opsi Layer7 dapat dipergunakan untuk memblok website tertentu atau mebypass aliran paket dari sebuah interface (proxy hit). Scipt untuk layer7 dapat di unduh di sini dan lakukan command import di terminal, seperti mengimport file nice.

. Protokol ini dipergunakan untuk mengirimkan data dari komputer pengirim email ke server email penerima. Istilah POP3 dan SMTP bagi para pengguna email mungkin sudah tidak asing lagi karena ini berhubungan erat dengan jalur lalulintas email yang dikirim maupun yang diterima. yakni protokol yang digunakan untuk mengambil email dari email server. Protokol ini timbul karena desain sistem email yang mengharuskan adanya email server yang menampung sementara sampai surat elektronik diambil oleh penerima yang berhak. SMTP adalah kepanjangan dari Simple Mail Transfer Protocol yang merupakan salah satu protokol yang umum digunakan untuk pengiriman email. Kehadiran email server ini disebabkan kenyataan hanya sebagian kecil dari komputer penerima email yang terus-menerus melakukan koneksi ke jaringan internet. kalau seandainya ingin bandwidth tersebut dibagi sama rata oleh Mikrotik. POP3 adalah kepanjangan dari Post Office Protocol version 3.Mangle merupakan metode bandwidth manajemen. Protokol POP3 dibuat karena desain dari sistem email yang mengharuskan adanya email server yang menampung email untuk sementara sampai email tersebut diambil oleh penerima yang berhak. Tapi jarang dari kita yang tau apa sebenarnya POP3 dan SMTP tersebut.

2. SFQ. Shaper merupakan pengaturan yang bertujuan membatasi kecepatan akses seperti PCQ dan HTB. 3. Untuk menjalankan QoS. sedang untuk virtual interface secara default tidak tersedia. data tidak akan berpengaruh pada paket TCP karena setiap paket yang didrop akan dikirimkan ulang. QoS dapat beroperasi dengan cara drop paket. CIR (Committed Information Rate) kecepatan access yang digaransi. Mikrotik mempunyai mekanisme mengatur bandwidth atara lain: 1. Traffic yang tidak melewati nilai CIR akan selau dikirim. 9. Priority adalah urutan prioritas paket untuk diproses. protokol. BFIFO.Quality of Service (QoS) berarti router harus melakukan prioritas dan mengatur traffik jaringan. Global-total merupakan informasi semua trafik yang keluar dan masuk interface router. Queuing digunakan saat trafik meninggalkan router menuju interfase fisik atau menuju ke interface virtual (global-in. . Jika tidak ada pengaturan queue atau tidak ada kriteria yang terpenuhi maka paket yang melewati interface tersebut mendapatkan kecepatan dan prioritas yang tertinggi. Cara yang digunakan dalam mode ini adalah PFIFO. 10. PCQ. Prioritas yang lebih tinggi diproses lebih dahulu. 5. Global-in queuing dieksekusi setelah mangle dan dstnat. Contention Ratio merupakan rasio kecepatan data yang dibagi kepada pemakai Pengaturan queueing default bisa dilihat di /queue interface. Jika queuing dipasang maka akan membatasi total kecepatan pada kedua arah. Global-out merupakan informasi semua trafik yang keluar dari interface router. Queuing disipline (qdisc) merupakan algoritma yang digunakan untuk mengatur paket didalam queue dan membuang paket tersebut jika tidak ada tempat di dalam queue. 7. Penggunaan burst untuk meningkatkan kecepatan internet access. 2. 8. Queue yang dipasang disini akan mengatur trafik sebelum meninggalkan router. 3. Masing-masing virtual interface tersebut berfungsi sebagai berikut: 1. port. dan global-total). Scheduler adalah pengaturan queue cara ini menggunakan algoritma reschedul dan mendrop paket yang tidak muat didalam queue. Mikrotik mempunyai jenis pengaturan queueing berdasarkan pengaruh aliran paket. Kecepatan proses transfer data berdasar alamat IP. Ada QoS untuk aplikasi jaringan: beberapa istilah yang menjelaskan. RED. 6. QoS tidak hanya sebatas membatasi saja tetapi lebih bertujuan untuk menjaga kualitas. Global–in merupakan informasi semua trafik yang diterima semua interface router sebelum melelui paket filter. global-out. MIR (Maximal Information Rate) kecepatan alir data maksimum yang disediakan. Pembagian traffic secara merata untuk setiap pengguna. subnet. 4.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->