P. 1
Pemrograman Lazarus Pascal Console Visual Database

Pemrograman Lazarus Pascal Console Visual Database

|Views: 276|Likes:
Published by Dodi Yudo Setyawan

More info:

Published by: Dodi Yudo Setyawan on May 04, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

04/21/2015

pdf

text

original

Tutorial Lazarus

Pemrograman Pascal Console, Visual dan Database
Husni, husni.trunojoyo.ac.id, komputasi.wordpress.com

Lazarus adalah sebuah IDE (Integrated Development Environment), lingkungan pengembangan perangkat lunak yang terintegrasi sehingga pembuatan software menjadi RAPID, dapat diselesai dalam waktu singkat. Lazarus bersifat open source, tersedia untuk banyak platform terutama Linux, Windows dan Macintosh. Bahasa pamrograman yang dijadikan landasan dalam Lazarus adalah Pascal. Karena itu, saat pengembangan aplikasi, apa yang disediakan oleh Lazarus terasa sebagaimana yang terdapat di Delphi, IDE Pascal visual yang terkenal di lingkungan Windows. Tampilan awal dari Lazarus diperlihatkan pada gambar 1.

Gambar 1. Tampilan awal dari IDE Lazarus Berikut adalah penjelasan mengenai bagian-bagian yang terdapat dalam Lazarus dan akan sering digunakan dalam pengembangan perangkat lunak: 1. Menu utama dan daftar komponen (Gambar 2)

Gambar 2. Menu utama dan daftar komponen Lazarus 1

Dalam Lazarus. Jendela ini digunakan untuk mengatur perilaku dari suatu kontrol atau komponen yang telah diletakkan di atas suatu Form atau jendela aplikasi yang sedang kita kembangkan. Bagian di sebelah kanan toolbar tadi. Komponen-komponen ini dikelompokkan berdasarkan fungsinya. Menu Run digunakan untuk menjalankan. Menu Project digunakan untuk membuka jendela tertentu untuk mengatur proyek pengembangan software yang sedang dilakukan. Window dan Help terdapat pada Lazarus dan dengan mudah dipahami kegunaan dan cara menggunakannya. Search. menu File. dan anda akan langsung mengetahui kegunaannya. Properti-properti ini dapat diubah pada saat pengembangan memanfaatkan object Inspector atau saat eksekusi program dengan menuliskan perintah-perintah dalam kode program. Pada sisi kiri terdapat sebuah kotak dengan judul Object Inspector. Setiap jenis komponen akan mempunyai properti yang berbeda. Sedangkan akses ke database tersebut dilakukan melalui komponen yang terdapat pada tab Data Accsess. di sebelah kiri. di bawah menu utama adalah daftar komponen yang dapat digunakan untuk membangun aplikasi visual.Menu-menu penting dalam pemanfaatan Lazarus ditampilkan pada bagian paling atas dari jendela Lazarus. Di bawah daftar menu. menyimpan proyek. Form menurupakan komponen paling penting dalam pemrograman visual. Edit. Toolbar ini digunakan untuk membuka proyek. View. Pada tab Standard terdapat komponen-komponen untuk membuat tampilan standard dari jendela aplikasi seperti tombol dan teks. biasanya berjudul Form1. Gambar 3. Tab Data Controls berisi komponen-komponen untuk mengendalikan akses ke suatu database. Pada gambar terlihat beberapa properti yang dimiliki oleh obyek Form1 yang merupakan instance dari komponen Form (Gambar 4). Form utama: Komponen utama sekaligus container bagi komponen lain Di bawah menu utama dan daftar komponen terdapat sebuah jendela. Jendela ini adalah bagian utama dari sebuah aplikasi visual. mentrace atau menghentikan eksekusi program atau proyek. Menu lain yang akan sering digunakan adalah Project dan Run. terdapat beberapa toolbar. setiap program komputer yang dikembangkan dinamakan project. Di atas form inilah diletakkan komponen-komponen lain. 2 . Seperti pada software lain. mengeksekusi proyek dan beberapa hal lain terkait pengerjaan proyek. Letakkan kursor mouse di atasnya.

Kode program ditulis mengikuti aturan dalam bahasa Pascal. Source Editor 3 . Gambar 5.Gambar 4. Object Inspector Bagian lain yang sangat penting adalah Source Editor. Di sinilah programmer menuliskan baris-baris kode program untuk mengatur apa yang harus dilakukan oleh Aplikasi.

pada jendela New. begin x := 10.. Dimana meletakkan kode tersebut? Pada Lazarus telah terdapat sebagian kode yang dibuat otomatis. Masukkan contoh kode program berikut: var x. writeln('Nilai X = '. Jelasnya perhatikan tampikan Source Editor berikut: Gambar 6. writeln('Nilai Y = '. x). x). end. writeln('Hasil kali XY = ' . Pemrograman Pascal Console Pembuatan program Pascal sederhana berbasis console dimulai dengan memilih menu File | New..Pada bagian paling bawah terdapat sebuah jendela Messages. Kode program pascal di dalam Source Editor 4 . y: integer. y := 7. x * y). Tugas kita adalah melengkapinya. Klik OK. pilih Program (di bawah bagian Project). Pada jendela ini akan muncul pesanpesan tertentu saat eksekusi program terutama jika terjadi kesalahan atau error.

Compile program tersebut dengan memilih menu Run | Build atau tekan Ctrl + F9./testpascal”. Berikutnya silakan bukan Console Linux (atau Windows). Pindahkan ke direktori dimana file testpascal di atas disimpan. misalnya dengan nama testpascal. Gambar 8. Hasilnya diperlihatkan pada gambar berikut: Gambar 7. tanpa tanda pentik. 5 . Jalankan program yang telah dibuat tadi dengan menuliskan “. Eksekusi program pascal pada Console Linux Pemrograman Visual Pemrograman Pascal secara visual dimula dengan memilih menu File | New … dan pada jendela New pilih Application (di bawah bagian Project).Simpan program tersebut. Pastikan anda tidak lupa di direktori mana meletakkan file program tersebut. Jendela New untuk menentukan tipe aplikasi yang akan dibangun Akhiri dengan klik OK.

Form1 dengan sebuah komponen Button di atasnya 2.Sebagaimana dijelaskan di awal. Pastikan obyek Button1 terpilih. Hasilnya seperti gambar berikut: Gambar 9. akan diperoleh sebuah form bernama Form1. klik komponen TButton. ubah properti Caption dari Button1 menjadi Keluar. Gambar 10. Di atas form inilah diletakkan beberapa komponen lain yang akan digunakan dalam aplikasi. Sekarang akan kita letakkan 1 buah komponen Button ke atas form dan atur beberapa properti. Pada Object Inspector. Form1 adalah form pertama. Mengubah properti Button1 melalui Object Inspector 6 . Pada tab Standard. Klik Form1 pada posisi dimana obyek Button tersebut akan diletakkan. Pastikan komponen tersebut dalam kondisi terpilih. form berikutnya akan bernama Form2 dan seterusnya atau nama lain jika kita mengubahnya. Caranya adalah: 1.

begin close. Klik dua kali (double click) TombolKeluar sehingga tampil Source Editor. 2. Gambar 12. Simpan proyek ini.” (tanpa tanda petik). 5. Tampilan aplikasi saat eksekusi 7 . ketika pengguna men-klik TombolKeluar maka aplikasi akan tertutup. lengkapnya adalah: procedure TFormUtama. Ubah properti Height menjadi 200 dan Width menjadi 400. Ubah properti Caption menjadi “Program Pertama dengan Lazarus”. Tulis kode “close. Ubah properti Name menjadi TombolKeluar. Tampilan Form1 dan Button1 setelah perubahan beberapa properti Penanganan tampilan dari aplikasi ini dianggap selesai. Berikutnya adalah penulisan kode program untuk TombolKeluar. Kursor mouse langsung pada diletakkan dimana kita harus menuliskan kode program yang diinginkan.3. Pilih obyek Form1:TForm1. Caranya adalah: 1. Saat aplikasi dijalankan.TombolKeluarClick(Sender: TObject). Drag n drop (klik. Masih pada Object Inspector. Eksekusi dengan menekan F9 atau melalui menu Run | Run atau klik Toobar Run. 4. geser dan letakkan di suatu tempat) obyek TombolKeluar di atas FormUtama sesuai dengan kebutuhan. Beri nama Pertama untuk project dan upertama untuk kode program. end. Tampilan dari FormUtama dapat menjadi: Gambar 11. Ubah properti Name menjadi FormUtama.

TDataSource (pada tab Data Access). Pada mesin Linux Ubuntu 10.so. Apa yang dihasilkan? Coba jalankan (F9) dan klik tombol baru tersebut! Silakan memanfaatkan komponen-komponen lain yang disediakan oleh Lazarus.so. coba letakkan komponen tersebut ke atas Form.16.0.Coba klik tombol Keluar. Lazarus menyediakan suatu komponen bersifat siap pakai meskipun perilakunya juga dapat diatur melalui kode program. buat sebuah aplikasi. TDBMemo dan TDBNavigator (ketiganya pada tab Data Controls). Sekarang.. Agar dikenali oleh Lazarus.0.. Seperti sebelumnya. seperti di bawah ini: ln -s libmysqlclient. Hasilnya seperti pada gambar berikut: Gambar 13. Kemudian ubah propertinya Kind menjadi bkClose..so Berikut ini adalah cara mudah membuat aplikasi database sederhana menggunakan Lazarus: 1. Tampilan form saat pengembangan aplikasi 8 .hanya memperkenalkan saja. TDBGrid. TSQLTransaction. baik berbasis Desktop maupun Web memerlukan akses ke database. file library MySQL terdapat di direktori /usr/lib/mysql. TSQLQuery (ketiganya pada tab SQLdb). Harusnya aplikasi tertutup dan selesai. Di dalam direktori tersebut terdapat file libmysqlclient. Di atas form yang ditampilkan. Akses Database MySQL Sangat banyak aplikasi yang dibangun. perlu dibuatkan sebuah link (symbolic) bernama libmysqlclient.04 LTS yang saya gunakan. 2. letakkan komponen TMySQL50Connection. Komponen tersebut adalah TbitBtn yang ada di tab Additional.0 libmysqlclient.. Bagian ini memperlihatkan cara membangun aplikasi database sederhana dengan Lazarus. Lazarus memerlukan library libmysqlclient.so.0. Tutorial singkat ini tidak membahas secara detail.16.so agar dapat membangun koneksi ke server database MySQL.

mengikuti tabel di bawah ini: Obyek Form1 MySQL50Connection1 Properti Caption Database HostName Password Username Transaction Connected Nilai Database dengan Lazarus Dbstbi 127. Pada jendela ini kita dapat menentukan kolom-kolom apa saja dari tabel hasil query (SQL) akan ditampilkan dalam DBGrid1.0. Pilih properti Columns dan klik tanda … Akan ditampikan sebuah jendela Editing DBGrid1.0. Pada jendela ini.3. Pilih obyek DBGrid1. Tampilan aplikasi database saat eksekusi 4. Atur properti dari obyek-obyek tersebut. klik toolbar + 9 .1 abc123 root SQLTransaction1 TRUE MySQL50Connection1 MySQL50Connection1 SELECT * FROM tbberita SQLTransaction1 TRUE SQLQuery1 DataSource1 DataSource1 Berita DataSource1 SQLTransaction1 SQLQuery1 Database Database SQL Transaction Active DataSource1 DBGrid1 DBMemo1 DBNavigator Dataset DataSource DataSource DataField DataSource Gambar 14.

MySQL50Connection1.0.Password := 'abc123'. Demikianlah tutorial singkat pemanfaatan Lazarus untuk pemrograman Console (pascal).Dataset := SQLQuery1. Semoga bermanfaat :) 10 .UpdateMode := upWhereChanged. SQLQuery1.1'. begin MySQL50Connection1. MySQL50Connection1. MySQL50Connection1. 5.Connected := true. Datasource1.DataSource := Datasource1. Klik baris kedua (1 – Title).DataSource := Datasource1.DatabaseName := 'dbstbi'. DBnavigator1. DBMemo1.DataField := Berita.DataSource := Datasource1. MySQL50Connection1.Transaction := SQLTransaction1. Contoh aplikasi database di atas tidak mengharuskan kita menulis kode program sama sekali. Simpan aplikasi ini dan eksekusi (F9). Klik baris pertama (0 – Title).Button1Click(Sender: TObject). DBMemo1. Berikut ini adalah kode program yang dapat digunakan untuk kebutuhan tersebut: procedure TForm1. visual dan aplikasi database. Contoh tampilan dari aplikasi saat dieksekusi diperlihatkan pada gambar 14.Open. DBGrid1. ubah properti DataField menjadi Id.HostName := '127.Transaction := SQLTransaction1. SQLQuery1.sebanyak dua kali (untuk menampilkan 2 kolom).SQL. SQLQuery1. Insya Allah tutorial berikutnya akan mengupas lebih jauh pemrograman database dengan melibatkan banyak penulisan kode program. end. ubah properti DataField menjadi Judul. Dapatkah database diakses melalui kode program? Bukan dengan mengubah langsung properti dari komponen-komponen yang digunakan? Jawabannya tentu DAPAT.Text := 'select * from tbberita'. SQLQuery1.0. MySQL50Connection1.UserName := 'root'.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->